ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE.

Main Area and Open Discussion > Living Room

[SOLVED] Boot problem/s

<< < (4/6) > >>

Default setting for Windows 7 is to make a 100MByte partition (on a spinning hard disk, SSD hard disks use a 350MByte partition for that same purpose) when installing on a unpartitioned disk. But if the disk already contains partitions Windows will use these however it sees fit. Anyway, if your system has such a partition, it becomes essential in the Windows boot procedure.

Not sure what to make of the first partition in your list, as I can't be exactly sure how the boot procedure on your computer was configured.

This is taken from my own system. I added a 120GByte SSD hard disk to an already working PC (disk0). Afterwards I installed Windows fresh on the SSD and as you can see, there is a 350MByte partition (label: 'System Reserved'). This partition must be 'Active'. Depending on what software you use to check the partition structure of your disk, the terms 'Active' and 'Boot' are used to indicate the same thing. The Windows disk manager makes a distinction here, as you can see in the screenshot.

So I am not sure what to make of the 1st partition on your hard disk. Likely when you make the 3rd partition the boot partition your system will start working again.


So I am not sure what to make of the 1st partition on your hard disk. Likely when you make the 3rd partition the boot partition your system will start working again.
-Shades (July 25, 2015, 07:43 PM)
--- End quote ---

I'm pretty sure it's part of the Dell restore crap. Not all of it, obviously, since it's not big enough. IIRC it contains the restore program, accessible through the Windows startup repair process. At least on the one I dealt with, the WIM image was actually stored on the system drive, but hidden so you wouldn't know it was there.

It's still a little fuzzy, but I'm pretty sure all I had to do at that point is set the correct partition to boot (using diskpart obviously), and it was fixed. I do remember for sure that the recovery partition was at the beginning of the drive, just because I had always seen them at the end in the past.

The plot thickens, and not in a good way :-(

I removed the 'boot' flag from the Recovery partition, and added it to the OS partition.

When I boot machine (with nothing connected to it), I get the message:
An operating system wasn't found. Try disconnecting any drives that don't
contain an operating system.
Press Ctrl+Alt+Del to restart.

When I try to boot via Hiren's bootable USB stick, I get the message:
BOOTMGR is missing.
Press Ctrl+Alt+Del to restart.

This is not getting any easier :-/

I *am* able to boot using the System Repair boot USB - looking at the options there, I think command line is the only option to do anything specific. Any suggestions much appreciated.

Note: it is (was) a win 7 machine, only a month old :eye-roll: :-) but it came with a Windows 8 upgrade cd. I dont see the Windows key anywhere on the machine or the disc, but a new install is an option...

I *am* able to boot using the System Recovery boot USB-tomos (July 26, 2015, 03:15 AM)
--- End quote ---

turns out this should have been my first line of recovery :D
I used the first option: "Startup Repair" and it recognised the problem as 'Boot manager missing or corrupt" and IT FIXED IT!!!
 :-* :-* :-*

Note I tried this before - but not using the repair disc - the machine did already start to the Startup Repair window, which was unable to fix the boot manager - it didnt occur to me that the Startup Repair on the boot usb-stick would have any more success.
Or maybe it was now successful because I had changed the OS partition to boot flag.

The boot is definitely different to before, there was a lot of updating on restart:
"Applying update operation xxxx of 105,389 ([filename here])"

As to what exactly happened to cause the problem in the first place, I can only imagine it was a clash between Dell's weird boot & partition management, and Partition Guru not being able to restore it to previous version.

Considering my options now  8)
a) leave well enough alone
b) rip it all out and install a 'normal' Windows 7 (or 8) without a recovery partition
c) try to move the partitions around to a more logical setup (recovery to end)

a) wins for today, but I will seriously consider (b)
I might make a list of lessons learned - but that's another post too

As I'm not sure exactly what went wrong, I cant be 100% sure what fixed it.
All I can say is be afraid of DELL's boot and partition management - be very afraid...
-tomos (July 23, 2015, 02:58 PM)
--- End quote ---

Congratulations.   I have pretty good experience messing with MBR.  But with W8 they changed to this UEFI and GPT jazz.  I understand it had to be changed to accommodate huge storage.  But I don't dare to do anything without a lot of reading in preparation and expendable machines to experiment with.  :)

Plus a lot of bootable utilities that worked for sure on MBR are now suspect.  Can't take anything as a given. 


[0] Message Index

[#] Next page

[*] Previous page

Go to full version