ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE.

Main Area and Open Discussion > General Software Discussion

HDD primary partition not able to resize!

(1/2) > >>

Hello folks, today I tried to restore my Win 7 back up image to my default primary partition. Backup was made by this programme called Acronis True image 2012.
After restore, the Pc didn't boot to desktop.
I checked by using G parted tool ,there it shows 8mb got created.
Remaining 70gb was set as logical partition.
I tried to delete, create and resize both the partition, but they like to stay as it is.

I also tried using the Winxp &Win 7 boot disc.
Winxp to can't merge the two partition. It can however delete and create, but can't merge them both.  Win 7 too can't install on the 70gb partition. It seems it got locked somehow.
I used Winxp disc to go to Recovery mode and entered the fix boot and fix Mbr command ,nothing seems to work.

I can't even backup my files to Ext HDD, since that too doesn't work properly. All I can think is to Nuke the disc and start from scratch.
Pleasesee the snapshot taken.

Any suggestions are welcomed.

Did you run Acronis from Windows or from a boot disc?  I haven't used Acronis but I have used EaseUS ToDo Backup, Macrium Reflect and Paragon Backup.  In all cases when restoring the boot partition you either need a "backup capsule" hidden partition with the restore image, or you boot a disc/usb with the restore program and then restore the image to the boot partition. If you boot to Windows off the HD and run the restore you are trying to restore files that are in use.

I would try not to panic.  You may be able to get the restore image to go on.  I would post on Acronis forum.  Somebody there was likely in the same boat at some point and may know the easiest way to right the ship.

Do you remember if the hard disk had a 100MByte partition as first partition before you attempted to put the image back?

That 100MByte partition contains information your system requires to boot. Windows 7 creates this small partition on a fresh installation on a fresh hard disk or hard disk that has enough unpartitioned space (located at the beginning sectors of the hard disk).

In a few situations Windows 7 (and higher) forgoes the creation of this 100MByte partition. Usually when the hard disk you use is already partitioned to its fullest extend. For example: you have a partitioned disk under XP, but you decide to re-use the partitions created by XP to onstall Windows 7 over it.

So, if you forgot to take that partition into the will get into situations like this.

GParted states your current hard disk situation to be:
- a 8MByte primary partition
- a 298GByte extended partition, that is sub-divided into logical partitions of about 70GByte each
- and 10MByte of unpartitioned space

One of these sub-divided partitions inside the extended partition was likely intended as your system disk. When the BIOS in your PC only supports the old-skool MBR partitioning, you cannot have more than 4 primary partitions. However, if you need/want more partitions, you can use an extended partition and create logical partitions inside it.

From what I see and understand, best thing to do is:
- use GParted to remove the extended partition intended as your Windows partition
- shrink the extended partition to accommodate the rest of the partitions
- remove all the different unpartitioned spaces in front of the extended partition to create one big unpartitioned space
- re-install windows (to recreate the 100MByte partition and the Windows partition) in that unpartitioned space
- overwrite (only!!!) the new Windows partition with the image you have and try if you can boot

You might end up completely re-installing windows 7 anyway. With the 20/20 hindsight you have now, you will agree that for the next time, try if your image works on a spare hard disk first, before you try it on your main disk.

One good thing: f..k-ups like this teach you so much more about these matters than any successful image restoration ever could.

If you managed not to touch the Movies and Stuffs partitions, the data inside these partitions should be safe and available after you restored the image.

@Milesahead : I am using Acronis 2012 bootable Usb created by YUMI creator.Funny I never had a problem of such nature.
I had once such a problem over Secure zone that was created by Acronis 2009, that was a real headache. Ended with few bad sectors, that was that, I won't be using Acronis in near future.
It would be great if you could post a thread in there forum and if possible, could come up with a solution.

@Shades:The 8mb partition is set as Active Primary partition.
I can't resize,  upon deleting and creating again it is locked at 8 mb.I thought of shrinking the extended partition, but I am scared if the files are gone too.
If only I had one Ext HDD with me now,  I would take the long road to re-install Winxp and then restore the image and play with it for a while With different image's I had created before.

I tried to restore my earlier back ups made by Drive Snapshot, which does sector by sector backups : it can only install on the logical drive. The  backup image cannot be restored to the  primary partition which is 7 mb in size.
It can delete and deactivate the active partition, but nothing more.

I see no way,except Nuke the disc.
Any suggestion.


[0] Message Index

[#] Next page

Go to full version