ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE.

Main Area and Open Discussion > General Software Discussion

Does anyone have know why you cannot map a drive letter to an FTP drive

(1/4) > >>

If this setup had worked as described in Windows it would have solved a long running problem with remote access to network resources.  This is the other half of why I needed that utility to change the mapping for a drive letter depending on which network the user was connected to.

Due to the speed (or lack thereof) i had put off even trying until recently.  The service we use for CLOUD storage of these fies has to run a client program to function.  This "client" effectively hides "what is really happening" so the user thinks their files have magically popped up in their cloud storage in seconds.  Naturally they keep loading more till done.  All that really happens is that the title of the file (or maybe not even that) is loaded long before all the data is transmitted so it LOOKS like it is there, but only to the person who just uploaded it.

No one wants to see the REAL speed of a 10MB upload to a cloud drive over a wifi connection running off a cellular router that probably is not even connected to 3G.

Network speed is always going to be a problem but i would rather the Users SAW their file was "in transit" and not THINK that they can shut down their system and forget it.  The others in their group who are patiently waiting for those files to show up in the shared folder eventually complain.  To me of course.  The UPloader swears they saw the file "Go uP" so it must be IT 's fault? 

Windows 8.1 plainly offers the option of creating a "network Place" just like Windows 7. Then adds the extra magic of offering to "View Ftp Site in File Explorer" which THEN offers you "Easy Access"  to "Map as Drive".

Wow.  If only it worked.

Everything works as it should including the user and password verification (which you have to do twice though it doesn't tell you that).  This would  not be quite so bad if it were not for the fact that if you BUY a 3rd party program, ( Like WebDrive )you CAN do it just as easy (or easier) than above.  But only with their help.
No one I have asked seems to know why.  Webdrive sure isn't going to tell me but why would MS put in something that useful and then NOT make it work?   Can't even map a drive letter to MS One Drive as far as I know. :mad:

Anyway, if anyone has a clue as to what the issue is, it would be appreciated. So many people have posted that the thing works when all they are getting is the same old "Network Place" which will not work as a reference point in a database program.  It MUST be on a specific drive letter referenced path.

Not the answer to your question but perhaps a free alternative: ftpuse

The FTPUSE command maps a remote share (FTP server) as a local drive, so you can use the FTP server of your choice as a local hard drive. FTPUSE is a free application which was developed during production of the network backup suite Ferro Backup System, but disks mapped using FTPUSE can be accessed by any application (e.g. Windows Explorer, Total Commander, MS-DOS command shell).
--- End quote ---

Works here under Win8.1 Pro x64.

Thanks and Sorry it doesn't work for me.  And it seems it doesn't for many others as well..  It would have been nice.  I tried it to even thought the explanations of why it worked sounded a but "off?"  
Have you managed to get t to work?  I researched it through StackOverflow and many others and found all kinds of people getting odd problems yet there would always seem to be one or two who got it to work.  You would think they would be the MOST popular program on the market.  

My "pet Peeve" is still with MS in that if they can;t do it why do they tell you how to do it and provide all the prompts just to fail.  This has all the signs of being a disabled capability
 Like something they put in and decided it was a bad idea but too late to get it all back out so they crippled it.  I'm just paranoid in my old age.

But if you have ever tried to map to your own OneDrive, you will get an idea of what I mean.  it is so convoluted that by the time you finally get it to work, it isn't worth it.
I'm going to keep looking on this one.  Maybe try some of the weird settings in FTP use like it says to use a non standard ftp port.
If I find the solution I will be sure to post it here first.

If you could get it to work, you could run your own drop-box.  ELDOS is the company that has something to do with the "trick" to get the network place to show as a network drive letter.
Setting the FTP to a network place is a breeze but i MUST have a REAL drive letter designation.  How did you get by with that DOKAN file System and what is it?
Also what FTP server did you connect to.  That may be my other problem.  Maybe I have to do something at the server end?
If your FTP site is one I can test to, please send me the coordinates.  I have FTPUSE loaded along with netdrive, webdrive and a few orthers.  Webdrive was the ONLY one that worked without a flaw but.. Not Free.

Have you managed to get t to work?-questorfla (November 16, 2014, 01:15 AM)
--- End quote ---

I installed it, it worked ... it was that simple.

UAC did pop up asking if it was OK to install but that was about it.

just to confirm.  What you got was a normal drive letter thn could be accessed just any other.
If you go to a dos cmd prompt, you can type in x: and it open to yout ftp folder.
once there, you can create folders, copy files into them and have no issues doing so.  They upload when sent & download back if pulled.?

For all intents, a Normal Shared Network folder accessed with a drive letter.  If so, i m doing something very wrong.
Please send me the link to dl the copy you got maybe mine was corrupted?
You did not have to  setup  anything odd?, you are using port 21?  On the FTP server, was it remote from your home.
If I still cannot get in to work I will IM your with credentials to access the FTP server at the office here and give you a login to see if you can get into it.
if you can, then Christmas came early!

This is a normal windows 2008R2 Box with IIS setup for FTP.  I can access the shared folder with no problem while on the same local network
That is essential for this to work.  This means people IN the office have the full 1GB data throuput for all access to those files as a normally mapped network drive to letter R:.
when they leave the office to travel or go home as soon as they try to connect to R: the NetSet program i found will switch their mspping to FTP-USE.  Same drive-letter , same files.  Just slower.  When they come back to office, the NetSet program switches them back to the local High Speed drive mapping.  I would be a Real Hero for a change. :)

I still don't know why WINDOWS wont work when it plainly says it will.

Looking forward to the PROOF of the Pudding (Hope it is 180Proof :)) :Thmbsup:


[0] Message Index

[#] Next page

Go to full version