ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE. Software > Mouser's Zone

Error upon installation and when running.



I recently installed Screenshot Captor. Whenever I run the program I get the error, "There is no disk in the drive. Please insert a disk into drive \Device\harddisk2\DR2." It gives me the options of Cancel, Try Again, and Continue. Whatever I hit it will cycle through Hardisk 2-4, and DR2-5. After about 30 clicks or so it will disappear and then allow me to use the program. It will pop up at other times throughout the capture process and again will demand 30 clicks or so before I can continue. I have read about similar issues here but nothing that was pertinent enough.
Also, I noticed that if I change anything in the preferences I see an error saving message pop up at the tray icon, but it goes by too fast.

My system is Windows 7 64 bit. I am the administrator of my PC. I have gone through all of the preference options and tried de-installing and re-installing.

Other than that, wonderful program.


Something must be unusual about your system.. Did you use the installer or the portable version?
Did you copy over an installation (or configuration settings) from another computer?

It sounds like you are saying it installed ok but gives this error when it runs.  The behavior you are describing sounds to me like the problem is that it is trying to save its settings (and the screenshot folder) on a disk that it can't access.

If you have not copied settings from another machine:  Exit Screenshot Captor, then edit the ConfigDir.ini file in the Screenshot Captor install directory and provide it with a legal place where it can store your settings (make sure to remove the // comment characters when you do).

Let us know if it works.


I figured it out. Maybe this will help someone else. I managed to take a snapshot of the save error message using my IPhone. It was saying that it could not create the directories it needed in order to save properly. I opened My Documents folder and created the DonationCoder folder, ScreenshotCaptor subfolder, and Older subfolder.

All errors have disappeared.


Thanks for reporting squeaky.. I wonder why it was not able to create them itself..

My "guess" is for some reason my admin priveledge had changed from Administrator to Debugger. I find that happens at times and my system always acts up when it does. It probably caused an incorrect installation.


[0] Message Index

Go to full version