ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE.

Main Area and Open Discussion > Living Room

[SOLVED] Please Help Me Recover Invisible Files!

(1/2) > >>

Yesterday I was attempting to move a folder containing subfolders which had music files in them. It had a structure like so:

----Lots of files
----Lots of files

After the move operation was completed (using TeraCopy), the "BaseFolder" was created in the new location, but it was empty. I've had similar experiences with TeraCopy in the past (but that's usually with it leaving behind empty folders after performing a move operation) so I went to the "old" location to try the move again, but the BaseFolder was empty there, too!

I was wondering where the files went if they didn't get moved. Surely they weren't just deleted! Alas, I couldn't find the files anywhere on my HDD, so I thought I had lost them. I even ran a checkdisk to see if it could recover them. Long story made shorter, I found that they appear in their old location when viewing the "BaseFolder" in my FTP client. But they don't show up in Windows Explorer (or cmd prompt).

So the files are there! Now the question is how do I make the files show up again like normal files? I already have my PC configured to show "hidden" and "system" files. But they still won't show up for me. Does anyone have any tips or ideas on how to restore the files to their original state?

first step would be making sure your ftp client is really seeing them, and not showing you a cached version of the directory.
if you ask your ftp client to REFRESH the directory (F5?) or you try to actually access a file, does it still show them?

second step, try an alternative file broweser (xyplorer, x^2, etc.)

Definitely not a cached version. This is after multiple reboots. And I pressed F5 just to make sure. They're still there. I can even move them around using my FTP client. But that doesn't make them show up in Windows Explorer in their new location.

I just tried XYplorer and it can't see them either. Unless maybe there's some advanced configuration I'm not aware of (I'm not a regular user of XYplorer).

Try resetting the attributes to remove a possible "hidden" flag that got set. From within the directory try attrib -h *.* or download a copy of unhide.exe from bleeping computer and use that instead. Link here.

If that fails, try booting off a Linux live CD or other rescue disk and see if your files are recoverable from there. I've had to do this on certain rare occasions to get a file back when Windows couldn't see it.

Luck! :Thmbsup:

I'm pretty sure they're not hidden, as I said, I've got my PC configured to show hidden and system files. But I'll try Unhide.

Unhide seems to be processing every file on every drive in my PC... This could take a while...

I suppose I could also try using my FTP client to upload the files somewhere, then re-download them again...

Or Linux LiveCD is a good idea.


[0] Message Index

[#] Next page

Go to full version