ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE.

Main Area and Open Discussion > General Software Discussion

Need help confirming IE bug

<< < (3/3)

... However the fact that it doesn't happen with other lowercase letters i tested, only "i" makes that explanation harder to swallow...
-mouser (June 16, 2014, 02:54 PM)
--- End quote ---

But "I" is a whole word in itself and is always capitalized in a sentence (unlike other single letters). I'm thinking some sort of spell checker thingy is goin' on here...

Edit: thanks for the spell check link. However, the original page where I found the error was XHTML 1.0 Strict - not HTML5. My app will remain XHTML which does not (I believe) include any sort of spell check property for the TEXTAREA element. I'm going to put together another minimal test page that is XHTML 1.0 Strict and run it up the flagpole. Standby...

I've added a new test page that is valid XHTML 1.0 Strict and updated the other page to be valid HTML5 (it was missing a DOCTYPE and char encoding META tag). Here they are:

Test IE10 paste bug (HTML5) 20140616_1400
Test IE10 paste bug (XHTML 1.0 Strict) 20140616_1400

Both exhibit the same pasty-i2I behavior on my Win7Pro64 IE10 box.

Have you confirmed that adding spellcheck="false" to the textarea has no effect on fixing the bug?

I've added two more test pages in HTML5 with spellcheck=true and spellcheck=false:

Test IE10 paste bug (HTML5) 20140616_1400
Test IE10 paste bug (XHTML 1.0 Strict) 20140616_1400
Test IE10 paste bug (HTML5 - spellcheck="false") 20140616_1400
Test IE10 paste bug (HTML5 - spellcheck="true") 20140616_1400

It appears that the problem occurs when the "spellcheck=true" property on the TEXTAREA is set (or not present as this is the default), and compatibility mode is on. It does not occur if compatibility mode is off or if spellcheck=false.

However, the auto-spell correction occurs with the XHTML 1.0 Strict page when compatibility mode is on and this cannot be turned off by the page markup because spellcheck is not a valid XHTML TEXTAREA property.

I'd call that a bug.

And could someone else please verify this? - I'm at my wits end right now (other stressful things going on in real life at the moment...)

Additional: The auto-spellchecking/correction feature can be disabled entirely. Under Win7, uncheck the following checkbox:
IE Menu -> Tools -> Manage add-ons -> Spelling correction -> Enable spelling correction.


[0] Message Index

[*] Previous page

Go to full version