ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE.

Main Area and Open Discussion > Living Room

LastPass - it doesn't work in IE10 under Win8? Yes it does.


I have documented these notes here in case they could be useful or of help to someone else.
A few days ago I got a new (refurbished) Toshiba Satellite L855D laptop, which came installed with Win8 +IE9.
I ran it through numerous Windows Updates, and that got it an up-to-date Win8+IE10.
In the process of setting up Firefox and IE10 to suit my needs, I encountered a problem - LastPass installed and worked fine in Firefox (latest ß version), and installed fine in IE10, but it but repeatedly crashed IE10 when I tried to sign on to LastPass.

I spent quite a bit of time looking for a possible solution on the Internet and in LastPass' knowledge base, but found none.
So I posted a problem ticket in LastPass support:
LastPass repeatedly crashes IE10 as soon as I log in to LastPass - using IE10, Win8. Lastpass is thus unusable in IE10.

Error message:
Microsoft Visual C++ Runtime Library
C:\Program Files\Internet Explorer\iexplore.exe

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

--- End quote ---

LastPass support updated the ticket with this:
Thank you for contacting LastPass Support and we do apologize for the inconvenience it may have caused you.

Please update your Internet Explorer to the current version here:


--- End quote ---

This would have necessitated my upgrading from Win8 to Win8.1, and I wasn't able to do that because of another (apparently common) problem. In any event, I could not see the need to update.
Not happy with this, I posted a comment to the ticket asking LastPass support to confirm whether LastPass supported Win8+IE10.
A deafening silence ensued.

So I did some more fossicking about in Internet forums and eventually came up with several comments that said that:
LastPass does not work in IE10 in Win8 because IE10 starts up in "No Addons" mode (when started from the Start menu). The workaround is to start up IE10 from the cmd box, and then LastPass works correctly in IE10.

--- End quote ---

So, I tried that out, and LastPass worked just fine in IE10.
My feedback to the LastPass ticket:
Case can be closed: I discovered that LastPass does not work in IE10 in Win8 because IE10 starts up in "No Addons" mode. The workaround is to start up IE10 from the cmd box, and then LastPass works a treat in IE10.
Come on - you guys really would/should have known this better than me, so your advice to upgrade to Win8.1 was rubbish.
I used to manage an IT HelpDesk for HP. If someone had made this kind of mistake in my team, they would have been put through a retraining programme.

--- End quote ---

After some fossicking on the Internet, I turned up the explanation and fix for this.
The reason for LastPass or other Addons not working (not being enabled) in IE10 and above is apparently that EPM (Enhanced Protected Mode) is enabled (ON) by default in the browser's preferences, except when it is started in Admin mode - say from the cmd box.

* Enhanced Protected Mode on desktop IE
* How to turn off enhanced protected mode in Internet Explorer 10 or newerSo the fix is to just untick "Enable Enhanced Protection Mode" in the IE Internet Options | Advanced tab.

As strange as it sounds it appears IE 10 only accepts one url one the command line even though it's a "multi-tabbed browser."  This is really poor.  Firefox and derivatives, chromium derivatives, Opera, all accept multiple urls on the command tail.

Not only that but last time I tried it(perhaps with IE 9) if you set it to open new pages in Tabs, then run iexplore.exe url on the command line, it insists on opening the new page in a new window.

The only way to program it is using ActiveX.

^^ "... it insists on opening the new page in a new window." - Yes, I noticed that too.

I've seen bug reports over a year old.  Talk about "you'll do it our way."  They just tell people where the setting is as if it worked.  Oh boy!   :mad:


[0] Message Index

Go to full version