ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE. Software > Screenshot Captor

Can't Download Latest Screemshot Captor


Zirconia Wolf:
(Sorry if this is in the wrong place!)

Okay, so Screenshot Captor has been *bugging* me all day (well, every time I turn on my Laptop) about the new version that was just released, however try as I might I simply cannot get it to download. All I get is an error message about how the "source file could not be read" & a 0KB file in my Download folder. (Attempting to open said file just gets me a warning about the file being corrupted.)

I have tried both the exe & the ZIP versions & it's the same problem for both.

The frustrating thing is that my mother - who also uses Screenshot Captor - downloaded the update on her computer without any problem just this morning. (This rules out Comcast as being the culprit as we live in the same house.)

I have dumped cookies (multiple times) dumped my history files (multiple times) tried two different browsers (FireFox & Chrome) & even tried logging out of my account here & nothing seems to make a difference.

So...any advice? Or is this just "one of those things" that will - hopefully - clear up on its own eventually?

How strange.. It does sound like something that may clear itself up in a day -- so let us know if it is still happening after a day.
You've already tried doing everything I would advise: Trying in different browsers, restarting, checking from another computer.  And I assume that you've already confirmed you can download other files.

The only thing you might try is downloading other programs from our website.. might I suggest Find and Run Robot :)
And see if it's only Screenshot Captor that won't download for you.

Same problem here.  The same happens with FARR.

Tried two different computers and three browsers


[0] Message Index

Go to full version