ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE. Software > Clipboard Help+Spell

Cannot delete single clips

<< < (2/6) > >>

Jesper Hertel:
IainB, I am sorry, I should have told that I already did View | Options | Backup Maintenance | Verify or Repair Database (as well as tried to restart Clipboard Help+Spell) before writing this bug report in the first place. None of it worked. But thanks for the tip!

Here is the CHS statistics:

   Database File: C:\Users\Jesper\Documents\DonationCoder\Clipboard Help+Spell\Database\ClipboardHelpAndSpell
   Temp Directory: C:\Users\Jesper\Documents\DonationCoder\Clipboard Help+Spell\Database\Temp (0)

   Text Clips Added To Database: 4533  (645.57kb)
   Image Clips Added to Database: 23  (548.25kb)
   Items Pasted: 205
This Run
   Text Clips Added To Database: 22  (1.14kb)
   Image Clips Added to Database: 0  (0b)
   Items Pasted: 0
This Run, Total Detected Clipboard Events: 55
   DB Retryable Errors: 0 (0)
   ClipEvents Triggered: 63
   ClipEvents Processed: 55
   ClipEvents TooSoon: 20
   ClipEvents Identical: 11
   ClipEvents Duplicate: 1
   ClipEvents Ignore: 2
   ClipEvents TooBig: 0
   ClipEvents BadFocus: 0
   ClipEvents BadMutex: 0
   ClipEvents IgnoredEvents: 0
   ClipEvents TooFast: 0
   ClipEvents GetUrl: 0
   ClipEvents GetUrlException: 0
   ClipEvents Exception: 0

One strange thing about the "Database File" is that there is no file or folder called "C:\Users\Jesper\Documents\DonationCoder\Clipboard Help+Spell\Database\ClipboardHelpAndSpell" on my computer. But the folder "C:\Users\Jesper\Documents\DonationCoder\Clipboard Help+Spell\Database" is there and contains:

Files (dir)
Temp (dir)

Is that as it should be?

And mouser, the clips are simply in All/Clipboard/Old and All/Clipboard/New. And none of the ones I tried to delete were Favorites.

When I try to delete from the Recycle Bin, I do get the warning that they will be permanently deleted – but still, after saying Yes to that, the clip stays. The "line cursor" ("current record marker") goes to a completely other place in the Recycle Bin, but the clip I wanted to delete was not deleted.

All the clips are written in a grey font, I noticed, which seems a bit odd. I don't remember if that is normal in Clipboard Help+Spell? I would expect just a normal black font... Is that some kind of indication that they cannot be deleted (that they are "greyed out")? But if so, why would I get the warning...

Because of all my special settings and adjustments over the years I don't feel very much like uninstalling Clipboard Help+Spell, deleting all settings, and starting all over with a clean install to see if that helps. But is there perhaps some way to export my settings in text form, so I can easily get them back after such a clean reinstall?

The file names seem fine and shouldn't make a difference.

The grey color just means that the clip is in a child group of the one you are currently in; it shouldn't effect anything.

Let's see.. another question to ask would be to confirm that the clip is really still there even on restart.

SO you try to delete a clip and it stays visible.  If you exit and come back, is it still there?

And can you add new clips?
Can you MOVE clips by dragging and dropping them into different folders?

And what operating system is this?

Jesper Hertel:
The grey color just means that the clip is in a child group of the one you are currently in
--- End quote ---
But how come, then, that no matter what group I switch to, all clips are grey? Even in groups without any children like All/Clipboard/New and All/Clipboard/Old? Well, except for the Quick Paste group, where all clips are blue. I cannot delete from the Quick Paste group either, by the way.

If you exit and come back, is it still there?
--- End quote ---

And can you add new clips?
--- End quote ---

Can you MOVE clips by dragging and dropping them into different folders?
--- End quote ---

And what operating system is this?
--- End quote ---
Windows 7 Home Premium SP1 64 bit.

Jesper Hertel:
I just tried taking a backup of the current database and then restoring the oldest version I have easy access to – a backup from July 11, 2013. Same issue there – and all clips are grey there too. I guess I rarely delete clips from the database, so that must be why I never discovered it before. But I accidentally put a password on the clipboard so I wanted to delete that – that was how I discovered that I couldn't.

Jesper Hertel:
Now I tried restoring miscellaneous backups from 2008 to 2013. Some make Clipboard Help+Spell crash, and in the ones that do not crash, the problem is the same.

I guess I will have to do a reinstall.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version