ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE.

Main Area and Open Discussion > General Software Discussion

Replacing the Control Panel

<< < (5/6) > >>

My brain lacks that filtering mechanism and as a result it collects as much information as I can handle. One side effect of that is an inability to recognize basic problem solving strategies. I simply have to dive in headfirst and work things out as I go. Until I get at least most of the way to the end I literally can't decide which way I'm going.

I compensate by assembling and refining complex systems in my head. At any given time at least 2 or 3 different parts of my brain are analyzing all the data that comes in from completely different perspectives. Once I've figured out the big picture I apply it to the challenge at hand and then use it to formulate a solution. And yes, it's just as complicated as it sounds whether I'm redesigning fundamental features of Windows or picking out which flavor of Linux to put on my file server. That took me about a month BTW.-Vurbal (August 20, 2013, 01:11 PM)
--- End quote ---

Hell, with that description...I think we have the same strategy. I tend to start by overloading with insanely tangential minutia and then letting the project define itself on the fly. :)
-Stoic Joker (August 20, 2013, 05:32 PM)
--- End quote ---

Based on the small sampling of your posts I've read that doesn't surprise me. In fact I'd be willing to bet there are more than a few posters here with some degree of autistic dysfunction and hyper function. The low functioning part of the autistic brain is in the limbic system (particularly the amygdala) which is sort of an advisor to most processes that go on in the brain.

In addition to its significant role in memory, the amygdala is also a sort of regulator for the prefrontal cortex. The prefrontal cortex is responsible for keeping most nervous system signals literally shut off most of the time so you can focus on only a handful of details. The human brain is so underpowered just processing all the information available from your eyes would be like trying to play a DVD on a 20 year old PC.

The prefrontal cortex is also responsible for shutting down purely internal signals so they don't get mixed up with each other. That way when you're taking a math test you don't accidentally write down 2+2=fish. I actually did something similar on a spelling test in 6th grade. I was always naturally gifted at spelling so I typically didn't pay a lot of attention in class. The teacher gave us a word and then used it in a sentence. Some completely different word in the sentence grabbed my attention and I wrote it down instead. On the good side I spelled it right at least.  :D

Those rogue brain functions are also essential to all the things I do well. Since I can't rely on my amygdala to learn like most people do I simply use other parts of my brain - especially the parts that process math and music. Other autistics (I'd bet Steve Wozniak is a textbook example) rely on their visual center. To most people language is mostly an emotional experience. For me it's part secret code and part musical composition. I break all the rules of grammar routinely and really never could keep them straight. But as I tell my daughter (a gifted writer herself), the rules are for people who can't hear the music.

And now for something completely different... or back on topic or whatever.

I think I've tracked down what was causing the problem getting the Windows Features applet to populate. The problem appeared to be related to the process spawning the applet process (optionalfeatures.exe). I decided to use Process Explorer to get to the bottom of it and it turns out the problem is with the program itself. More specifically the problem (or maybe my system's problem) is with the 32-bit version of the EXE.

What's happening (at least today) is the 32-bit version of OptionalFeatures.exe is apparently unable to query the registry for the list of Windows features. I say apparently because the only notable difference I can find in the 2 processes is that SeCreateSymbolicLinkPrivilege is enabled for the 64-bit version but disabled for the 32-bit version. I also know that Registry Reflection was dropped for Windows 7 in favor of Registry Redirection which according to this MSDN page is accomplished via symbolic links.

Of course like any Microsoft documentation, especially dealing with the registry, the explanation just makes things more confusing. It describes registry keys as symbolic links to other registry keys which is either gibberish or a borderline criminal misuse of terminology. Presumably what they're actually describing is symbolic links somewhere below the SysWOW64 directory which refer to the registry files under System32.

In fact there don't appear to be junction points of any kind pointing to System32 registry files. That leads me to an alternate conclusion that symlinks to registry files are created on the fly when a 32-bit program accesses the keys in question and then deleted afterward. That would explain why the 32-bit applet with no symlink creation privileges wasn't able to access the necessary keys and why the list of features was never populated. It would be great if someone could definitely confirm or correct my conclusion.

Even if I'm right, though, I'm still confused. In Windows Vista I seem to recall SeCreateSymbolicLinkPrivilege being one of the privileges that UAC stripped when you weren't working in an elevated context. Then in Windows 7 they watered down UAC by whitelisting nearly every OS component so they could elevate silently and be less annoying to users. That's clearly how the 64-bit version maintains that privilege. If I set UAC to the highest setting I do, in fact, get prompted for it. However that's also true for the 32-bit version of the program. It just doesn't happen to inherit that particular privilege from my account.

Except at some point in the past - multiple points in fact - the 32-bit OptionalFeatures.exe worked perfectly for me. I'm sure it worked when I first added it to LBC. Then later I tried it again and it didn't work so I figured I was remembering wrong. I changed the command a little and got it working again, and again it stopped working later so I changed it again. I wouldn't say I fixed it since all I did was remove the .EXE extension. That fixed it again and now it's not working again. I ran the System File Checker to be safe and didn't find any problems. I'm curious to find out if anybody else has this problem or if it's just me.

What I can say is the applet runs just fine when I launch it by GUID using explorer:

--- Code: Text ---explorer.exe shell:::{67718415-c450-4f3c-bf8a-b487642dc39b}
Since explorer is a 64-bit program I know the 64-bit applet will be opened. Now it would be nice to figure out why it matters and especially if it's unique to my computer. If somebody could try running the 32-bit version and let me know what happens that would be great.

Edit: It finally occurred to me to look at some other processes to get an idea about whether SeCreateSymbolicLinkPrivilege is normally enabled or disabled. The general pattern seems to be that I was right about it being enabled by Windows components you would expect to run with elevated privileges like Control Panel applets and the Windows Script Host. However that was also true of the other 32-bit applets I looked at. This definitely looks like an anomaly so now the only question seems to be whether it's the program or my computer that's off.

I am not sure what should happened when I run explorer.exe shell:::{67718415-c450-4f3c-bf8a-b487642dc39b} but I used DOPUS as my explorer replacement and it opens my Desktop (I am running Windows XP SP 3).

I am not sure what should happened when I run explorer.exe shell:::{67718415-c450-4f3c-bf8a-b487642dc39b} but I used DOPUS as my explorer replacement and it opens my Desktop (I am running Windows XP SP 3).
-dluby (August 21, 2013, 09:42 AM)
--- End quote ---
In Vista, it opened the add/remove windows features applet and then sat for ages trying to populate it. I gave up waiting, so I don't know if it would have got there eventually. I can confirm that it doesn't work right in XP -- I have a suspicion that this may only work correctly in at least Vista and possibly Win7.

I am not sure what should happened when I run explorer.exe shell:::{67718415-c450-4f3c-bf8a-b487642dc39b} but I used DOPUS as my explorer replacement and it opens my Desktop (I am running Windows XP SP 3).
-dluby (August 21, 2013, 09:42 AM)
--- End quote ---

GUIDs change from one version of Windows to the next. It's been so long since I used XP I had to Google it myself. I'm pretty sure this is right:

--- ---%windir%\system32\sysocmgr.exe /i:%windir%\inf\sysoc.inf


[0] Message Index

[#] Next page

[*] Previous page

Go to full version