ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE. Software > Screenshot Captor

Screenshot Captor - Blank Capture Problem Solved - Caused by Avast plugin

(1/6) > >>

I upgraded to the latest (4.5?) and had a problem with whenever I select Grab Selected Region (which is usually what I need), I get a white screen and a red crosswire and a grid to the lower left side. If I try and guess where I need to select I hear the shutter sound and the New Screenshot window just shows a white image of nothing.

Thinking it was because of the new version I uninstalled it and reinstalled 4.01. Same problem. I had this before but it seemed to solve itself though I don't know why or how, before upgrading. Can anyone help please. Great application otherwise.

blank captures are due to a security program being an ass:

I turned off the Avast Free AntiVirus Shields Control for 10 minutes (except I could not turn it on again or even open Avast so has to reboot) but before rebooting I was able to capture OK. I can capture a desktop section OK but it seems to be something to do with Firefox. If Firefox (my usual browser) is open I can't capture that, but open another browser and I can capture that one, but only with Firefox minimised to the Taskbar.

I tried making Screenshotcaptor an exclusion in the automatic sandboxing in Avast to no effect. I use Outpost Firewall Free and  settings, under Application Rules, I found Screenshotcaptor and it shows two Avast content filters. I tried turning both off to no effect.

Here are screenshots of Outpost attached

First you could disable Avast and Outpost and see if you still have the problem.
If no problem, then it has to be the settings in Avast or Outpost.
Click allow, as in your 2nd shot, allow or disable protection for screenshotcapture.exe in all the settings you can find.

I disabled the Avast Shields and the capture worked. With Shields on again it didn't. I then turned off Outpost firewall, just using Windows Firewall and it captured OK.

Your suggestion of clicking allow in the rules in my screenshot changed the word to block and changed the colour of the blob in my first screenshot to red, presumably meaning it is now blocked. Still no capture. I tried deleting these rules but as I launched Screenshotcaptor again, Outpost just prompted for action again, remaking the rules, though not both initially. So short of switching off Outpost and using the Windows Firewall, I really don't know.

Amendment: It seems to be an issue with capturing images from Firefox. Chrome and IE8 are both OK.


[0] Message Index

[#] Next page

Go to full version