ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE. Software > Post New Requests Here

Turn a batch file into an AHK script.

<< < (9/16) > >>

The possibility of a clash between rasdial and PPTPchek makes sense because I was using it frequently yesterday to try and track down the server problem I'm having, the majority of the time it worked and there was nothing to indicate why it didn't at times.

I'll test the new version later and let you know.

I have only tested it briefly but the shorter delay in the latest version definitely looks better.
It never got hung up but I need to test it for longer to be certain the problem is solved.

I've now added disconnect commands for both rasdial and the TAP-Win32 Adaptor to my main Internet ON-OFF batch file, cutting out a few more clicks.
I still need to separately shut down any OpenVPN clients I might have running, which I will leave that way.

I have just been switching connections frequently for some time while testing CleanTray, the PPTPcheck icon only hung once and that might not have been due to the program itself.
So it looks like your idea about a clash was most likely right. :)

It's still hanging now and then but I cannot figure out any consistent factor.

It does not appear to be related to how long the connection has been established nor does it seem to be related to how the connection is disabled - just disconnecting the VPN or shutting down the entire internet connection and associated programs.

Sometimes it will work many times without hanging then it will hang several times in a row.

It is still better than having no indication at all.

If I create a shortcut to any PPTP/L2TP VPN, in 'properties' they all show the same 'target':
I cannot find that anywhere, as a device ID, a file name, or a registry key, so what is it?

In Network Connections under 'Device Name' all PPTP/L2TP VPN's show 'WAN Miniport'.
Is there a way to 'trigger' from that instead of rasdial?

It occurred to me that I can overcome the problem of PPTPchek hanging when I am using my main 'Internet Toggle' batch file by adding a command to exit/kill PPTPchek.
But that does not solve the problem if I shut down the VPN on its own, or if the VPN drops out, and PPTPchek hangs.

Just throwing out some passing thoughts.  :)


[0] Message Index

[#] Next page

[*] Previous page

Go to full version