ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE.

DonationCoder.com Software > Find And Run Robot

FARR slow searching/pauses - tips

(1/3) > >>

highend01:
Hi mouser,

I use FARR to scan only three directories:
1.) C:\TBOS\%COMPUTERNAME% (search depth = 1 | file extension = exe)
2.) D:\Tools\.Shortcuts (search depth = 0 | file extension = lnk)
3.) D:\Users\%USERNAME%\Tools\.Shortcuts (search depth = 0 | file extension = lnk)

The first one contains one subfolder with two subfolders underneath which have 2 .exe files.
2. and 3. contain only .lnk files which point to .exe files that are placed in a parent folder structure like
D:\Tools\VLC\vlc.exe
or
D:\Users\%USERNAME%\Tools\XYplorer\XYplorer.exe

Overall there are about 160 .lnk files.

On my system (Win 7 Ultimate x64 SP1 German | Samsung 830 SSD) everything is fine, search results in FARR appear instantly.

I have two other systems with the same operating system and the same ssd (but slower prozessors and less ram) which
behave absolutely different.

Search results need up to 10 seconds before they appear (and FARR is not responding when you click e.g. on the title bar in that time) but the status lines always says that the number of results was returned in 0 (instead of the real amount) of seconds.

These machines use exactly the same FARR setup (like my main machine) and the number of .lnk files are much less (about 40).

I think it must be some problem of icon caching that makes FARR so slow but none of the 3 machines uses a tweak or special (registry) setting that influences the Windows icon cache... Deleting the icon cache and rebuilding it by opening these folders with windows explorer doesn't help and I've changed all settings inside FARR (Incremental search on each keypress, Delay search start based on..., Resolve shortcuts when searching..., Resolve shortcuts when adding..., etc.) that could be related but the problem persists.

Any hints on how to find out what hampers FARR's performance so much on the two other machines?

Regards,
Highend

mouser:
Can you try two things:

1. Tell me if the search is always slow, or is fast if you run it twice in a row.
2. Try the new experimental tweak option on Display Options tab, labeled "Speed up display by avoiding lookup of some icons"; disabled by default.  Enabled if some search results cause a pause in your FARR when displaying them.

highend01:
1. It's fast when I run the same search a second time
2. I don't have this setting ;(

I'm running v2.107.01
and an image of the display options setting screen is attached.

Regards,
Highend

mouser:
highend, can you do a test for me, and tell me if it solves the problem:

1. Redownload the beta and install it.

2. Make sure these options are set as follows:




In addition, these two options are good candidates for causing slowdown:

highend01:
Hi mouser,

Redownloaded again, now I have the "Speed up display..." option :)

I've thought about if there are any major differences between those 3 machines and the most important one is:
The main doesn't use any virus scanner, the other two have Microsoft Security Essentials installed...

So after adding the FARR executable to the process exclusion list... FARR's search results are instant now,
regardless if I change any settings from one of your screenshots ;)

This should have come to my mind earlier, sorry mouser!

Thanks for taking the time to help me out.

Highend

Navigation

[0] Message Index

[#] Next page

Go to full version