ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE. Software > Circle Dock

work around for middle button not working on X64 Win 7 Logitech mouse

(1/9) > >>

Since several versions back I have been having problems with using the middle button to toggle visibility. This is on a Windows 7 64bit computer with an old Logitech mouse. It would work for a short while then stop. Sometimes the reconnect mouse function helped, other times not and required restarting circle dock. I had tried adding modifier keys like shift and ctrl to no avail. I had tried finding different drivers and that didn't help either. I had tried several different macro programs to trigger a keystroke combo on middle mouse and that didn't work.

finally I tried X-mouse Button Control. Its a program that lets you remap mouse buttons to some other function. I have not looked into how it works, but it fixes the problem. I set middle mouse button down to send "ctr shift F7" and it has worked for 2 days without a single hiccup.

I believe this should work with any mouse not just Logitech.

Markham - I read up on X-mouse a little more and found out a little something that may interest you. X-mouse is free, but not open source so I am just going on what I found from the site. According to the site he says he is using  SetWindowsHookEx() to read outputs from the drivers, so it should be hardware agnostic. I think you had said that is what CD uses correct? How much of that code is from VIP verses new that you wrote? Maybe something to dig into for a slightly different implementation under x64 could fix the issue? I am grasping there, without seeing the code. If you like I would be happy to look over the source and research MSDN and other resources some.

Also, as defined here ( ), I have utilized setpoint tools , by Logitech, to compensate....I have been working flawlessly since. I am also on a Windows 7 64bit system

I was wondering if "X-mouse Button Control" would produce similar results.
Thanks for the confirmation  :Thmbsup:

setpoint didn't work for me.

Is it because there is no SetPoint tools available for your mouse, or SetPoint did not correct the issue???
You had mentioned your mouse is "Older" (???)


[0] Message Index

[#] Next page

Go to full version