ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE.

DonationCoder.com Software > T-Clock

T-Clock 2010 (download)

<< < (56/170) > >>

Stoic Joker:
-AMMA (March 30, 2011, 08:55 AM)
--- End quote ---
Ok, here what appear for some different languages in older version:
T-Clock 2010 (download) Eng
T-Clock 2010 (download) Greece

And your version only show english locale(ie. the first one) no matter what other locale i set!
[/quote]

Okay, this is rather interesting. It seems that you have identified a paradigm shift in the project that I've never seen/noticed before. The original TClock, and TClock Lite both have the same behavior in that the Clock's regional language is independent of (and completely ignores) the system.

Where as Two_toNe & I (albeit unwittingly), Use/leverage the system's regional setting (ignoring its-own) to determine the clock's output (see below).


(Now if by chance that ain't actually Greek ...(I've not a clue)... I may be screwed)


So actually the Locale setting on the Time Format tab is a decorative artifact of a configuration that (perhaps was only for Win9x) is no-longer used.

Does that make sense? Or do you think there would be need to have the clocks textural region working independently of the (rest of the OS) Windows shell?

Obviously something must be done, as the non/dysfunctional control could be quite annoying. I'm thinking that (pull the control) shell integration/harmony is the (long term) less confusing option ... But you it seems do use/have a need for this feature. Yes?

I'll hold off on doing anything in either direction until I hear from you.

movrshakr:
Sir, an uncertain observation...

I turned the option ON for 'monitor off on screen lock.'  That worked--screen did go off when locked.  But I had a strange phenomenon occur about 5 times over four days...

I'd be working along and the screen would go dark then come back on on a mouse move.  Two of the times, it went into an off-on-off-on-off-on blink mode.  The period was about 1.5 sec from off to off or on to on.

I have a widget for oneclick shutdown and was able during the ON blinks to eventually move the cursor over that and click a shutdown.

I do not know for sure that Tclock was causing this, but I strongly suspect it. Since turning the option back off yesterday, I have not had the situation reappear.

AMMA:
-AMMA (March 30, 2011, 08:55 AM)
--- End quote ---
Ok, here what appear for some different languages in older version:
T-Clock 2010 (download) Eng
T-Clock 2010 (download) Greece

And your version only show english locale(ie. the first one) no matter what other locale i set!

Okay, this is rather interesting. It seems that you have identified a paradigm shift in the project that I've never seen/noticed before. The original TClock, and TClock Lite both have the same behavior in that the Clock's regional language is independent of (and completely ignores) the system.

Where as Two_toNe & I (albeit unwittingly), Use/leverage the system's regional setting (ignoring its-own) to determine the clock's output (see below).
 (see attachment in previous post)(Now if by chance that ain't actually Greek ...(I've not a clue)... I may be screwed)


So actually the Locale setting on the Time Format tab is a decorative artifact of a configuration that (perhaps was only for Win9x) is no-longer used.

Does that make sense? Or do you think there would be need to have the clocks textural region working independently of the (rest of the OS) Windows shell?

Obviously something must be done, as the non/dysfunctional control could be quite annoying. I'm thinking that (pull the control) shell integration/harmony is the (long term) less confusing option ... But you it seems do use/have a need for this feature. Yes?

I'll hold off on doing anything in either direction until I hear from you.
-Stoic Joker (March 30, 2011, 07:44 PM)
--- End quote ---
When i started using Tclock i didn't have this feature in mind, but after using it i found it more convenient to have months and days names in my local language, since my most usage of these are in my local language and not in english.
Unlike my common usage for my PC; which is in English, so english local is needed for my system.
I hope you get my point.

Stoic Joker:
When i started using Tclock i didn't have this feature in mind, but after using it i found it more convenient to have months and days names in my local language, since my most usage of these are in my local language and not in english.
Unlike my common usage for my PC; which is in English, so english local is needed for my system.
I hope you get my point.-AMMA (April 01, 2011, 03:00 PM)
--- End quote ---

Okay, I think I can work with that. I'm corrently studying multiple versions of the code to see how who toggled what where to flip the default behavior. I'm thinking that the new default is probably best as a default behavior, for most folk ... But I may be able to add a checkbox to enable/disable the language window so both options/behaviors can be accessed.

Sound Fair?

Stoic Joker:
Sir, an uncertain observation...

I turned the option ON for 'monitor off on screen lock.'  That worked--screen did go off when locked.  But I had a strange phenomenon occur about 5 times over four days...-movrshakr (April 01, 2011, 11:32 AM)
--- End quote ---

That sounds like a fairly good sampling size.

I'd be working along and the screen would go dark then come back on on a mouse move.  Two of the times, it went into an off-on-off-on-off-on blink mode.  The period was about 1.5 sec from off to off or on to on.

I have a widget for oneclick shutdown and was able during the ON blinks to eventually move the cursor over that and click a shutdown.

I do not know for sure that Tclock was causing this, but I strongly suspect it. Since turning the option back off yesterday, I have not had the situation reappear.-movrshakr (April 01, 2011, 11:32 AM)
--- End quote ---

That shouldn't be possible (shouldn't...), the monitor off code only fires (once) in response to a Session Lock message that it can only receive from the system. during a Session Change event. Hence the session would have to be in the process of locking to fire the code. Relevant code shown below:
--- Code: C++ ---case WM_WTSSESSION_CHANGE:           switch(wParam) {                case WTS_SESSION_LOCK:                Sleep(500); // Eliminate user's interaction for 500 ms                SendMessage(HWND_BROADCAST, WM_SYSCOMMAND,SC_MONITORPOWER, (LPARAM) 2);                return 0;           }
I'm running it on both of my Windows 7 machines, one I lock frequently, and one I never lock. So far I've seen no ill effects. Granted that doesn't auto-magically mean there isn't any ... But 2 out of 3 ain't my favorite odds. ;)

When it went on/off/on/off did the power light on the monitor (turn orange) react accordingly? If it stayed green/blue/whatever it could be the florescent bulb starting to go in the monitor.

Video card overheating might cause this type of behavior also...but is unlikely without other behavioral indicators.

Leave the feature off for the next week and we'll see what it does. Then if nothing goes awry, re-enable the feature and we'll see if the behavior returns.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version