ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE.

DonationCoder.com Software > N.A.N.Y. 2009

NANY 2009 Release: Trout (audio player)

<< < (64/173) > >>

tomos:
I can. :-D
-Deozaan (March 21, 2009, 08:40 PM)
--- End quote ---

well I have the same behaviour here as in Deo's screenshot

skwire:
@skwire
If you're entertaining this idea, also consider the flip side... A wake-up alarm could be a nice feature as well.
You could set a time, playlist/song/folder, and a wake-up volume that might be different than "normal" listening volume;
Volume settings might even include a gradual rise as not to startle you awake.
-SoggyDog (March 20, 2009, 11:13 AM)
--- End quote ---
Added to the ToDo.

I found another ampersand problem. It won't show up in the tray icon's tooltip.
-Deozaan (March 21, 2009, 08:00 PM)
--- End quote ---
I'm not sure why it displays correctly on my system and not yours but it may have something to do with the fact that my computers are set up with Japanese as the default language.  Unfortunately, I don't believe there is any sort of SS_NOPREFIX for tooltips like there is for text controls.  The SS_NOPREFIX setting is what allows a text control to not interpret the ampersand as an underliner for the immediately following character.  I could probably fix it by doubling-up ampersands in the tooltip strings but that would, most likely, break it for me (and other's systems that currently display it properly).  In other words, this may have to be left as a cosmetic bug.  I'll keep it in my bug tracker, though, in hopes that I come across a universal fix.

Latest build:

v1.0.2 build 251
    + Added an option to autopause after "x" minutes of user idle time.  [Thanks, app103]
    + Added a delete hotkey button to the hotkey options dialog.  [Thanks, drugwash]
    + Added an option to allow single or double-clicking the tray icon to bring the main
      window to the front.  Tools, Optoins, General, System tray section.  [Thanks, brotherS]

Controller:

I found another ampersand problem. It won't show up in the tray icon's tooltip.
-Deozaan (March 21, 2009, 08:00 PM)
--- End quote ---
I'm not sure why it displays correctly on my system and not yours but it may have something to do with the fact that my computers are set up with Japanese as the default language.  Unfortunately, I don't believe there is any sort of SS_NOPREFIX for tooltips like there is for text controls.  The SS_NOPREFIX setting is what allows a text control to not interpret the ampersand as an underliner for the immediately following character.  I could probably fix it by doubling-up ampersands in the tooltip strings but that would, most likely, break it for me (and other's systems that currently display it properly).  In other words, this may have to be left as a cosmetic bug.  I'll keep it in my bug tracker, though, in hopes that I come across a universal fix.

-skwire (March 25, 2009, 04:48 AM)
--- End quote ---

For standart tooltips TTS_NOPREFIX would work, but there is no such option for the systray icon (tooltip), so ampersands wont show there (tested on Windows 95 shell and Windows XP)... the underlining is ment for keyboard accelerators, so I'm not sure why needed for systray icon tooltips :)

SoggyDog:
Also posted on the AHK forums, based on a similar but unrelated request by Drugwash, a possible new feature might be cross-fading between tracks.  Just a suggestion for my new favorite audio player.

Thanks for everything skwire.  I greatly appreciate that you not only consider all the suggestions given to you in the forums, but you actually make many, many, many of those suggestions come to fruition.

You, sir, are a rock star!

apfel:
Got this error with the latest version.
---------------------------
trout.exe
---------------------------
Error: The following variable name contains an illegal character:
"LastFM_FAILED Invalid/Missing Parameter(s)"

The current thread will exit.

   Line#
--->   5468: Last_FM_Auth_Check_Message := %LastFM_tmp%

---------------------------
OK   
---------------------------

--- End quote ---

Just started and enabled Internet Access->Enabled Last.FM checkbox->clicked on username field.
Not a serious "bug"...

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version