ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE. Software > FARR Plugins and Aliases

Fscript trouble

<< < (5/5)

Yes, that will be great.  Please email me at [email protected].

I would need a volunteer that has the issue described above to test several versions of fscript to tell me if the issue began to occur at some version of fscript. zhichao send me a callstack, however the callstack is a bit uninformative, or it is beyond my debugging capacities. It would really help me if we found the version that introduced the issue, if any.

The test consist at downloading fscriptsample and try the previous version of fscript within it. All files are located at :

Here is the callstack for info :

--- ---     FScript.dll!_NMSG_WRITE(int rterrnum=10)  Line 198    C
     FScript.dll!abort()  Line 59 + 0x7 bytes    C
     FScript.dll!terminate()  Line 136    C++
     FScript.dll!__CxxUnhandledExceptionFilter(_EXCEPTION_POINTERS * pPtrs=0x0012ec54)  Line 72    C++
     [Frames below may be incorrect and/or missing, no symbols loaded for kernel32.dll]   
     FScript.dll!_heap_alloc_base(unsigned int size=255)  Line 105 + 0x28 bytes    C

The solution that worked for me was posted here by BenRad.
I had that "Runtime..." error on 3 different PC's running WinXP because of the "FScript.dll" files in the Plugins folder. If I deleted them, there were no errors (the fscript.dll dependent plugins were also inactive).
BenRad's solution worked on all three PC's.
Thanks again!

That seems to fix the problems on my machine.  Very weird dll loading issue :(.  Thanks joby_toss very much for the solution!


[0] Message Index

[*] Previous page

Go to full version