topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • October 14, 2019, 05:54 AM
  • Proudly celebrating 13 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - JeremyWW [ switch to compact view ]

Pages: [1] 2next
1
N.A.N.Y. 2012 / Re: NANY 2012 Release: Ethervane Echo
« on: January 18, 2013, 04:56 AM »
http://www.zhornsoftware.co.uk/stickies/

I can confirm it doesn't work. Stickes seems to be doing something special with its windows - unlike normal application windows, they do not acquire focus when they become "uncovered", and without focus they cannot receive input.

Here's a simple experiment:

  • Start Word. It will have focus.
  • Start Notepad. Word will now lose focus, and you can type in Notepad.
  • Minimize Notepad.
  • Word will now have focus again, you don't have to click it before you can start typing in Word again.

Now if you try the same with Stickes instead of Word, you'll see that in step 4 after you minimize Notepad, you still cannot type in Stickies. You have to click one of the notes first. This is why when Echo tries to paste the clip, Stickies does not "get the message" (figuratively and literally both).


Spell checking while editing simply produces an error pop-up that tells me 'No Spelling dictionaries are available...' On installing EE initially I chose English (UK) and un-ticked the other 2 languages. In the Spellchecker section in Preferences it showed 'Last Language' as being English (US). After using the separate spell-checker installer the Spellchecker section appears as in my screen-shot here - no 'LastLanguage' and no 'DictionaryPath'. Changing the 'DictionaryPath' to "C:\Program Files (x86)\Ethervane\Common\Spell" (which is where the English (UK).adm file is) makes no difference. It still doesn't work, with the same error as above.

The "DictionaryPath" option is only used to add a custom dictionary folder to other folders Echo already checks for dictionaries. It's OK to use it as you did, but it should not be necessary.

Please check if the UK dictionary (English (UK).adm) exists in any of the folders listed in "Database information".  I have attached the UK dictionary to this message. You can unzip it and copy it into that folder, then restart Echo.

One more thing: did you select the UK dictionary in the list, in the editor dialog box? Since originally there were no dictionaries, the "last language" option is empty, and no dictionary is selected by default. If you click the list at the top of the dialog box, the UK dictionary should be listed there. Perhaps all you need to do is to select the dictionary in the list.

In the next release I'll make sure to pick a dictionary automatically if only one is available.



This still isn't working (other than manual method above). Likely to be fixed? New version...??

2
N.A.N.Y. 2012 / Re: NANY 2012 Release: Ethervane Echo
« on: January 18, 2013, 04:04 AM »
One of my favorite features in Ditto is naming clips with quick paste text and searching them using /q.  I am unsure if this feature is already available in Echo but please consider adding it.

Not available yet. I am considering something like it - an ability to assign names or tags to clips - but I need to find a way of implementing it without disturbing the basic design of the app. I've posted some thoughts on it earlier on in this thread, for example here and here.

It's not likely to happen very soon, but it *is* on the wish list.

Any update on a clip naming feature? I would find this massively useful - I have a load of sticky clips, some of them numeric and / or meaningless / easily forgotten. A name / tag would solve this for me.

Thanks.

3
Clipboard Help+Spell / Re: Update Check
« on: January 17, 2013, 06:31 PM »
strange.. i'll look into it -- i may have to send you a debug version to shed light on where things are going wrong with the update check..
Please do. I'm used to testing...

4
Clipboard Help+Spell / Re: Update Check
« on: January 17, 2013, 04:42 PM »
Not in registry.
It will be in your User's Documents folder, under DonationCoder\ClipboardHelpAndSpell.

(unless you are running it portably).
Don't know how I missed that. However, update still does not work. No response when I click 'Check for Updates'. Firewall is off, nothing else to block it. Very, very strange...

5
Clipboard Help+Spell / Re: Update Check
« on: January 17, 2013, 03:47 PM »
Running Vista Home Premium, UAC On, user account, CHS portable in a no-install directory; Ctrl+Alt+Q to bring up clip list; W - Show main Window; Help; Check for updates; result:-

---------------------------
Update Check for: ClipboardHelpAndSpell
---------------------------
ClipboardHelpAndSpell is up to date (v2.16.02).



Update check complete.
---------------------------
OK   
---------------------------



Very odd. Mine is still not working. BTW, where on earth does CH+S keep all it's settings? I've un-installed, deleted remaining folders and re-installed, but it still retains it's settings as I had them! Is there something stashed away in the registry that I need to remove so I can achieve a clean install and test again?

6
Clipboard Help+Spell / Re: [Bug] Menu displaying
« on: January 17, 2013, 05:26 AM »
Strange.. anyone else notice this?
I can reproduce this. Win 7 Pro x64.

7
Clipboard Help+Spell / Update Check
« on: January 17, 2013, 03:58 AM »
Very strange. Since yesterday the update check from CH+S doesn't work at all. Could someone do me a favour and try checking from the Help menu to see if it's just me...?

8
Clipboard Help+Spell / Re: Quick Paste Confusion
« on: January 12, 2013, 06:49 PM »
This is a good question, though a bit tricky and advanced.

The "Quick Paste" group is a "virtual" group, which is created dynamically based on the date of clips.  So it will always show recent clips, even if those clips are in other groups.'

You can't physically remove clips from the "Quick Paste" groups, and if you delete a post shown in "Quick Paste" group it will be deleted from its real/home group.

However, what you can do is CHANGE the rules for the Quick Paste group to tell it to never show clips that are in your Favorites.

Here's how you do that:
  • Show the main window of CHS.
  • Right click on the "Quick Paste" group and select "Edit this Group"
  • In rules, add this to the end:  AND (IsFavorite=false)

Perfect - thanks! I tried to do something similar but got the syntax wrong.

While I've got your attention  :) ... any news on the next version?

9
Clipboard Help+Spell / Quick Paste Confusion
« on: January 12, 2013, 12:40 PM »
I think I'm getting old - or something has changed.

I already have a list of Favorites (none of which appear in the 'Quick Paste' group) which is fine. On the pop-up, I have my Favorites listed and any new clips above that. I've just added a new clip to Favorites which worked fine but it stubbornly stays in the Quick Paste group as well - which I don't want! I now have the same clip duplicated, and if I delete from Quick Paste it also deletes from Favorites. Can I achieve what I want? I did at some point, but can't remember how...

10
Clipboard Help+Spell / Re: Additional actions on last clip
« on: December 05, 2012, 05:02 AM »
Let me chew on the idea.. It's very sensible but not quite as trivial to implement as one might think.
OK. I'm not a programmer so I don't know what would be involved in clearing the text between the () on the pop-up... Hopefully you'll have a 'eureka moment'  :)

Sometime back I recall someone suggesting that there should be a 'one click' option somewhere to clear the clipboard completely, rather than having to open up the main window and delete entries. I was imagining that it could be tied in with that somehow...

11
Screenshot Captor / Re: Can SC capture user defined multiple objects ?
« on: December 04, 2012, 04:27 PM »
Thank you for quick reply.

I know I can capture multiple objects one by one with SC3. But in this mode.
One picture One object. (multiple pictures)
My need:
One picture multiple objects

Ctrl+Click should not end the capture. Ctrl+Click is better to select each object like selecting mutiple files in explorer. "Enter" is the key to end the capture. This is a normal way to capture multiple objects in other software (Faststone Capture)

I agree with your last sentence. There should be an addition key  to select and retain red box mode. I think "ctrl" key is simple and works.



Any hope of implementing this in the new Beta? Thanks.

12
Clipboard Help+Spell / Re: Additional actions on last clip
« on: December 04, 2012, 12:36 PM »
Any comment on this mouser? Might seem picky, but I like things cleared up / deleted when choosing to do so. It's a shared computer so having left overs on the pop-up is undesirable. Thanks.

13
Clipboard Help+Spell / Re: Note naming issue
« on: November 29, 2012, 12:43 PM »
I will add an option to let you customize the title (or set to blank) for manually added notes.
Brilliant. Thanks.

14
Clipboard Help+Spell / Note naming issue
« on: November 29, 2012, 03:42 AM »
Hi,

I choose to have no name for new clips, i.e. I delete and remove the word 'NOTE' from 'Clip Naming' under Options | Clipboard. Unfortunately if I create myself a new clip in the main window it automatically gets named 'NOTE' anyway which also resets the clip naming option above. Can you make that 'no naming' setting stick please - it's irritating and stops me using that otherwise useful 'new clip' function!

Thanks :)

EDIT: In fact, it's worse than I thought. Even if you choose some other string as a default naming method in Options, creating a new clip in the main window still creates a clip with the name 'NOTE' and also overrides the naming setting.

15
Clipboard Help+Spell / Additional actions on last clip
« on: October 29, 2012, 11:46 AM »
Hi,

Even when the 'last clip' and even all clips are deleted the last clip text remains on the 'Additional actions on last clip...' line on the quick paste pop-up. Possible to have that removed when the clip is deleted?

Thanks.

16
NEW BUG (APPARENTLY):

In 'Notes' 'copy clip to clipboard' (toolbar icon) does not appear to work.

Very good, except the above still doesn't function.

17
a brief 8 line letter in Word.

are you sure the 8 lines aren't one "word-wrapped" paragraph?

try this, make a new word document with contents like:
"one
two
three"

and copy that and see if it shows up as multiple lines in the CHS hover hint.

You're right... and I'd figured it out in the mean time :)

Did you see my post above though about 'copy clip to clipboard'?

18
It's not possible in current version, but I'll probably add it later.  Newlines should be preserved -- if the original is one large line, that's what you'll see.

I'm totally confused. I have a brief 8 line letter in Word. I copy the text and it pastes correctly but the preview from the quick paste pop-up is a line of text that wraps when it gets to the screen edge.

19
Clipboard Help+Spell / Re: Clip preview size on pop-up
« on: October 19, 2012, 12:09 PM »
We're talking about on the Quick Paste popup menu right? (Ctrl+Alt+Q hotkey by default).

Yep...

20
NEW BUG (APPARENTLY):

In 'Notes' 'copy clip to clipboard' (toolbar icon) does not appear to work.

21
I'm a little unclear about what you are saying -- you say you can alter the size but you can't?

I'm confused because your original words were '...full excerpt size with new lines preserved'. By that I thought you meant that if I have two lengthy clips with slight differences, say a few lines in, I would be able to tell them apart using the preview on clip hover. I didn't realise that the excerpt was actually still limited. Is it possible to set it to 'unlimited' if desired? Also, new lines are not preserved. The preview on hover is a continuous line of text.

EDIT: Also, could we have the preview stay visible until the mouse is moved, rather than timing out?

22
Clipboard Help+Spell / Re: Clip preview size on pop-up
« on: October 19, 2012, 11:41 AM »
Change the excerpt size to 255 on the Tweak page, and then capture NEW clips.  It won't affect old ones.
Yep. Sorry to mess you about - I got that and replied in the 'beta' thread but I never get a full size excerpt / new lines are not preserved.

23
Next version will have an improvement and option for this, where you can change the maximum excerpt size to 255 (see Tweak tab of options), and hint on clip hover will now show full excerpt size with newlines preserved.

Ok, it seems I can alter the size of the preview between captures, i.e. older clips with the excerpt set to a smaller size will not show at an 'increased size' after changing the setting - you need to 'capture' the same clip again. Also, I never get a full size excerpt and new lines are not being preserved.


24
Clipboard Help+Spell / Re: Clip preview size on pop-up
« on: October 19, 2012, 11:21 AM »
Hmmm...doesn't seem to be working at all. I can't get a full size excerpt and the 'excerpt size' setting doesn't seem to do anything.

25
Clipboard Help+Spell / Re: Clip preview size on pop-up
« on: October 19, 2012, 10:48 AM »
Next version will have an improvement and option for this, where you can change the maximum excerpt size to 255 (see Tweak tab of options), and hint on clip hover will now show full excerpt size with newlines preserved.
Excellent! Thanks.

Pages: [1] 2next