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Introduction
Welcome to the "Help" file for the Kyrathaba's Hangman application!

Welcome

Hello, and welcome!  I'm kyrathaba of www.donationcoder.com, the developer of the Kyrathaba's Hangman application. 
I'm pleased that you chose to download and try out my program.  I hope that you find it enjoyable, and that you choose to
investigate my other programs at some point in time.

Basically, this application is the age-old Hangman game, but with a competitive element: it encourages competition by
allowing players to create registered user-names on an online database.  Then, playing as these registered users, the
high score for any given installation of the program is sent to and recorded on the online database.

Kyrathaba's Hangman presents some bonus puzzle types that are reminiscent of "Wheel of Fortune" fame, i.e., "Same
Name", "Before & After", and others.

The objective is to solve as many consecutive puzzles as possible in one game session (i.e., in one run of the
application).

What's new

The application tracks the highest score achieved using any given install of the program.  It sends that high score to the
online database, which then gets processed by a PHP script and added to the database.

The program has a menu option to view the highest scores achieved by players of this game.

The program can also check for updates of itself online and offer to download them.
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Getting Started
When you download the installer and run it, the installer will first install the application, and will then offer to run it as you
exit the installer.

System requirements

The program should run on any Windows platform that is Windows XP or newer.  You will need to have the most recent
version of the .NET Framework installed.  However, the installer should detect if this is absent, and download it as part of
the program's installation.

The program was developed on a Windows 7 Home Premium OS, running with 4 Gb of RAM.  However, I believe it should
run fine on systems that have at least 256 Mb of memory installed.

Getting help

This help file should provide any help that you need.  However, as it is a work-in-progress, you may send any uncovered
topic or unanswered question to the developer by using one of several "email the developer" interfaces within the
application.  I suggest the email button found under the "About" menu item.  Or, your can click here to email me.

The First Run

The very first time that you run Kyrathaba's Hangman after installing the program, you should see the following dialog
pop up just a second or so after the application finishes loading  :

You should respond "Yes" to this dialogue.  It will take you to this webpage, which gives a few brief words of explanation
and provides a URL linking to the user-name registration page.  

Note: it isn't necessary to register a user-name in order to play the game.  However, it is necessary if you wish the
application to be able to submit your highest score to the online database for bragging rights.

Once you've registered a user-name successfully, you'll see a confirmatory webpage something like the following.  You
should follow the instructions by highlighting the relevant data (as shown) and copying it to the Windows Clipboard:
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Once you've done that, you should click the link below those three lines of text (see below), which will take you to a
webpage explaining what little else you need to know to get started.  

View THIS Url for further instructions...

And that's it.  Read the webpage that this link takes you to.  The material is quite simple.  It only takes a minute to read,
and you're done, and ready to enjoy the program and compete with other people for highest score!

Bonus Puzzles

Every third hangman game will present you with a Bonus Puzzle whose theme is shamelessly stolen from the well-known
television game-show "Wheel Of Fortune".  One of these themes is "Before & After".  In this type of puzzle, the solution
will contain one particular word that connects the first part of the sentence (the Before part) with the last part of the
sentence (the After part).  For example,

What's up dude ranch

The above phrase might be one particular "Before & After" puzzle, where the word "dude" is the connecting word, form a
Before phrase ("What's up dude") with an After phrase ("Dude ranch").

Another bonus theme is "Same Name".  In this type of puzzle, the last word of the puzzle is shared by two separate
words, or two separate groups of words, earlier in the phrase.  Here's an example:

Ellis & Fantasy Island

In the above example, obviously the last word can be paired with both the first and second word, for "Ellis Island" and
"Fantasy Island".  Here's a slightly more complex example:

Great Wall Of & Fine China

In this, the last word can be paired with a word group ("Great Wall Of") and a single word ("Fine") for "Great Wall Of
China" and "Fine China".
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The game also sports these other categories:  Geographic Location or Landmark, Occupation, and Trivia.  Examples of
these are, respectively:

Vatican City
Certified Public Accountant
Everything weighs one percent less at the equator.
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Features

The File Menu

The first item I'll draw your attention to is the File Menu:

Load Puzzle File 

There are three sub-items under the "File" menu.  The first is labeled "Load
Puzzle
File".  The puzzle file is the text file from which the application reads in a
series of Hangman "puzzles" (generally phrases, although they can be single
words).  

Obviously, the application needs such "puzzles" or phrases in-memory before
it can serve up a game of Hangman to the player.  If you do not have the
"Auto-load Default Hangman File" option set, the application will prompt you

to load such a text file manually before it will start a game.

I should also state that the default text file for use with this application is "defaultPuzzles.txt", and resides in the same
directory as the application executable.  This default file has been what I like to call "obfuscated", to make it much more
difficult for anyone to cheat by taking a peek using a text editor.  

You are strongly encouraged not to use text files other than the "defaultPuzzles.txt" file that was designed to work with
this game.  Other text file may cause run-time errors.

As you can see, the obfuscated text appears as gibberish.  I wouldn't
recommend wasting time trying to crack this, either :)   It should be possible
to crack by reverse-engineering the executable to study the MSIL code,
thereby gaining insight into the obfuscation method, and how to reverse it.  I
provide this information since, in my humble estimation, anyone willing to go
to such lengths to learn this particular file's contents is obsessive-compulsive,
and therefore not likely to be a productive or longstanding fan of the application
anyway.

The next menu item you see under the "File" menu is "Import User-name Info".  The proper use of this feature is
demonstrated and explained in the online HTML document referenced at the bottom of "The First Run" topic above (this
link will take you there).

 And finally, of course, the "Exit" menu item that Windows users are accustomed to finding under the "File" menu.  As
you might imagine, this exits the application.  However, if a game is in progress when you attempt to exit, the application
will warn you, and give you the chance to change your mind.

The Options Menu

The "Options" menu has the most sub-menu items of any of the application's six top-level menus:

Created with the Freeware Edition of HelpNDoc: Easily create Help documents

http://kyrathaba.netii.net/appsWithOnlineDB/KyrHangman/import_reg_info.htm
http://kyrathaba.netii.net/appsWithOnlineDB/KyrHangman/import_reg_info.htm
http://www.helpndoc.com


Parse Loaded File For...

The first sub-menu item, as you can see, is "Parse
Loaded File For...", which allows you to select between
"Phrases" and "Individual Words".  By default, the
loaded text file is parsed for phrases.  This should be
the case when you first install the application.  However,
as with all available options, your selection is
"remembered" by the application in between runs of the
program.

If you do choose to have the application parse individual
words, your Hangman game will present you with a
single word, rather than a phrase, to solve.  As the
developer, I recommend that you leave this option set to
"Phrases".  The other option is included only for
completeness sake.

Choose Mask Character

When the application presents a new puzzle, initially all you will see is a placeholder- or mask-character.  These
represent real characters in the puzzle's solution that are masked because you have not yet guessed them.

As you correctly guess characters, these mask characters are replaced by the actual characters in the puzzle's solution
until, finally, the entire puzzle is solved, and no mask characters remain.  

You have three mask characters to choose among: the asterisk *, the ampersand &, and the caret ^ character.  You can't
change mask characters during a game, but can do so in between games.  

Text Box Font Size

You have the option to increase or decrease the default font size of the text that appears in the text box in which the
application shows the un-/fully-/partially-solved puzzle.  The range runs from 8 points to 32 points.  As with other options,
this one will be "remembered" by the application across runs of the program.

Minimum Word Length

If you have selected to parse the loaded text file into individual words, then the "Minimum Word Length" option sets the
minimum length a word has to be before it gets added to the pool of words from which the application will randomly select
a word as your hangman challenge puzzle.

AutoLoad Default Hangman File

This option, when set, will cause the application to automatically load the default hangman text file, "defaultPuzzles.txt",
when a user clicks the "Play" menu, if no text file is currently loaded.  This option should be enabled (i.e., checked) right
after you've installed the application.  However, as with other others, your choice regarding whether to enable or disable
this option will be persisted across program runs.

View Hangman File Statistics

This item is disabled unless a text file is currently loaded.  When clicked, it displays statistics about the currently loaded
text file.  For example, here is a screenshot of the default file's statistics:
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 Note: I've cut-down this screenshot from its full

appearance, which presents even more info

View Existing Local HighScore

This menu item just shows the highest score currently held by anyone using the application on the particular computer on
which it is installed:

View Global HighScore on the WWW

This menu item launches your default Internet browser and points it to the webpage that pulls high-score data from the
online database and presents it in a nice little table:
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View Local Registered User-names

This menu item simply shows the user-names that are currently registered to the online database and available on the
computer on which the copy of the application is running:

Don't Use Audio Cues
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If this menu item is enabled (i.e., checked), then the application will not play the sound files associated with particular
actions/events within the game.  At the time of this writing, there are two: (1) when you win a game, and (2) when you've
just lost a game.  Some players may not want to hear those sounds.  Perhaps they're listening to streaming audio, or are
up past their bedtime and don't want anyone else in the household to hear them playing...

That's it for the "Options" menu.  Pretty simple, straightforward stuff.

The Play Menu

Since the relevant webpage demonstrating use of the "Play" menu item is linked in The File Menu section of this help file,
I don't feel it necessary to go into any lengthy explanation here.  Besides, it's quite self-explanatory.  You click "Play",
and the application responds by presenting you with the dialogs needed to gather what little info it needs prior to setting
up a game for you.

 You can also use the "Start Game" menu
sub-item under the "Game-Related" menu, but
the Play menu provides this same functionality
in one click rather than two.  

Notice that also under the "Game-Related"
menu is the "Game Progress Report" sub-item.

When you click this item, you will get a report of
the progression of games you've battled your
way through during the current session of play. 
An example screenshot is shown below:

Notice the "Unload Current Game" item (the
middle menu sub-item above).

This item is grayed-out when no game is in
progress, to give a visual indication that the
menu item's function cannot be invoked. 
When a game is in progress, this menu
item will appear in the same way as do the
other two items -- black text.

I think that's enough explication to
adequately cover this menu item and its
three sub-items.  If you have any further questions about them, just email me.

TheHelpMenu

The "Help" menu item is the fifth of six top-level menu choices along the top of the main form.  When you click it, you'll be
presented with the custom help dialog I've prepared.  Note the features along the left-hand edge of that form:
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As you can see, at the top of the Help form is a dashing miniature photograph of the
developer.  The email address directly beneath it should adequately suggest to the
moderately sensible that clicking on the image will email the developer.  But if that
weren't enough, hovering over the image will cause the cursor to change to a Hand
cursor, further hinting that the control can be clicked for a useful effect.

Beneath that, you'll see credit given to any beta testers who helped with polishing the
application.  At the time of this revision of the help file, there has only been one such
tester, cranioscopical, but what a tester he has been!  His help has been invaluable.  If
you note any feature that you makes you say, "Cool!  That is slick !", chances are that
he is responsible for suggesting it.

Under the credits to beta-testers you'll find an animated hangman who appears to be
waving his arms and legs jubilantly, completely out of character with his predicament. 
Or perhaps he is writhing in agony?  He's not exactly smiling, after all...

Finally, you see a graphic near the bottom, "F1 Help".  As with the miniature
photograph at the top, when you hover the mouse over "F1 Help", the cursor turns into
a Hand cursor, signaling that clicking it will bring up further help (this very help-file, in
fact).  It should also signal that pressing the F1 key has the same effect (though only
from the main form -- not while the Help or About dialog is visible).

Not pictured here, but easily seen when you run the program and click "Help", centered
at the bottom of the Help dialog is a hyperlink that will, when clicked, launch another
page in your web browser and take you to my little corner of the DonationCoder
website.

There are 600+ lines of text to read in the loaded text-file in this dialog.  Much of it is
revision information, however, and so probably not of interest to the average user,
though developers and DC members may want to peruse it.

TheAboutMenu

Finally, there is the "About" menu, which produces the following:

The items arrayed vertically along the left-hand side of
this form should look familiar to you from the previous
Help topic in this file.  And, indeed, they serve an
identical function.

The four buttons on this form should be rather
self-explanatory, but since the function of a Help file is
to explicate, allow me to briefly comment on each
one.

The Donate button will take you to a donation page
which permits you to donate to this worthy developer
via his PayPal account.  Please be my guest and
experiment with this program feature, trying different
amounts of donations to see if they are submit with
equal ease...

The Credits button simply once again may inadequate
homage to my A+ beta-tester, cranioscopical.

The Update button connects to my website and
checks to see if a more recent version of the program
is available for download.  If there is, the application
then offers to download it.

And, of course, the Email button can be used to send me electronic mail.  Please use it to let me know if you enjoy the
program (or if you don't, I suppose).
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The End
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