Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • September 02, 2015, 09:30:38 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Last post Author Topic: Help needed (again): Miro "destroyed" all my videos!  (Read 13778 times)

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 6,763
    • View Profile
    • Donate to Member
Help needed (again): Miro "destroyed" all my videos!
« on: September 06, 2007, 05:05:09 AM »
Enough talking, reading and writing, now it was time to listen to some good music - and I couldn't!  :(

Yesterday I installed the new version of Miro, but it wouldn't open, so I removed it again, and went to sleep. Today I have come to realize that every common video type has been changed into miro.1, and I am utterly unable to open my 20 GB music videos!! - except for the DivX types. Ohh, am I frustrated right now!

Double-clicking will only open Notebook. Before trying something wild, which could make things even worse, I thought I would come here and ask you what to do. What do you think I should do - except for banging some heads at the Participatory Culture Foundation, the makers of Miro - ? Their FAQ and troubleshooting pages don't tell about this problem. Membership application for the Miro forum seems to be handled manually? I don't know, but I have not yet recieved any clearence. Miro has no dedicated support office, only some "feedback(at)pculture.org".

---
http://www.getmiro.com/ - but be warned...

Dirhael

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 382
    • View Profile
    • defreitas.no
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #1 on: September 06, 2007, 07:35:15 AM »
Well, here's what I would have tried:

- Uninstall Miro. Applications that change extensions in Windows most often leaves a backup copy of said extensions that gets restored when uninstalling.
- Try using the "Default programs" utility in Windows and try setting WMP as the default player for all supported filetypes.
- Try installing a new movie/music player, like KMPlayer, VideoLAN or perhaps GOM Player and let it take over all supported extensions.
- Shift-right-click the filetypes you're having problems with, and change the player under "Open width.."

Should the above fail, you could try to open regedit and under HKEY_CLASSES_ROOT locate the extensions you're having problems with (like .mp3, .mp4, .aac, .mpg etc.). Each of these keys should have at least two string values that are important here:

PerceivedType = Should be either video or audio, depending on the filetype.
Content Type = The files mime type. For instance, AVI files should have video/avi, MP3 should have audio/mpeg etc. Just google <file extension> + mime type and you should have no problems finding the correct ones.

Now this might not work seeing as there are other regkeys affecting this as well, but it could be worth a shot. I know how difficult this can be to fix, as not to long ago some application took over my .exe and .lnk extensions...but I finally got that sorted by taking a look over here :)
Registered nurse by day, hobby programmer by night.

Carol Haynes

  • Waffles for England (patent pending)
  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 7,969
    • View Profile
    • Dales Computer Services
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #2 on: September 06, 2007, 08:00:38 AM »
Have you tried running your usual app manually and telling it to reset all its file type via the Options/Preferences dialogue?

Failing that there is a set of default filetype fixes on http://www.dougknox.com/ you may find something to help in that collection of registry fixers.
« Last Edit: September 06, 2007, 08:04:00 AM by Carol Haynes »

yacht_boy

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 30
    • View Profile
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #3 on: September 06, 2007, 08:31:27 AM »
I happen to know the guys and gals at the PCF and forwarded your note along.  They're a particularly awesome group of people--look for a response of some sort soon.  I've already ribbed them for their cruddy forum management, hopefully they'll fix that soon

Jason

yacht_boy

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 30
    • View Profile
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #4 on: September 06, 2007, 09:57:44 AM »
Got this message from Janet at PCF--I'm reposting here and have told Janet to swing by the forum since I didn't want to post her email addy without permission.

Jason

Jason - I am sorry you have had a bad experience - but I am pretty sure
this is all recoverable.

First - can you right-click on one of your music videos and select the
"Open With..." option.

Then choose the application you were previously using and check the
"Always use the selected program for this kind of file" box.

That should reset the default application for your files.

Then - in order to find out what happened to the Miro installation - can
you please look in your Temp directory (Documents and Settings\<you>\Local
Settings\Temp and send me the Miro.log file.

It is a hidden file so you may have to unhide it.  There are more detailed
instructions on this here.

https://develop.part...racy/wiki/TestingDtv

Email me back and let me know how this goes,

Janet Dragojevic

ps - the approval process is manual for the forums, but it is checked
regularly and is only to prevent spam which was a huge problem on our old
forum.

steeladept

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 1,059
    • View Profile
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #5 on: September 06, 2007, 11:00:02 AM »
Yacht_boy beat me to it, but really all you need to do is reassociate the file types to the correct package.  It is a pain, but not all that uncommon after an uninstall.  Programmers miss things on occasion, and this is one of them.  Another way to do this in XP is to open Explorer (don't know for all those replacements, but I am pretty certain they have a similar feature) and then go to Tools>Folder Options>File Types and browse down to your file extension (.avi for example).  Once there click on the file extention and in the box below, click on the "Change" button by "Opens With:" (It may or may not have an entry there already).  Now just browse to the application executable that you want to open that file type with and it is associated.

This is basically the GUI interface to changing file types in the registry without the chance of screwing up the registry itself.  You still have to be careful to not screw up the file types too much, or program dependencies can get broken; but it won't screw up the registry.

jgpaiva

  • Global Moderator
  • Joined in 2006
  • *****
  • Posts: 4,727
    • View Profile
    • Read more about this member.
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #6 on: September 06, 2007, 11:09:20 AM »
It is quite simple to fix those associations, but i must say it's not right that the program broke all of those.
Also, i've already broke a few things by doing what steeladept mentioned. It's not that what he said isn't incorrect, it is. But if you don't do things the right way, you can get drawn in a sea of trouble.

Personally, i'd go for the "open with" method, and i'd never use any software from PCF. (Although it's pretty good that they took the time to explain how to get things right again  :Thmbsup:)

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 6,763
    • View Profile
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #7 on: September 06, 2007, 11:57:29 AM »
Oh, how I wish I could address you all in Danish!

1) The problem is not the file associations, the problem is the file types.

I can right-click any video file and say "always open with KMP", and KMPLayer will open it and play it well, but that will not change the "perceived" file type; it will still be wrong (miro.1),
-  and the file will still just open Notebook when double-clicked.

I cannot use the answer from "Janet at PCF".

2) I am so far very much afraid that I will have to look further into the answers from Dirhael and steeladept, but I don't like it - "KISS" (Keep It Simple, Stupid), was invented for people like me!

But thanks anyway, all of you.
« Last Edit: September 06, 2007, 11:59:42 AM by Curt »

jgpaiva

  • Global Moderator
  • Joined in 2006
  • *****
  • Posts: 4,727
    • View Profile
    • Read more about this member.
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #8 on: September 06, 2007, 12:13:56 PM »
Curt: you mean it changed the extension of the file from .avi to .miro.1??

Dirhael

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 382
    • View Profile
    • defreitas.no
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #9 on: September 06, 2007, 12:19:35 PM »
Oh, how I wish I could address you all in Danish!

1) The problem is not the file associations, the problem is the file types.

I can right-click any video file and say "always open with KMP", and KMPLayer will open it and play it well, but that will not change the "perceived" file type; it will still be wrong (miro.1),
-  and the file will still just open Notebook when double-clicked.

I cannot use the answer from "Janet at PCF".

2) I am so far very much afraid that I will have to look further into the answers from Dirhael and steeladept, but I don't like it - "KISS" (Keep It Simple, Stupid), was invented for people like me!

But thanks anyway, all of you.

Bare ta det på dansk du, er selv norsk så jeg tror nok det ska gå bra ;)
Registered nurse by day, hobby programmer by night.

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 6,763
    • View Profile
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #10 on: September 06, 2007, 12:22:57 PM »
Hmmm. This may very well all have been because my XP is unstable, but steeladept came the closest without being near:

Quote
open Explorer .. and .. go to Tools>Folder Options>File Types and browse down to your file extension (.avi for example). .. click on the file extention and in the box below, click on the "Change" button by "Opens With:" .. Now just browse to the application executable that you want to open that file type with and it is associated.

- because, I did all that, which steeladept said, only: it didn't help! But then I clicked Reset, and wow!! All file types were changed back to the right types again!

Edit: it would have been a problem if I didn't first changed some file type, because then there would have been no "reset" button! So I actually had to do it this "wrong" way, in order to be able to do it the right way! Now that doesn't sound too sane, does it.

The correct answer may be unknown, but the problem is solved, so who cares!

Thanks a lot, all of you!
« Last Edit: September 06, 2007, 12:26:55 PM by Curt »

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 6,763
    • View Profile
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #11 on: September 06, 2007, 12:32:35 PM »
er selv norsk

Jatak Øjvind  :D

Thanks for being around!  :up:

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 6,763
    • View Profile
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #12 on: September 06, 2007, 12:44:26 PM »
Curt: you mean it changed the extension of the file from .avi to .miro.1??

No, jgpaiva, that was the strange point. The extension was right, but the description was wrong. In the Explorer column "type", any divx video is listed as a "divx video file". Any avi file should be listed "avi file", but was described as a miro.1 type.

But who cares, now, the problem has been solved.

jgpaiva

  • Global Moderator
  • Joined in 2006
  • *****
  • Posts: 4,727
    • View Profile
    • Read more about this member.
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #13 on: September 06, 2007, 01:21:18 PM »
No, jgpaiva, that was the strange point. The extension was right, but the description was wrong. In the Explorer column "type", any divx video is listed as a "divx video file". Any avi file should be listed "avi file", but was described as a miro.1 type.

I see. Ok. Well, i'm glad it's solved, then :P

Dirhael

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 382
    • View Profile
    • defreitas.no
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #14 on: September 06, 2007, 02:34:26 PM »
er selv norsk

Jatak Øjvind  :D

Thanks for being around!  :up:

Hey, how'd you know my name? http://img407.imageshack.us/img407/5530/panicbyzacthetoadzm9.gif
Help needed (again): Miro "destroyed" all my videos!

...it's actually "Øyvind", but very close. Not that it matters though ;)

I did  actually install Miro to see if this would happen to me as well (oh the joys of having installed VMware), but I did not encounter any problems. By the sound of it, I'd guess you somehow came over a random bug in the installer...and that's one of the reasons I never let applications take over my file extensions during installation. Should you want to protect yourself agains problems such as this in the future, you could take a look at installing WinPatrol 2007 or Spyware Terminator and just lock the file extensions until you're done installing. That way, it should be impossible that it could mess up your system this way again :)
Registered nurse by day, hobby programmer by night.

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 6,763
    • View Profile
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #15 on: September 06, 2007, 04:38:45 PM »
Sorry, Dirhael, for publishing your private info. I wasn't thinking too clearly, was I. You revealed your name when you uploaded a screenshot recently, and I remember thinking "with this name he can only be a Norwegian!"  ;)  But I couldn't remember right away in which thread the picture was to be found, so I didn't check up on the proper spelling - sorry again!

-

I have Spyware Terminator running all the time, and I do remember answering  Yes  to the question, to which I now know, I should have answered  No.

For 40 days I was trialing Total Uninstall, but if you install some new programs each day, you - no, not "you" but "me / myself / I", I really get tired of "wasting" all that amount of time - Total Uninstall really is a slow way to keep the PC safe. Anyway, the point being that I didn't purchase a license. But then there are moments, as today, when I regret I did not keep it.

Dirhael

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 382
    • View Profile
    • defreitas.no
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #16 on: September 06, 2007, 05:40:39 PM »
Sorry, Dirhael, for publishing your private info. I wasn't thinking too clearly, was I. You revealed your name when you uploaded a screenshot recently, and I remember thinking "with this name he can only be a Norwegian!"  ;)  But I couldn't remember right away in which thread the picture was to be found, so I didn't check up on the proper spelling - sorry again!

-

I have Spyware Terminator running all the time, and I do remember answering  Yes  to the question, to which I now know, I should have answered  No.

For 40 days I was trialing Total Uninstall, but if you install some new programs each day, you - no, not "you" but "me / myself / I", I really get tired of "wasting" all that amount of time - Total Uninstall really is a slow way to keep the PC safe. Anyway, the point being that I didn't purchase a license. But then there are moments, as today, when I regret I did not keep it.

Haha, don't worry about it :) I publish my name all over the place from time to time, as even though complete anonymity can be desirable in certain situations and places, I think it would make communities such as this (and other mostly friendly sites) less personal than I'd like. Friendly communities is usually a result of its members acting more like one would "in the real world" and less as a bunch of John/Jane Doe's. Wouldn't want this place to end up like this, I've had enough of that on certain other forums ;)

I absolutely agree with you on Total Uninstall and other programs like it. I can see situations where it might be useful, but the problem is that by the time you notice that something is wrong, you most likely wouldn't want to restore your registry and risk break something else.
Registered nurse by day, hobby programmer by night.

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 6,763
    • View Profile
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #17 on: November 15, 2007, 02:02:48 PM »
This is hard for me to believe and just as hard to tell: I have done it again!

Well, not really "me", but Miro. The final version 1.0 is on the street and I just had to give it yet another try. But Miro is still far too sluggish for my weak and unstable XP, so I removed it again after a couple of hours, and Bang, there you have it!: All video file types are again miro.1 !!  :wallbash:

- and this time my "reset-trick " didn't work. The file types are still wrong.

The problem:

When uninstalling Miro 1, it did not change the file types back to what they were before Miro was installed. [Edit: .divx was and is okay because Miro does not change the divx type]

The problem now is not the file associations, but the file types.

The extension is right, but the description is wrong. In the Explorer column type, any .divx video is listed as a divx video file, and any avi file should be listed avi file, but is described as a miro.1 type.

I can right-click any video file and say "always open with X-Player", and X-Player will open it and play it, but that will not change the "perceived" video file type; it will still be wrong (miro.1), (except for .divx)

-  and the video file will just open the text editor when double-clicked.

 :tellme:
... Should the above fail, you could try to open regedit and under HKEY_CLASSES_ROOT locate the extensions you're having problems with (like .mp3, .mp4, .aac, .mpg etc.). Each of these keys should have at least two string values that are important here:

PerceivedType = Should be either video or audio, depending on the filetype.
Content Type = The files mime type. For instance, AVI files should have video/avi, MP3 should have audio/mpeg etc. Just google <file extension> + mime type and you should have no problems finding the correct ones.

Now this might not work ...

In HKEY_CLASSES_ROOT the "problem" seems to be the first key listed, "(Standard)", which Dirhael did not mention. The data in the key named (Standard) is "Miro.1" - but should of course be something different, as I don't have Miro on my machine anymore. Please take a look in your HKEY_CLASSES_ROOT > .avi and tell me exactly what (Standard) says!  :tellme:

HKEY_CLASSES_ROOT > .avi > (Standard) :
(Standard).gif
« Last Edit: November 15, 2007, 02:11:14 PM by Curt »

jgpaiva

  • Global Moderator
  • Joined in 2006
  • *****
  • Posts: 4,727
    • View Profile
    • Read more about this member.
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #18 on: November 15, 2007, 02:09:19 PM »
I'm sorry to know that, curt :(

Here's mine:
Screenshot-07_11_15,20_08_33.png

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 6,763
    • View Profile
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #19 on: November 15, 2007, 02:23:05 PM »
@ jgpaiva, do you use BSPlayer for all the (common) video file types? I suddenly realize that I don't know what the text should say, if I try to change it - as I don't use BSPlayer. Does any of you guys have K-Lite's Media Player Classic as your default player, and care to tell what the text in HKEY_CLASSES_ROOT > .avi > Data > Default is saying?

 :tellme:

Edit: I already know that, don't I. My screenshot is telling the answer: KLCP AVI File

- well, it has been a long and stressfull day. Hope you will forgive me. But of course, I have not yet tried to change the text, so I don't know yet if I am in the clear or not. Talk to you later!
« Last Edit: November 15, 2007, 02:40:50 PM by Curt »

jgpaiva

  • Global Moderator
  • Joined in 2006
  • *****
  • Posts: 4,727
    • View Profile
    • Read more about this member.
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #20 on: November 15, 2007, 02:40:26 PM »
Interestingly.. The program i use for .avi files is not bsplayer, it's media player classic :)

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 6,763
    • View Profile
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #21 on: November 15, 2007, 02:43:50 PM »
I have noticed that MPC (= KLCP) in many situations is very modest. For example extension icons are not always changed when MPC becomes default - sometimes but not always. At least not on my PC.

Dirhael

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 382
    • View Profile
    • defreitas.no
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #22 on: November 15, 2007, 02:48:15 PM »
@ jgpaiva, do you use BSPlayer for all the (common) video file types? I suddenly realize that I don't know what the text should say, if I try to change it - as I don't use BSPlayer. Does any of you guys have K-Lite's Media Player Classic as your default player, and care to tell what the text in HKEY_CLASSES_ROOT > .avi > Data > Default is saying?

 :tellme:

Edit: I already know that, don't I. My screenshot is telling the answer: KLCP AVI File

- well, it has been a long and stressfull day. Hope you will forgive me. But of course, I have not yet tried to change the text, so I don't know yet if I am in the clear or not. Talk to you later!

I didn't have MPC as my default player, but I just set it to be and the default is:
Quote
avifile
(I belive this is the default setting on a clean WinXP installation as well)

I don't want to ruin my DirectShow setup with one of those potentially system-breaking codec packs, so I just downloaded and ran MPC by itself and I don't have any of the "KLCP*" strings in my registry.
Registered nurse by day, hobby programmer by night.

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 6,763
    • View Profile
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #23 on: November 15, 2007, 02:50:50 PM »
Hmm... I now know that it doesn't help to merely change the text in the Data key. The file type is still described as a Miro.1 and will just open up the text editor, when db'clicked. Nothing seems to have changed. I am back in the dark.


Anyone with an opinion on this matter?  :tellme:

Dirhael

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 382
    • View Profile
    • defreitas.no
    • Donate to Member
Re: Help needed (again): Miro "destroyed" all my videos!
« Reply #24 on: November 15, 2007, 03:00:23 PM »
Hmm... I now know that it doesn't help to merely change the text in the Data key. The file type is still described as a Miro.1 and will just open up the text editor, when db'clicked. Nothing seems to have changed. I am back in the dark.


Anyone with an opinion on this matter?  :tellme:

I may have...See the thing is, if you see my previous post, I mentioned that my DEFAULT string under .AVI in the registry referenced another key called AVIFILE. Well, if you locate that one, you should see that it has a string under it called FriendlyTypeName, which by default should have the following value:
Code: [Select]
@C:\WINDOWS\inf\unregmp2.exe,-9905

Well, I checked that file with a resource editor and sure enough, the string from the executable is "Video Clip" just as it should be. This will also hold true for the other filetypes as well, allthough not all of them will have the "FriendlyTypeName" key if they have been changed from the Windows default settings. In such cases I belive you could solve it by either adding said string, or alternatively just change the DEFAULT string under the keys referenced by the extension keys (I don't know if I was able to make myself understood there...).

You will most likely have to reload the registry after doing this though, either by rebooting, log off/on or kill/start explorer.exe
Registered nurse by day, hobby programmer by night.