Welcome Guest.   Make a donation to an author on the site April 25, 2014, 02:23:33 AM  *

Please login or register.
Or did you miss your validation email?


Login with username and password (forgot your password?)
Why not become a lifetime supporting member of the site with a one-time donation of any amount? Your donation entitles you to a ton of additional benefits, including access to exclusive discounts and downloads, the ability to enter monthly free software drawings, and a single non-expiring license key for all of our programs.


You must sign up here before you can post and access some areas of the site. Registration is totally free and confidential.
 
Learn about the DonationCoder.com microdonation system (DonationCredits).
   
   Forum Home   Thread Marks Chat! Downloads Search Login Register  
Pages: [1]   Go Down
  Reply  |  New Topic  |  Print  
Author Topic: Invalid Pointer crash in ScreenshotCaptor 2.93  (Read 1242 times)
TurboJosh
Supporting Member
**
Posts: 9

View Profile Give some DonationCredits to this forum member
« on: July 10, 2011, 08:40:18 PM »

I dont recall having a crash in ScreenshotCaptor before, but I did today.  v2.93. 

I was scrolling down through the list of ClipArt Objects (arrows and such), when it popped up an error dialog, I dont recall the contents, but it was something like an access violation.  I was able to hit OK and continue operating.  But scrolling any more would give the same error.  So I closed ScreenshotCaptor and reopened.  Then I did the same thing and scrolled the clipart down really fast to see if it would crash, and got a "List index out of bounds".

I was able to get a user.dmp from DrWatson (Windows XP) for the crash, and I ran an analysis I'll include at the end of this message.

Then I upgraded to 2.95 and I couldn't immediately reproduce the error.  But since I didnt see anything in the Version History regarding the ClipArt, I wanted to let you know of this malfunction.

Here's the WinDbg analysis:

FAULTING_IP:
ScreenshotCaptor+289a7a
00689a7a 8b7e08          mov     edi,dword ptr [esi+8]

EXCEPTION_RECORD:  ffffffff -- (.exr 0xffffffffffffffff)
ExceptionAddress: 00689a7a (ScreenshotCaptor+0x00289a7a)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 00000000
   Parameter[1]: 00000008
Attempt to read from address 00000008

PROCESS_NAME:  ScreenshotCaptor.exe

ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at "0x%08lx" referenced memory at "0x%08lx". The memory could not be "%s".

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at "0x%08lx" referenced memory at "0x%08lx". The memory could not be "%s".

EXCEPTION_PARAMETER1:  00000000

EXCEPTION_PARAMETER2:  00000008

READ_ADDRESS:  00000008

FOLLOWUP_IP:
ScreenshotCaptor+289a7a
00689a7a 8b7e08          mov     edi,dword ptr [esi+8]

FAULTING_THREAD:  00000928

BUGCHECK_STR:  APPLICATION_FAULT_NULL_CLASS_PTR_DEREFERENCE_NULL_POINTER_READ_INVALID_POINTER_READ

PRIMARY_PROBLEM_CLASS:  NULL_CLASS_PTR_DEREFERENCE

DEFAULT_BUCKET_ID:  NULL_CLASS_PTR_DEREFERENCE

LAST_CONTROL_TRANSFER:  from 00689abc to 00689a7a

STACK_TEXT: 
WARNING: Stack unwind information not available. Following frames may be wrong.
0013fc98 00689abc 03167e01 00688fc4 018f4af8 ScreenshotCaptor+0x289a7a
0013fc9c 03167e01 00688fc4 018f4af8 018f3401 ScreenshotCaptor+0x289abc
0013fca0 00688fc4 018f4af8 018f3401 005072db 0x3167e01
0013fca4 018f4af8 018f3401 005072db 004fad85 ScreenshotCaptor+0x288fc4
0013fca8 018f3401 005072db 004fad85 006dfdd2 0x18f4af8
0013fcac 005072db 004fad85 006dfdd2 00000000 0x18f3401
0013fcb0 004fad85 006dfdd2 00000000 01a03b80 ScreenshotCaptor+0x1072db
0013fcb4 006dfdd2 00000000 01a03b80 0000000b ScreenshotCaptor+0xfad85
0013fcb8 00000000 01a03b80 0000000b 0195dc00 ScreenshotCaptor+0x2dfdd2


STACK_COMMAND:  ~0s; .ecxr ; kb

SYMBOL_STACK_INDEX:  0

SYMBOL_NAME:  ScreenshotCaptor+289a7a

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: ScreenshotCaptor

IMAGE_NAME:  ScreenshotCaptor.exe

DEBUG_FLR_IMAGE_TIMESTAMP:  4d8a07e6

FAILURE_BUCKET_ID:  NULL_CLASS_PTR_DEREFERENCE_c0000005_ScreenshotCaptor.exe!Unknown

BUCKET_ID:  APPLICATION_FAULT_NULL_CLASS_PTR_DEREFERENCE_NULL_POINTER_READ_INVALID_POINTER_READ_ScreenshotCaptor+289a7a

WATSON_STAGEONE_URL:  http://watson.microsoft.c...5/00289a7a.htm?Retriage=1

Followup: MachineOwner
Logged
mouser
First Author
Administrator
*****
Posts: 32,704



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #1 on: July 11, 2011, 03:17:22 AM »

I've never heard a report of an error crash before when messing around with clipart BUT then again i don't think it's a very commonly used feature.
The "List index out of bounds" error usually means some improper attempt to reference an item in the list of files that no longer exists..  I'll play around and see if i can cause it to reoccur -- if it happens to you again let me know.
Logged
Pages: [1]   Go Up
  Reply  |  New Topic  |  Print  
 
Jump to:  
   Forum Home   Thread Marks Chat! Downloads Search Login Register  

DonationCoder.com | About Us
DonationCoder.com Forum | Powered by SMF
[ Page time: 0.034s | Server load: 0.08 ]