Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 10, 2016, 10:16:19 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: FARR Occasional Hangs  (Read 4832 times)

cnewtonne

  • Honorary Member
  • Joined in 2006
  • **
  • default avatar
  • Posts: 117
    • View Profile
    • Donate to Member
FARR Occasional Hangs
« on: February 18, 2007, 09:23:01 AM »
Mouser,
I have been using FARR full day for the last 2 days and it really has not been acting up good.
this is what happens...

- hit alt+z to bring it up
- type any letter (or hit any key e.g. backspace)
- hangs for 30-40 seconds. No disk activity. Can't type or respond to hotkey
- results are showen

Facts...
- same things happens on new searches.
- If I disable incremental searches, I can type but hitting enter would make it hang again.
- disabling/enabling skins made no difference.
- I did not see CPU high usage when it hung.
- Bouncing FARR makes no difference. Still hangs
- I do not see memory usage, IO reads/writes change in taskmgr for FARR

Guesses...
- looks like it is somehow related to the actual search behavior because other operations on FARR are not affected such as getting in/out of options menu, adding aliases, and so forth.
- also it works fine when type an alias. I see the results just fine (no delay)

Any ideas?

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,435
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: FARR Occasional Hangs
« Reply #1 on: February 18, 2007, 09:27:22 AM »
this is version 2 alpha right?

can you explain if this is new behavior or always does this or just recently started doing this.  does it do it every time?

cnewtonne

  • Honorary Member
  • Joined in 2006
  • **
  • default avatar
  • Posts: 117
    • View Profile
    • Donate to Member
Re: FARR Occasional Hangs
« Reply #2 on: February 18, 2007, 09:45:46 AM »
Only saw it last 2 days. I really can not attribute this to any specific event on my machine. I rebooted it and FARR is nice to me now. I will try to observe FARR more closely if this happens again.

On a different subject, however,
is there a way to have FARR run using a higher process priority. Other apps had this as an option.

cnewtonne

  • Honorary Member
  • Joined in 2006
  • **
  • default avatar
  • Posts: 117
    • View Profile
    • Donate to Member
Re: FARR Occasional Hangs
« Reply #3 on: February 18, 2007, 09:46:35 AM »
sorry, this is 20046.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,435
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: FARR Occasional Hangs
« Reply #4 on: February 18, 2007, 09:55:35 AM »
i've never had farr v1 hang on me, but i have once seen the behavior you describe in v2.  i will try to track it down - right now i'm just getting plugins finished so you may have to remind me.  anyone else experienceing this please keep your powder try and let me keep working on v2 before we start a long thread on this.

cnewtonne

  • Honorary Member
  • Joined in 2006
  • **
  • default avatar
  • Posts: 117
    • View Profile
    • Donate to Member
Re: FARR Occasional Hangs
« Reply #5 on: February 18, 2007, 10:29:47 AM »
sorry for the confusion. I'm using v2.00.46.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,435
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: FARR Occasional Hangs
« Reply #6 on: February 19, 2007, 01:20:28 AM »
Quote
is there a way to have FARR run using a higher process priority

Use my Process Tamer program and tell it that you always want FindAndRunRobot.exe to run as high priority.

cnewtonne

  • Honorary Member
  • Joined in 2006
  • **
  • default avatar
  • Posts: 117
    • View Profile
    • Donate to Member
Re: FARR Occasional Hangs
« Reply #7 on: February 19, 2007, 11:09:06 AM »
just did. I thought I can get around the hanging issue by raising FARR's priority. No luck.

cnewtonne

  • Honorary Member
  • Joined in 2006
  • **
  • default avatar
  • Posts: 117
    • View Profile
    • Donate to Member
Re: FARR Occasional Hangs
« Reply #8 on: February 19, 2007, 11:26:07 AM »
Shortly after posting the above I was monkeying around with c:\Program Files\FindAndRunRobot\FindAndRunRobot.ini file, so I shut it down, renamed the ini file, and re-launched. To my surprise, FARR acted as healthy as it could it be. This is what I did...

- FARR was hanging as described above.
- Re-launched FARR several times, no luck.
- Elevated its priority using PT, no luck.
- Shut it down.
- Renamed existing ini file.
- Started it again. NO hangs. It was instantaneously responsive. 
- The bad part, I lost all my settings. I do not know when and how FARR deals with the ini file.

This may give you some leads into where to look.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,435
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: FARR Occasional Hangs
« Reply #9 on: February 19, 2007, 11:49:55 AM »
send me your renamed ini file please - ill see if i can find what went wrong (mouser@donationcoder.com).
its a text file btw so you can open it and make sure you are not sending me anything sensitive.

cnewtonne

  • Honorary Member
  • Joined in 2006
  • **
  • default avatar
  • Posts: 117
    • View Profile
    • Donate to Member
Re: FARR Occasional Hangs
« Reply #10 on: February 19, 2007, 11:55:44 AM »
I can see the it stores my aliases, groups, and search folders. This is what happened...

1- shutdown farr
2- renamed ini file.
3- start farr
4- I do no remember seeing this file recreated.
5- renamed file in step 2 back to original.
6- shutdown farr
7- start farr
9- when I examined ini file, all my aliases and customization were gone.

So the ini file I have now is default. When I checked options, everything was back to default. I'm currently building it back again as it was. If this hang happens again, I will make sure I save a copy in a safe place.


mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,435
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: FARR Occasional Hangs
« Reply #11 on: February 19, 2007, 12:32:18 PM »
in step 6, when you exited, it saved current settings and thus overwrote your old file :('
perhaps it is time for me to have farr save backups.

cnewtonne

  • Honorary Member
  • Joined in 2006
  • **
  • default avatar
  • Posts: 117
    • View Profile
    • Donate to Member
Re: FARR Occasional Hangs
« Reply #12 on: February 22, 2007, 08:05:20 AM »
Just an update. Since my original ini file was overwritten (it was not a big deal), I have not had this hanging issue return. It has been 2 days and FARR is running like a horse shshhshs

cnewtonne

  • Honorary Member
  • Joined in 2006
  • **
  • default avatar
  • Posts: 117
    • View Profile
    • Donate to Member
Re: FARR Occasional Hangs
« Reply #13 on: February 25, 2007, 08:41:57 AM »
Mouser,
FARR 2.00.56 hung again. I noticed the following ...
- it happens everytime I add/edit/remove a number of aliases.
- Issue resolves when removing existing ini and starting with a new one.

I already emailed you the bad ini file.