Welcome Guest.   Make a donation to an author on the site September 21, 2014, 09:15:40 PM  *

Please login or register.
Or did you miss your validation email?


Login with username and password (forgot your password?)
Why not become a lifetime supporting member of the site with a one-time donation of any amount? Your donation entitles you to a ton of additional benefits, including access to exclusive discounts and downloads, the ability to enter monthly free software drawings, and a single non-expiring license key for all of our programs.


You must sign up here before you can post and access some areas of the site. Registration is totally free and confidential.
 
The N.A.N.Y. Challenge 2010! Download 24 custom programs!
   
   Forum Home   Thread Marks Chat! Downloads Search Login Register  
Pages: [1]   Go Down
  Reply  |  New Topic  |  Print  
Author Topic: Screenshot Captor Error Message  (Read 4781 times)
Squiffy
Participant
*
Posts: 4

View Profile Give some DonationCredits to this forum member
« on: February 13, 2007, 03:10:41 AM »

Hi.

I have a problem with ScreenShot Captor, when I start it up I receive error
message:

The work item queue of the TWorkerThreadPool should be empty now,
nut the number of elements were: 4(C:\Libs\BCB6\JAMSoftware\ShellBrowser\BCB6\lib\
ThreadPool.pas,line820)

this message opens up with the program, I click on OK and there are another four underneath
after that the program runs perfect.
This started after I upgraded to the latest version.

Thank you for your help.

Rod.

Logged
mouser
First Author
Administrator
*****
Posts: 33,372



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #1 on: February 13, 2007, 03:49:35 AM »

you're not the only one who's got this.. there seems to be a bug in the third party thumbnail library im using.. i'll try to have an update this week and i hope not too many people have been getting this  mad
Logged
Squiffy
Participant
*
Posts: 4

View Profile Give some DonationCredits to this forum member
« Reply #2 on: February 16, 2007, 06:00:02 AM »

Hi
Any fix for:

The work item queue of the TWorkerThreadPool should be empty now,
nut the number of elements were: 4(C:\Libs\BCB6\JAMSoftware\ShellBrowser\BCB6\lib\
ThreadPool.pas,line820)

When starting "Screenshot Captor"

 Sad
Logged
mouser
First Author
Administrator
*****
Posts: 33,372



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #3 on: February 16, 2007, 07:27:29 AM »

the best advice until i upload a new fix this weekend is to install the previous stable version which should not have this problem: http://www.donationcoder..../old/ScreenshotCaptor.exe

squiffy have you also customized the screenshot directory used by screenshot captor? im trying to figure out why this bug happens to some people and not others.
Logged
Squiffy
Participant
*
Posts: 4

View Profile Give some DonationCredits to this forum member
« Reply #4 on: February 17, 2007, 04:23:18 AM »

Hi

All I have done is install the latest version in C:/program files then dragged some screenshots from
an old version into the new one.

 huh
Logged
mouser
First Author
Administrator
*****
Posts: 33,372



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #5 on: February 17, 2007, 04:31:53 AM »

hopefully i can find a fix for this this weekend.
Logged
Squiffy
Participant
*
Posts: 4

View Profile Give some DonationCredits to this forum member
« Reply #6 on: February 17, 2007, 05:05:36 AM »

Hi

I have installed v2.25.03 in Program Files 2 and dragged over my screenshots ever thing
now works OK, no error messages, I will wait for the new fix.

Thank you for your help.

Rod.

 cheesy
Logged
dluby
Charter Member
***
Posts: 175


see users location on a map View Profile Give some DonationCredits to this forum member
« Reply #7 on: March 06, 2007, 10:10:29 AM »

I'm getting this error now (6th March) and I've been using version 2.30.04 for a good while.
Logged
mouser
First Author
Administrator
*****
Posts: 33,372



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #8 on: March 06, 2007, 01:40:44 PM »

Thank you for reminding me about this - things have been crazy at my house this last 2 weeks but Ive got this coming weekend to catch up and Screenshot Captor definitely needs a new release; I hope some of you suffering from this will be around to help me test the fix.  I promise I will attend to this before next week.
Logged
dluby
Charter Member
***
Posts: 175


see users location on a map View Profile Give some DonationCredits to this forum member
« Reply #9 on: March 06, 2007, 06:02:11 PM »

Hey Mouser, you build it, we'll test it.

Don't you get weekends off?
Logged
cliedwar
Participant
*
Posts: 3

View Profile Give some DonationCredits to this forum member
« Reply #10 on: March 31, 2007, 07:27:00 AM »

I'm having the same (or very similar) issue. When I start Screenshot Captor, I get this error message:

The work item queue of the TWorkerThreadPool should be empty now, nut the number of elements were: 5
(C:\Libs\BCB6\JAMSoftware\ShellBrowser\BCB6\lib\ThreadPool.pas, line 820)

Once I click OK, the error box disappears and another exactly like it pops up. I end up having to click OK on a total of 6 error boxes before I can use the program.

Another curious thing is that the thumbnails on the left side of the program refresh themselves approximately every 5 seconds or so. This makes working with Screenshot Captor almost impossible because when you select any thumbnail other than the most recent one, in five or so seconds it resets itself and the most recently taken thumbnail is active (has focus) again.

This was not happening when I first upgraded to this version, but suddenly this bug appeared.

Possibly useful info:

Screencaptor Version 2.30.04
Windows XP Home Edition Service Pack 2 (build 2600)
3.20 gigahertz Intel Pentium 4
1022 Megabytes Installed Memory
Logged
mouser
First Author
Administrator
*****
Posts: 33,372



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #11 on: March 31, 2007, 08:39:56 AM »

I see i'm a bit behind in fixing this.. I'll try to get a new version out this weekend -- Hopefully you guys/gals can test it and see if i've solved it (hard for me to test if i can't reproduce the bug).
Logged
cliedwar
Participant
*
Posts: 3

View Profile Give some DonationCredits to this forum member
« Reply #12 on: March 31, 2007, 01:03:16 PM »

Hopefully you guys/gals can test it and see if i've solved it (hard for me to test if i can't reproduce the bug).

I'd be happy to test possible fixes and report back. Also, if you have any questions about the specs of my machine or the other software I'm running on it, just let me know.
Logged
mouser
First Author
Administrator
*****
Posts: 33,372



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #13 on: April 02, 2007, 05:20:41 AM »

Can you guys who are experiencing these crazy problems try this beta version (v2.31.01) and let me know if it's any better:
http://www.donationcoder....Beta/ScreenshotCaptor.exe
Logged
dluby
Charter Member
***
Posts: 175


see users location on a map View Profile Give some DonationCredits to this forum member
« Reply #14 on: April 02, 2007, 05:31:12 AM »

Hi Mouser, I only got the error for one day (strange).

I've installed the beta and I'll let you know if I get problems. Is there anything else we should test/look out for in this version?
Logged
cliedwar
Participant
*
Posts: 3

View Profile Give some DonationCredits to this forum member
« Reply #15 on: April 02, 2007, 10:59:53 PM »

mouser,

After upgrading to 2.31.01 the problem seems to have disappeared. I'll let you know if it shows back up. (The last version worked for a while and then suddenly developed the strange behavior.)

Thanks for looking into this for us.  smiley
Logged
mouser
First Author
Administrator
*****
Posts: 33,372



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #16 on: April 02, 2007, 11:05:13 PM »

thank you for this report, i could use some more feedback from others who were having this problem.
Logged
Pages: [1]   Go Up
  Reply  |  New Topic  |  Print  
 
Jump to:  
   Forum Home   Thread Marks Chat! Downloads Search Login Register  

DonationCoder.com | About Us
DonationCoder.com Forum | Powered by SMF
[ Page time: 0.033s | Server load: 0.35 ]