Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 03, 2016, 01:51:21 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Tip of the Day: HowTo Disable AutoPlay in Windows XP (works on removable drives)  (Read 5756 times)

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,405
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Do you hate AutoPlay? I Do.

This little tip will show you how to turn it off.

AutoPlay is one of those things that tries to be smart and figure out what to do when you insert a cd or removable drive.  It will scan the drive (or cd) and run whatever installer is on the cd, or if its a removable usb drive it will pop up a dialog and start scanning the drive to try to guess what you might want to do with the drive.  Guess what? It's my drive, I think I know what i want to do with it thank you very much.  If i want a clippy artificial intelligence on my computer i'll install this.

Ok so if you want to disable autoplay for all or just some drives (or just removable drives), go to theMicrosoft PowerToys for Windows XP Web Page, and find the download for TweakUI on the bottom right.

Once TweakUI is installed, run it and go to the "My Computer -> AutoPlay" section, and there you go, just disable what you dont want, or re-enable it as you wish.

Screenshot - 11_11_2006 , 2_00_00 PM.png



ps.
If you have the opposite problem - you lost your AutoPlay and TweakUI wont fix it for you, try this Microsoft AutoPlay fixer tool.

jgpaiva

  • Global Moderator
  • Joined in 2006
  • *****
  • Posts: 4,727
    • View Profile
    • Donate to Member
Good idea!!
This is most anoying when you have a 250gb external usb disk filled with stuff, and the stupid OS thinks it is a usb drive and takes 2 minutes to check it all for media.
Now following your advice on using teakui :D

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
cool info, mouser. :up:
btw, this can also be done without TweakUI, by going to 'My Computer' then right-click & selecting the 'Properties'. here we can enable/disable auto-play based on the drive and its contents..

autoplay1.png

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,405
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
yep, good point lanux, but this never seems to work for me on my pc with removeable drives, that's why i had to find the tweakui method.

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
yes, i understand, mouser. my info was more like method B, if A wasn't available.. ;-)

MerleOne

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 949
  • 4D thinking
    • View Profile
    • Read more about this member.
    • Donate to Member
I have a problem close to the one with autoplay, also regarding removable drives : I don't want to activate system restore on a set of removables USB drives that always have letter P: and Q: when mounted on my XP Home.  But quite regularly I have to deactivate system restore on them, as if the settings were gone.  The same setting remains stable for non removable drives.

Is there a way, once and for all, to disable system restore for these removable drives.  I don't think TweakUI allows this (it didn't on my old Win98SE system, and caused quite a few other problems...)

Thanks.
.merle1.

direnc

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 5
    • View Profile
    • Donate to Member
Another method to stop autoplay: http://www.llbbl.com...to-disable-autoplay/ it worked really well for me.