Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • September 04, 2015, 08:16:34 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: treeview displays wrong contents after some inserting/moving/deleting  (Read 9626 times)

pencoe

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 18
    • View Profile
    • Donate to Member
When i'm doing some editing about the structure if my launchbar, the shown content of groups becomes wrong.

Example: i have some root level item folowed by some groups. The group contents are not visible ("+" sign in front). Now i add some items to the content above these groups (using context menu). When i'm now opening a group (switching the + sign), the wrong content is displayed. After closing Prefs and reopening, everything is fine again.

Bye, Peter

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,219
    • View Profile
    • Coding Snacks by Lanux128
    • Donate to Member
Re: treeview displays wrong contents after some inserting/moving/deleting
« Reply #1 on: October 11, 2006, 01:39:44 AM »
hi there pencoe,

welcome aboard!
btw, in your case, a screenshot would be nice. it makes things easier to understand.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 35,013
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Donate to Member
Re: treeview displays wrong contents after some inserting/moving/deleting
« Reply #2 on: October 11, 2006, 01:46:11 AM »
i'll see if i can reproduce.. a good clue is that after prefers repoen its ok.

is it just the images that are incorrect or the actual node labels?

pencoe

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 18
    • View Profile
    • Donate to Member
Re: treeview displays wrong contents after some inserting/moving/deleting
« Reply #3 on: October 11, 2006, 05:47:32 AM »
i added two snapshots

as you can see, after inserting two new nodes, the content of the third group is displayed in the first and second group too following the insertion point.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 35,013
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Donate to Member
Re: treeview displays wrong contents after some inserting/moving/deleting
« Reply #4 on: October 11, 2006, 06:21:02 AM »
how strange! ok i'll look into it, you've given me enough to go on i think..
if you feel comfortable doing so (or after editing) it would help me if you sent the .mcf file defining your toolbars (mouser@donationcoder.com), but i'll see if i cant reproduce it without them.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 35,013
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Donate to Member
Re: treeview displays wrong contents after some inserting/moving/deleting
« Reply #5 on: October 12, 2006, 01:49:54 AM »
i've uploaded a beta version here that hopefully fixes the problem:
http://www.donationc...unchBarCommander.exe

please make a backup of your tree before doing too much experimenting (there is a built in backup function in tree config dialog Tools -> Maintenance -> Backup).

pencoe

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 18
    • View Profile
    • Donate to Member
Re: treeview displays wrong contents after some inserting/moving/deleting
« Reply #6 on: October 12, 2006, 02:37:50 AM »
ok, i did some testing with this version: i created a new file, added some groups filled with some commands (see stage1). Then i added step by step three additional entrys above the existing groups (stage2 to stage4)

See yourself in the attached screenshots...

When i delete a node, everything works fine.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 35,013
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Donate to Member
Re: treeview displays wrong contents after some inserting/moving/deleting
« Reply #7 on: October 12, 2006, 02:43:16 AM »
ok so yet something different strange is now happening..   >:(

can you send me your test.mcf so i can work with same file?
(mouser@donationcoder.com)

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 35,013
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Donate to Member
Re: treeview displays wrong contents after some inserting/moving/deleting
« Reply #8 on: October 12, 2006, 03:04:09 AM »
i've confirmed this, no need to send. working on it..

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 35,013
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Donate to Member
Re: treeview displays wrong contents after some inserting/moving/deleting
« Reply #9 on: October 12, 2006, 04:42:51 AM »
ok i think i've got it this time!

http://www.donationc...unchBarCommander.exe

pencoe

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 18
    • View Profile
    • Donate to Member
Re: treeview displays wrong contents after some inserting/moving/deleting
« Reply #10 on: October 12, 2006, 04:51:53 AM »
 Yep, this one seems to solve this problem!  :Thmbsup:

Thank you very much  :-*

BTW: do you sleep sometimes?!?  :)

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 35,013
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Donate to Member
Re: treeview displays wrong contents after some inserting/moving/deleting
« Reply #11 on: October 12, 2006, 04:55:18 AM »
pencoe -
when i have helpful users like you who are willing to test things and report bugs without getting mad, i thank my lucky stars and skip sleep until the bugs are killed :)

well at least usually i try to, sometimes i have to go to sleep in a tent and hide from the bugs :P