topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 13, 2019, 11:39 PM
  • Proudly celebrating 13 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Running ClipBoard Help+Spell block char "|"  (Read 1018 times)

Hilario

  • Supporting Member
  • Joined in 2017
  • **
  • default avatar
  • Posts: 12
    • View Profile
    • Donate to Member
Running ClipBoard Help+Spell block char "|"
« on: November 12, 2019, 05:07 PM »
Hello . I like this software a lot
I have found something is guiving me trouble since I am working in bash shell.
As soon as I start CHS, the char "|" (ALT+124) stop working
As soon as I exit from CHS, the char "|" work again
You can see more info in the screencast

http://bit.ly/32FY9Vv

Thank you for any suggestion.
Regards

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,581
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Running ClipBoard Help+Spell block char "|"
« Reply #1 on: November 12, 2019, 07:28 PM »
Hi Hilario!

Thank you for taking the time to post and making such a clear video showing the problem.  :up:

I'm thinking that it must be that somehow the pipe character has been set as a hotkey in CHS.

There are two places that hotkeys can be set.  The first is the main hotkey tab in the options of CHS:
Screenshot - 11_12_2019 , 7_26_01 PM.png

So look there for the | character set as any of your hotkeys.

Now, if it's not there, there is another place that a hotkey could get set, which is in a GROUP (a node on the left of the folder tree).  But I'm thinking it's probably not that, since that would cause a pop-up menu of the group.

Let us know if that helps solve it!

Hilario

  • Supporting Member
  • Joined in 2017
  • **
  • default avatar
  • Posts: 12
    • View Profile
    • Donate to Member
Re: Running ClipBoard Help+Spell block char "|"
« Reply #2 on: November 13, 2019, 02:37 AM »
Thanks for the fast answer.
It doesn't seam to be hotkeys
https://drive.google...a7KFPLIdvGEOeDA4XNrd

For the GROUP option,, I check the 4 Group Properties (All, Clipboard, Virtual Folders, Recycle Bin)
In all the same situation: Popup Hotkey show "Ninguno"
no "|" anywhere. I am just surprised by the fact to see "Ninguno" which is nothing in spanish instead of reading it in English (by the way this also appear in the hotkeys screen).
https://drive.google...wXoTPC8tSrndgU_pMfyS

What I have detected and can drive us to find something is:
- When I open the Options screen, the problem persist
- When I open the Edit Group Properties, the problem disappear. Then it seams to be very much related to the GROUP aspect.

Not till resolved but I found how to use "|" without stopping CHS ;-)
Thanks







mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,581
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Running ClipBoard Help+Spell block char "|"
« Reply #3 on: November 13, 2019, 07:09 AM »
When I open the Edit Group Properties, the problem disappear. Then it seams to be very much related to the GROUP aspect...

I think this confirms it is hotkey related, since i disable hotkey processing when that group dialog is open.

So it must be a hotkey is set somewhere in CHS causing this problem -- either in the main dialog or in one of the groups.

(But it could be my hotkey component is somehow malfunctioning on a non-english pc..)

I wonder if one of those Ctrl+Alt hotkeys is somehow also catching the | pipe character, OR if the hotkey component is getting confused by the NONE/NINGUNO issue.

Can you try this maybe:
Exit CHS and then using your screenshot in a text editor type all those hotkeys... See if one generates the pipe character.  If so, that is our culprit!


If that fails, maybe clear all of the hotkeys in chs options dialog and see if that fixes it.

Hilario

  • Supporting Member
  • Joined in 2017
  • **
  • default avatar
  • Posts: 12
    • View Profile
    • Donate to Member
Re: Running ClipBoard Help+Spell block char "|"
« Reply #4 on: November 13, 2019, 08:18 AM »
OK. Problem found.
I began changing my language from Spanish to English in case is was a language problem.
Problem persist.
Then I decided to delete hotkeys (even if the problem seams related with groups)
one of my CHS hotkeys was CTRL+ALT+1
I delete this hotkey and it works fine
Then I made some additional tests to understand
In my spanish keyboard there are some keys with special chars which have to be used with ALTGR to access them.
\ |@#~€[{}
If I use any one of this Keys with CTRL+ALT+key in the hotkeys configuration
the ALTGR char stop working with this key.

Must be some kind of relationship that I don't understand but this happend like this.
Regards and thanks for the help.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,581
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Running ClipBoard Help+Spell block char "|"
« Reply #5 on: November 13, 2019, 08:24 AM »
very interesting.. so any hotkey with CTRL+ALT triggers this problem?

Hilario

  • Supporting Member
  • Joined in 2017
  • **
  • default avatar
  • Posts: 12
    • View Profile
    • Donate to Member
Re: Running ClipBoard Help+Spell block char "|"
« Reply #6 on: November 13, 2019, 08:31 AM »
only the keys linked to a AltGr character (\|@#~€[]{})
Those are the problematic chars .. at least on the spanish keyboard
\ key º
| key 1
@ key 2
# key 3
~ key 4
¬ key 6
€ key E
[ key `
] key +
{ key ´
} key ç



mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,581
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Running ClipBoard Help+Spell block char "|"
« Reply #7 on: November 13, 2019, 08:48 AM »
Ah I see..  ok good to know.. if anyone has this problem in the future hopefully they will find this thread.  Thanks for your detective work!