topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • August 24, 2019, 09:42 AM
  • Proudly celebrating 13 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: FARR automatically pops up on Windows 10 [solved]  (Read 926 times)

SaschaM

  • Participant
  • Joined in 2007
  • *
  • Posts: 5
    • View Profile
    • Donate to Member
FARR automatically pops up on Windows 10 [solved]
« on: June 13, 2019, 02:39 AM »
Hi,

on my work laptop running Windows 10 x64 I experience a strange behavior with FARR:

if my computer was either locked or in sleep mode (which also causes locking up) after I log in the FARR search window is shown and can't be closed using the X button. If I use the hotkey to bring up FARR the window gains the focus and when hitting the hotkey again it is hidden again. I changed the memory usage setting from Average to "stay in memory" today and after logging out and in again the Settings dialog was shown instead of the FARR search window, the behavior was the same and the window couldn't be closed using either the OK button nor the window's X button.
It is not a big bug as I know how to handle it but a fix would still be nice, though :-)

SOLUTION:

in my case I had to force FARR to run on the Nvidia graphics card rather than using the internal Intel graphics card.
« Last Edit: June 14, 2019, 07:42 AM by SaschaM, Reason: Problem solved »

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,401
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: FARR automatically pops up on Windows 10
« Reply #1 on: June 13, 2019, 08:26 AM »
Hi Sascha.

It sounds like maybe some weirdness about the FARR window being minimized to the tray, but the system thinking it should show it.. I'm trying to think why that would happen or how to fix it..
There are some infrequently used FARR options in the "Window Options" and "Advanced Visuals" settings tabs.. Maybe you could post screenshots of your settings for these tabs -- they might hold some clues?

Is there anything else unusual about your laptop?  Do you sometimes have an external monitor connected? Is it possible that there is a utility that is thinking FARR was offscreen when the laptop woke up and is thus moving it back to the main monitor?

Anyone else with Win10 having this isssue?

SaschaM

  • Participant
  • Joined in 2007
  • *
  • Posts: 5
    • View Profile
    • Donate to Member
Re: FARR automatically pops up on Windows 10
« Reply #2 on: June 13, 2019, 11:01 AM »
Hi mouser,

thanks a lot for the feedback :Thmbsup:. I can't remember if and which settings I had changed but please find attached the screenshots of the two asked windows. My laptop is connected totwo external monitors, one of the two is configured as Windows' Main Monitor.

Should I perhaps uninstall, remove the configuration files (in case they are preserved and not removed) and reinstall?

Thanks!

2019-06-13 17_55_29-Options.pngFARR automatically pops up on Windows 10 [solved]
2019-06-13 17_55_45-Options.pngFARR automatically pops up on Windows 10 [solved]

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,401
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: FARR automatically pops up on Windows 10
« Reply #3 on: June 13, 2019, 11:08 AM »
Looks like your relevant settings are at the default.

I'm thinking the two-monitor wake from sleep could be the culprit, if one of the monitors wakes up more slowly and windows tries to move FARR from a monitor it thinks is no longer connected.

Could I ask you to try a test where you disconnect the external monitor, and then after using FARR as you normally do, let your laptop go to sleep and then wake up, and see if you still experience the problem?

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,401
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: FARR automatically pops up on Windows 10
« Reply #4 on: June 13, 2019, 11:12 AM »
And just for fun you might try unchecking the box "Show on Taskbar When Active" on the Window Options tab, and the "Do not show icon in tray when minimized" on the Advanced Visuals tab, just to see if they has any effect on the problem.

SaschaM

  • Participant
  • Joined in 2007
  • *
  • Posts: 5
    • View Profile
    • Donate to Member
Re: FARR automatically pops up on Windows 10
« Reply #5 on: June 13, 2019, 01:14 PM »
I'll definitely check this tomorrow when I'm back in the office. I kind of suspect our IT to have installed some software messing up FARR but we'll see about that. Will keep you posted and thanks for the feedback!

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,401
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: FARR automatically pops up on Windows 10
« Reply #6 on: June 13, 2019, 05:18 PM »
Look for a utility -- could be a graphics driver helper utility -- that is designed to move windows back on screen when they are off the boundaries of the screen.  There are a few programs and graphics driver utilities that have the option to do this.

SaschaM

  • Participant
  • Joined in 2007
  • *
  • Posts: 5
    • View Profile
    • Donate to Member
Re: FARR automatically pops up on Windows 10
« Reply #7 on: June 14, 2019, 03:25 AM »
Just checked your recommendations:

- when the external monitors are connected, FARR will pop up after logging in again
- when the external monitors are not connected, no window will pop up

So I think it has to be connected to the two different graphic adapters, one being the Intel HD graphics, the other is a Nvidia Quadro that is being used fornal monitors. I am just updating the drivers and will check if I can tell the PC to always use the internal graphics card to run FARR. Perhaps that'll fix things.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,401
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: FARR automatically pops up on Windows 10
« Reply #8 on: June 14, 2019, 05:43 AM »
Another solution would be to change the setting of FARR so that instead of popping up on the "current" monitor, it always popped up in same place, and have it pop up on the internal monitor; then it might not confuse the graphics driver/utility into thinking it was off screen when it wakes up from boot.
Screenshot - 6_14_2019 , 5_42_45 AM.png

SaschaM

  • Participant
  • Joined in 2007
  • *
  • Posts: 5
    • View Profile
    • Donate to Member
Re: FARR automatically pops up on Windows 10
« Reply #9 on: June 14, 2019, 07:41 AM »
Thanks again for the continuous support! After the lunch break I booted into BIOS and changed my graphics card settings to use "Hybrid" rather than "Discrete graphics". I then configured Nvidia drivers to always use the Nvidia card in combination with FARR. Now it no longer pops up when locking up and logging in again.

I also tried your recommendation but this still shows FARR after the above lock/log in.

Thanks anyway, my problem is now solved :-). Have a great weekend!

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,401
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: FARR automatically pops up on Windows 10 [solved]
« Reply #10 on: June 14, 2019, 07:46 AM »
Thanks for reporting your discoveries and solution  :up: