topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 17, 2018, 12:51 PM
  • Proudly celebrating 13 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Chrome 70.0.3538.110 (is) was the worst ever  (Read 341 times)

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 7,431
    • View Profile
    • Donate to Member
Chrome 70.0.3538.110 (is) was the worst ever
« on: November 24, 2018, 09:14 AM »
Google Chrome 70.0.3538.110 (on 64 bits PC) is the worst ever. Nothing is going right, everything is taking forever and then I'm told I am not even connected.
 :(
Any one else experiencing massive problems with Chrome 70.0.3538.110 ?

« Last Edit: November 24, 2018, 04:08 PM by Curt »

wraith808

  • Supporting Member
  • Joined in 2006
  • **
  • default avatar
  • Posts: 9,894
    • View Profile
    • Donate to Member
Re: Chrome 70.0.3538.110 is the worst ever
« Reply #1 on: November 24, 2018, 11:32 AM »
Just updated to it this morning, and haven't seen anything yet along the lines that you're talking about.

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 7,431
    • View Profile
    • Donate to Member
Re: Chrome 70.0.3538.110 is the worst ever
« Reply #2 on: November 24, 2018, 04:07 PM »
It's working okay now!

8 hours ago, it was terrible, and the problem was only with Chrome; Firefox and Edge were doing fine. Hm... could it be that it was working midst updating? But why then did it go along for maybe half an hour? Any way, as I said, it's behaving like normal now.