Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • September 25, 2016, 02:10:53 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Problem launching Firefox with commandline from LBC - am I doing it wrong??  (Read 1890 times)

Lolipop Jones

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 54
    • View Profile
    • Donate to Member
Firefox Portable is located on a USB stick mapped to drive L:\  and is in the subfolder L:\KeyApps\FirefoxPortable

I want to run the program with a command line argument forcing it to use the (relative) profile on that stick located in \KeyApps\FirefoxPortable\Data\Profile

When I navigate to the folder where the executable is located and enter

 FirefoxPortable.exe -profile "Key Apps/FirefoxPortable/Data/profile"

it works fine, but when I place the following in LBC as the command, nothing happens -

%APPDRIVE%\Key Apps\FirefoxPortable\FirefoxPortable.exe -profile "Key Apps/FirefoxPortable/Data/profile"


Am I missing something??
Today's problems were yesterday's solutions....

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,247
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
That looks like a correct use of %APPDRIVE%.

LBC expects the arguments to be specified in a separate edit box though -- see if that helps.

Lolipop Jones

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 54
    • View Profile
    • Donate to Member
Thanks for getting right back!!

When I put the argument in that box, Firefox launches OK, but the argument seems to be ignored.

The argument which gives me the result I want when run directly is

 -profile "Key Apps/FirefoxPortable/Data/profile"

Next to the argument box is the legend (use %file%) and I'm not quite sure what that means.  Should I rewrite the argument in some way??
Today's problems were yesterday's solutions....

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,247
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
you can just ignore the suggestion about %file%, that's just if you want to let your node be able to receive a dropped file and use it in the argument.

what about trying:
-profile "%APPDRIVE%/Key Apps/FirefoxPortable/Data/profile"

Lolipop Jones

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 54
    • View Profile
    • Donate to Member
That's got it.  You're the <s>man</s> cat, mouser.
Today's problems were yesterday's solutions....

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,247
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member