Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 04, 2016, 08:33:11 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Plugin management not working  (Read 1424 times)

skajfes

  • Honorary Member
  • Joined in 2008
  • **
  • Posts: 231
    • View Profile
    • Donate to Member
Plugin management not working
« on: April 29, 2015, 07:18:32 AM »
Hi,

FARR does not save settings regarding plugins. For example if I disable a plugin trough FARR settings dialog, the plugin remains enabled.
Also some plugins have additional settings (ie. Timer plugin) and changing those settings also doesn't get persisted.

I am running FARR on Windows 8.1. I don't have UAC enabled, and FARR is not running with elevated permissions.
It is impossible to make anything foolproof because fools are so ingenious.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Plugin management not working
« Reply #1 on: April 29, 2015, 08:48:58 AM »
Are you using portable farr or the installer version? Do you customize your ConfigDir.ini file?
It sounds like maybe it's trying to save settings someplace it doesn't have permission.. If you change other options are they saved on a program exit and restart?

skajfes

  • Honorary Member
  • Joined in 2008
  • **
  • Posts: 231
    • View Profile
    • Donate to Member
Re: Plugin management not working
« Reply #2 on: April 30, 2015, 03:08:22 AM »
I am using the installer version, and ConfigDir.ini file was the default one (all lines commented out).
Other options are getting saved, yes.
It seems to me that the options and aliases are getting saved in the %mydocuments%\DonationsCoder\FindAndRunRobot folder, but the plugins are saved in the c:\program files.. folder
If I grant myself (the regular user on the pc) access on the plugins folder then plugin management works, but that is not really a solution.
I would think that the plugins should get saved to the mydocuments folder as well.


It is impossible to make anything foolproof because fools are so ingenious.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Plugin management not working
« Reply #3 on: April 30, 2015, 08:02:10 AM »
Quote
It seems to me that the options and aliases are getting saved in the %mydocuments%\DonationsCoder\FindAndRunRobot folder, but the plugins are saved in the c:\program files.. folder

Thanks, let me try to track that down -- it does indeed sound like that's what's happening, though it shouldn't.
However, it may be that older plugins are not using the right directory.

The one thing that seems odd is that the disabling of a plugin, if my memory serves me, is stored in the normal settings file of FARR -- so *that* value at least, i would think would be saved properly.

skajfes

  • Honorary Member
  • Joined in 2008
  • **
  • Posts: 231
    • View Profile
    • Donate to Member
Re: Plugin management not working
« Reply #4 on: April 30, 2015, 01:23:15 PM »
The one thing that seems odd is that the disabling of a plugin, if my memory serves me, is stored in the normal settings file of FARR -- so *that* value at least, i would think would be saved properly.
FWIW disabling a plugin creates a .cfi file inside the plugin folder, which contains some info about the plugin together with the enabled flag. That should explain why is it not working :)

It is impossible to make anything foolproof because fools are so ingenious.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Plugin management not working
« Reply #5 on: April 30, 2015, 01:42:16 PM »
thanks skajfes, i guess my memory is not so good -- i will try to fix.