Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • October 01, 2016, 03:44:24 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Trouble with plus sign in alias  (Read 1331 times)

Jonny Johnson

  • Participant
  • Joined in 2015
  • *
  • Posts: 4
    • View Profile
    • Donate to Member
Trouble with plus sign in alias
« on: April 11, 2015, 07:36:08 PM »
Whenever I use the + symbol using an alias, it does not translate in my browser. For example, I have a wolfram alias that I use to graph mathematical expressions, and whenever I use the + symbol it just becomes a space, and I have to manually edit it. Everything else works, such as -/*^(). How can I get the + to work?

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,276
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Trouble with plus sign in alias
« Reply #1 on: April 11, 2015, 07:40:38 PM »
can you show me your alias (screenshot)?

Jonny Johnson

  • Participant
  • Joined in 2015
  • *
  • Posts: 4
    • View Profile
    • Donate to Member
Re: Trouble with plus sign in alias
« Reply #2 on: April 11, 2015, 07:48:42 PM »
Here you go

Image 1.png

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,276
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Trouble with plus sign in alias
« Reply #3 on: April 11, 2015, 07:55:18 PM »
Ok, so I can help :)

Someone made a wolfram alpha alias here:
http://www.donationc...ex.php?topic=18405.0

Now if you look at it, you'll see what's different between that one and yours:
Screenshot - 4_11_2015 , 7_54_05 PM.png

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,276
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Trouble with plus sign in alias
« Reply #4 on: April 11, 2015, 07:56:13 PM »
The $$u1 is useful when you are opening urls, because it does the necessary replacement urlencoding so that urls are properly encoded when they have symbols like + or & in them.
I'm going to modify the tips on that form to give a hint about this -- it's very tricky i'll admit.

Jonny Johnson

  • Participant
  • Joined in 2015
  • *
  • Posts: 4
    • View Profile
    • Donate to Member
Re: Trouble with plus sign in alias
« Reply #5 on: April 11, 2015, 08:18:48 PM »
Ahhh, very nice!  It's working great now, thanks Mouser.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,276
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Trouble with plus sign in alias
« Reply #6 on: April 11, 2015, 08:56:17 PM »
Awesome  :Thmbsup:

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,276
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Trouble with plus sign in alias
« Reply #7 on: April 11, 2015, 08:57:17 PM »
Btw DC member Gothic, who did server admin for dc for a while, now works for wolfram doing server stuff.