Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • September 26, 2016, 05:31:46 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: mapping_data_source::init error: file not found  (Read 2059 times)

Contro

  • Participant
  • Joined in 2007
  • *
  • Posts: 2,564
    • View Profile
    • Donate to Member
mapping_data_source::init error: file not found
« on: April 03, 2015, 09:28:17 AM »
mapping_data_source::init error: file not found

I recently received the above error during the execution of a simple bat file that goes well until now.
The sytem is w7-64.
Don't happen in my portatil with the same system.
So....
The first problem i have is that the console window dissapear very quick . The above message appear twice in the console. And another message i can't read.

My bat is :
@echo off
taskkill.exe /im ditto.exe /f
START Y:\Dittoprg64\Ditto.exe

The target with this bat is close ditto and open again.

I have tried information in web but i am not able to process the information.

Best Regards

f0dder

  • Charter Honorary Member
  • Joined in 2005
  • ***
  • Posts: 9,027
  • [Well, THAT escalated quickly!]
    • View Profile
    • f0dder's place
    • Read more about this member.
    • Donate to Member
Re: mapping_data_source::init error: file not found
« Reply #1 on: April 03, 2015, 09:44:59 AM »
First of all, try running the batch file from a cmd.exe shell, or insert a "pause" statement at the end - that way, the console window won't disappear when the batch file is done executing.

Second, "taskkill /f"? Really? I wouldn't be surprised if Ditto (whatever that is) complains when you start it again, since that command is basically giving the program a headshot. Your headshot has probably caused corruption in some data file it uses.
- carpe noctem

Contro

  • Participant
  • Joined in 2007
  • *
  • Posts: 2,564
    • View Profile
    • Donate to Member
Re: mapping_data_source::init error: file not found
« Reply #2 on: April 03, 2015, 10:21:21 AM »
Done :

These are the messages :

[— ] mapping_data_source::init error: file not found
O:\Mis documentos en 0\SCRIPTING\ReOpenDitto>taskkill.exe /im ditto.exe /£
[—] mapping_data_source:: init error: file not found
Correcto:   se   terminó   el  proceso   "Ditto.exe"  con   PID 9976-
O:\Mis documentos en OSSCRIPTINGNReOpenDitto>START Y:\Dittoprg64\Ditto.exe
O:\Mis documentos en 0\SCRIPTING\ReOpenDitto>pause
Presione una tecla para continuar ...

 

f0dder

  • Charter Honorary Member
  • Joined in 2005
  • ***
  • Posts: 9,027
  • [Well, THAT escalated quickly!]
    • View Profile
    • f0dder's place
    • Read more about this member.
    • Donate to Member
Re: mapping_data_source::init error: file not found
« Reply #3 on: April 03, 2015, 10:38:29 AM »
Right, so that happens before you even kill Ditto... seems fishy. Google results for mapping_data_source::init are obscure, with some Java hits (goosechase) and some russian stuff that talks about agnitum firewall - but also has good advice.

Something related to cmd.exe might be messed up on your machine - try running "sfc /scannow" from a cmd.exe started with administrative privileges. This starts Windows' System File Checker integrity check, which can sometimes repair problems.
- carpe noctem

Contro

  • Participant
  • Joined in 2007
  • *
  • Posts: 2,564
    • View Profile
    • Donate to Member
Re: mapping_data_source::init error: file not found
« Reply #4 on: April 03, 2015, 11:23:41 AM »
Thanks f0dder. I assume is a strange case, I even try translate the russian but only understand a bit...
I will do the sfc /scannow

Contro

  • Participant
  • Joined in 2007
  • *
  • Posts: 2,564
    • View Profile
    • Donate to Member
Re: mapping_data_source::init error: file not found
« Reply #5 on: April 03, 2015, 11:24:54 AM »
ejem.

The first message in the console was the name of this post.
Checking 3%....

Contro

  • Participant
  • Joined in 2007
  • *
  • Posts: 2,564
    • View Profile
    • Donate to Member
Re: mapping_data_source::init error: file not found
« Reply #6 on: April 03, 2015, 11:34:15 AM »
Se completo la comprobación de 38%
comprobation up to 38%
---
Protección de recursos de Windows no pudo realizar la operación solicitada.
Windows protected resources can't do the operation...


Shades

  • Member
  • Joined in 2006
  • **
  • Posts: 2,079
    • View Profile
    • Donate to Member
Re: mapping_data_source::init error: file not found
« Reply #7 on: April 03, 2015, 11:44:14 AM »
What is the reason of (brutally) terminating Ditto in the first place?

Software like 'Process Governor' or 'Process Tamer' would help closing any application gently, before its memory consumption or CPU consumption becomes too much for your liking.

Best practices regarding RAM consumption by an application is a whole different warzone discussion.

Debugging batch scripts involves a lot of handwork, especially when such scripts get a bit more complicated.
Fodder's suggestion is very helpful, it is best to type 'cmd' in the search box of your start menu. Perhaps it would even be better to run the 'cmd.exe' application in administration mode. Navigate to the batch script inside this CMD shell and run the script:

@echo off
taskkill.exe /im ditto.exe /f
PAUSE
start y:\Dittoprg64\Ditto.exe

When the PAUSE command is executed in the script you will see the result of the taskkill command you have executed. It the result shows one or more error messages, you can use the key combination CTRL + C to terminate the execution of this batch script (this won't close the CMS shell). Starting the Ditto application before fixing the error message is of no use and can even damage the data that is stored in that application. But you already managed to find that out the hard way.

It is very important to give an application time to close itself properly, so it can save files and data it was working with to allow it to function correctly the next time the application is started. The '/f' parameter of the taskkill command doesn't give any time at all to the application to terminate itself. Therefore it is only to be used as last resort.

For example, if Ditto consumes too much RAM for your liking, proper use of the taskkill command would be:

taskkill.exe /fi "Memusage gt 500000" /im ditto.exe         (this kills Ditto if it uses more than 500MByte of RAM)


Replace the taskkill line in your own script with the line above and use the built-in scheduler of Windows to execute the adjusted batch script on an interval (once per hour, once per day etc.) and Ditto will be properly terminated and restarted automatically, only when it is running out of your optimal settings.

Managing multiple applications in this way is a very time consuming task and there are specific tools here already available on the DC forum that make this a lot easier.

[joke (or not?)]
  You are always allowed to use the '/f' parameter like this: taskkill.exe /im excel.exe /f
[/joke]

Follow the link above for more explanation about this command (including some simple examples).

It also looks like you use a non-standard drive and folder setup in this particular Windows setup.

The reported error mentions that it cannot find a file, so that leads to to the following questions:
Y:\ - this is a network drive? And even if it isn't, are you sure you have enough user rights to access this drive and its contents?
Dittoprg64\ - Are you sure you have enough user rights to access this folder and its contents?

Contro

  • Participant
  • Joined in 2007
  • *
  • Posts: 2,564
    • View Profile
    • Donate to Member
Re: mapping_data_source::init error: file not found
« Reply #8 on: April 03, 2015, 12:10:15 PM »
 :-[
I will investigate. I am using this bat some years ago. And goes well in the portatil...
Never corrupted data with Ditto.
I have 16 GB ram in this pc. And only 4 GB in the portatil.


P.D. I think I must explain how i use this bat:
Ditto is a great clip manager, even in network. But sometimes in my system (3 pc's) fails the connection. And one way to solve this is close and open ditto again....

No problems of ram memory really...
 :-[

f0dder

  • Charter Honorary Member
  • Joined in 2005
  • ***
  • Posts: 9,027
  • [Well, THAT escalated quickly!]
    • View Profile
    • f0dder's place
    • Read more about this member.
    • Donate to Member
Re: mapping_data_source::init error: file not found
« Reply #9 on: April 03, 2015, 01:22:48 PM »
Se completo la comprobación de 38%
comprobation up to 38%
---
Protección de recursos de Windows no pudo realizar la operación solicitada.
Windows protected resources can't do the operation...
That doesn't sound too good.

I would try rebooting Windows in "safe mode with command prompt", and run the "sfc /scannow" again there. If that also fails, your install is in pretty bad condition. It could be corrupt Windows system files for whatever reason, it could be malware, it could be "security" software of the stupid kind.

P.D. I think I must explain how i use this bat:
Ditto is a great clip manager, even in network. But sometimes in my system (3 pc's) fails the connection. And one way to solve this is close and open ditto again....
Is there a reason you use the /f argument? Can't taskkill do a clean shutdown of ditto?

If you generally use the practice of /f'ing processes (whether with taskkill or by force-qutting from task manager), it's no wonder your system is acting wonky - that way of shutting down processes should only be done as a last resort.
- carpe noctem

wraith808

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 8,267
  • "In my dreams, I always do it right."
    • View Profile
    • Donate to Member
Re: mapping_data_source::init error: file not found
« Reply #10 on: April 03, 2015, 03:34:27 PM »
If you generally use the practice of /f'ing processes (whether with taskkill or by force-qutting from task manager), it's no wonder your system is acting wonky - that way of shutting down processes should only be done as a last resort.


/f'ing is admirably and accurately named.