ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE. Software > Screenshot Captor

How to make ScreenshotCaptor PORTABLE?

(1/2) > >>

How to make ScreenshotCaptor PORTABLE and make it use .INI configuration files in its EXE folder?

Instead the application creates INI-files in my user's local folder, which makes it NOT portable...

P.S. I did not install it into 'Program Files'.
Instead I downloaded ScreenshotCaptor by 'get the' link (
and then unpacked it.

You shouldn't have to do a single thing if you downloaded the portable zip file, so something is going wrong.

Can anyone confirm they are experiencing the same behavior?

The portable version should be creating it's ini file in the folder you unpack it to -- just like you are saying you want it to.
You should not have to do anything other than unpack the zip file and run it, and all files should be saved in that directory.

The only thing that should change that would be if it can't save to that directory  for some reason (like it doesn't have permission to) or if you do something that would change/replace/relete the ConfigDir_Default.ini file or put a different ConfigDir.ini file in that directory.

Can you check that you have a Configdir_Default.ini file in that directory and no ConfigDir.ini file in that directory.

And give me some more information?

Did you unpack it into your my documents directory somewhere, or onto a usb drive? If you tried to manually install it into the Program Files or other similar directory, and you are using Windows Vista or later, it may be blocking the ability to save there.

What version of windows are you using?

Windows 7 x64 Home Basic; Windows 8.1
I log into Windows with 'Administator' user.
Some time ago I logged into Windows with another name of user with admin rights rather than Administrator itself.
I unpacked ScreenshotCaptor to my local hard disk, folder D:\My_Portables\ScreenshotCaptor

There is ConfigDir_Default.ini file in the folder.
And also there was ConfigDir.ini there, but all its lines were prefixed with comment symbols.
I'm not sure, maybe it was my bad idea to create that file from ConfigDir_Default.ini file, maybe not.

So, I deleted ConfigDir.ini file and now everthing works 'portably' fine! :)

Thank you.

Glad to hear it worked out well, and thanks for taking the time to let us know the fix  :Thmbsup:

I'll explain basically what my programs do with regard to those ConfigDir files, for others that might stumble across this same problem.

When Screenshot Captor (or other programs i've written) start up, the first thing they look for is a ConfigDir.ini file.  This file should not be created automatically during installation, so if it exists, its because user made it, so it takes precedence.  If this file doesn't exist, the program will then check for a ConfigDir_Default.ini.  This is useful because in my portable zips, i include one of these that says to save configuration settings in the current directory (that is, to run portably).

As an aside, the reason that the portable versions come with a ConfigDir_Default.ini and not a Configdir.ini is so that users can make their own ConfigDir.ini that takes precedence, which won't be overwritten if they unpack a new release on top of the old.

So the ConfigDir_Default.ini that comes in the portable zips explicitly says to save settings in the current directory.  Without that, the program will choose to use the users local documents directory.

So when you made your own ConfigDir.ini and COMMENTED OUT the lines that said to run portably, that combination was telling the program to save in users local documents directory, since that's the default behavior of the program if nothing tells it any differently.

In short, the portable zip files are ready to use portably, you don't need to do anything else other than unzip them.  The installer is set up to run non-portably and use user document directory.

If you want to modify either of these behaviors you can, just create your own custom ConfigDir.ini file and tell the program exactly where you want the settings saved.


[0] Message Index

[#] Next page

Go to full version