Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 09, 2016, 01:40:03 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Turn off INI backups  (Read 2649 times)

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
Turn off INI backups
« on: September 02, 2013, 09:34:31 PM »
i am using the latest version 4.6 beta and i am wondering if it is possible to turn off SC's auto-backing-ups of the INI files. thanks.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,421
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Turn off INI backups
« Reply #1 on: September 02, 2013, 09:40:55 PM »
You mean just the case where it creates a single .bak file of the ini?  Why would you want to disable that?

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
Re: Turn off INI backups
« Reply #2 on: September 02, 2013, 11:21:13 PM »
i have had instances where the newer ini files have been overwritten by the backup. i have no idea why this happens but the default ini goes missing replaced by the older ini.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,421
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Turn off INI backups
« Reply #3 on: September 02, 2013, 11:24:57 PM »
i'm not sure what you are saying -- but it seems like you are describing a bug that needs to be fixed -- rather than describing a need to turn off backups.
can you maybe try to describe a bit more what you think happens wrong?

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
Re: Turn off INI backups
« Reply #4 on: September 03, 2013, 12:04:21 AM »
the whole thing is quite random but normally it happens upon startup. one of the telltale sign is the screenshot folder would be changed to a folder within the SC folder, instead of the custom one that i had chosen previously. i'd be more than happy to provide my INI file, if that would help.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,421
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Turn off INI backups
« Reply #5 on: September 03, 2013, 01:19:10 AM »
You said that it's using the backup instead of the latest -- is it possible instead that its merely resetting to all default options?
Second question: is it possible that this behavior only happens after restarting the computer?

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
Re: Turn off INI backups
« Reply #6 on: September 03, 2013, 01:37:12 AM »
You said that it's using the backup instead of the latest -- is it possible instead that its merely resetting to all default options?
i had assumed SC is restoring from the backup but as you highlighted it is plausible that the settings are just being reset to the defaults.

Second question: is it possible that this behavior only happens after restarting the computer?
sometimes it happens after restarting the computer but it also happens when cold-booting the PC.

also worth mentioning, for some crazy reason i have the "start with windows" turned off within SC. instead i load SC via batchrun.

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
Re: Turn off INI backups
« Reply #7 on: September 07, 2013, 08:20:03 PM »
i had to the opportunity to restart the computer this morning, and SC had its settings reset to default. i attach the newer INI file which overwrote my custom settings. maybe it could shed some light on the cause.

* ScreenshotCaptor.ini.zip (5.2 kB - downloaded 52 times.)

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,421
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Turn off INI backups
« Reply #8 on: September 07, 2013, 08:31:49 PM »
There has to be something unusual about your setup that is causing this to happen.
Are you running SC portably or did you use the installer?  Have you edited your ConfigDir.ini file?

Try this:
Start SC as you normally do.  If you normally launch it automatically at boot time, turn that off while we experiment.
Then change an option, and exit SC. Restart it.  Is your change in place?

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
Re: Turn off INI backups
« Reply #9 on: September 08, 2013, 01:10:57 AM »
i have always used SC in portable mode. these are the two lines in my ConfigDir.ini

Quote
PORTABLE=TRUE
CONFIGDIR = .

i will post the results of the 2nd part when i have completed a reboot. thanks..

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,421
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Turn off INI backups
« Reply #10 on: September 08, 2013, 01:13:11 AM »
what operating system?

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
Re: Turn off INI backups
« Reply #11 on: September 08, 2013, 01:53:00 AM »
this is on a PC running WinXP SP3 and i have enabled SC's internal option for starting with Windows.

this is the current settings. (but yet to reboot..)

Screenshot Captor Options_2013-09-08_00001.png

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,421
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Turn off INI backups
« Reply #12 on: September 08, 2013, 12:05:03 PM »
Quote
Try this:
Start SC as you normally do.  If you normally launch it automatically at boot time, turn that off while we experiment.
Then change an option, and exit SC. Restart it.  Is your change in place?

first step is to make sure the settings are saved if you manually start and exit, without worrying about rebooting.

can you also make sure you don't have multiple versions of SC installed in different locations.

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
Re: Turn off INI backups
« Reply #13 on: September 08, 2013, 08:06:12 PM »
the settings stick if i manually start and exit. there are no other versions of SC installed and it's at the same location all this while.