Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 04, 2016, 04:21:25 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Removing text format when copying text from CHS into another application  (Read 3017 times)

dcwul62

  • Supporting Member
  • Joined in 2013
  • **
  • default avatar
  • Posts: 293
    • View Profile
    • Donate to Member

Say I am writing a mail, or creating a Word doc.

I want to paste text that I copy-pasted from (e.g.) a website to the mail or Word doc.

I would select the text from CHS Main window, copy that and paste into the mail.
Now, when copying from the main window, I would like the text layout/format be removed, i.e. non-formatted text.
So once it is pasted in mail/word.doc it will adopt the textformat from the mail or word.doc.

If at all possible, how to do this?

TIA
=

tomos

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 10,317
    • View Profile
    • Donate to Member
CHS always remembers the formatting from the last clip. The only way I know of to strip the formatting, is to copy more text (i.e. after you've copied the text you want) - the text you want to paste will now be in second place in the list - when you paste this it will not be formatted.

That's a messy workaround though - hopefully someone else will have a more graceful method. I know there are formatting presets, but dont know if they can be used to strip formatting (?)

Screenshot - 2013-08-07 , 13_58_45.png
Tom

dcwul62

  • Supporting Member
  • Joined in 2013
  • **
  • default avatar
  • Posts: 293
    • View Profile
    • Donate to Member
Up front, sorry for the delay.
I did not get a notification, apparently I need to tag notifications in my profile, or so.

Anyway, thanks.

Vainly tried to get the same window as above. Q: How to get this?

Regretfully selecting text and ctrl-c does not work.

Maybe a new option: strip format then.

=
http://i528.photobucket.com/albums/dd330/phwul/SnagIt-15082013134216_zps365ad17d.png
Removing text format when copying text from CHS into another application


=

later .. I found it, click on the taskbar button. ahum..


« Last Edit: August 15, 2013, 07:06:15 AM by dcwul62 »

tomos

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 10,317
    • View Profile
    • Donate to Member
Vainly tried to get the same window as above. Q: How to get this?

it's the "Quick-paste" menu. I'm not sure what the default shortcut is - have a look in preferences:

Screenshot - 2013-08-15 , 15_40_20.png

and look what else is on offer there!!
"Paste last clip as plaintext" :D
Tom

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,137
  • Slartibartfarst
    • View Profile
    • Donate to Member
You will probably find this a bit quicker (no menus needed) and thus a timesaver - use the approach here: CHS tip - retain last clip's formatting with an AutoHotKey workaround script

You basically choose - at the time of pasting - whether you want to paste some copied text with or without formatting, and you can paste it a second time with formatting after having first pasted it without formatting. It's effectively a workaround to CHS' default destruction of the text formatting, but it only works on the last item to have been copied to the Clipboard.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Quote
CHS always remembers the formatting from the last clip. The only way I know of to strip the formatting, is to copy more text (i.e. after you've copied the text you want) - the text you want to paste will now be in second place in the list - when you paste this it will not be formatted.

is this true?

i thought the way it worked was that if you use Ctrl+V you will get the normal formatting since you are using the windows clipboard, but if you use the quick-paste menu, EVEN IF ITS THE FIRST ITEM, it would strip formatting.  no?

tomos

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 10,317
    • View Profile
    • Donate to Member
Quote
CHS always remembers the formatting from the last clip. The only way I know of to strip the formatting, is to copy more text (i.e. after you've copied the text you want) - the text you want to paste will now be in second place in the list - when you paste this it will not be formatted.

is this true?

... eh...    no :-[



i thought the way it worked was that if you use Ctrl+V you will get the normal formatting since you are using the windows clipboard, but if you use the quick-paste menu, EVEN IF ITS THE FIRST ITEM, it would strip formatting.  no?

Dunno why I never noticed that with my very roundabout 'workaround'  ;D
Tom

dcwul62

  • Supporting Member
  • Joined in 2013
  • **
  • default avatar
  • Posts: 293
    • View Profile
    • Donate to Member

"Paste last clip as plaintext" :D

tried that, regretfully CHS crashes.
regretfully.
=


tomos

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 10,317
    • View Profile
    • Donate to Member

"Paste last clip as plaintext" :D

tried that, regretfully CHS crashes.
regretfully.
=

Easiest would be then if mouser could fix that.
Can you give details - what's your OS, etc.?

I tried it here (win7 64bit) and it mostly works.
In Wordpad it works as expected.
In a html pane (in InfoQube's web-forum) it works as expected.
In Textmaker wordprocessor (Softmaker), it strips italic and bold - but *not* underline. (Using Quickpaste has the same problem in Textmaker.)


@ dcwul62 -
did you also try mouser's suggestion?

if you use Ctrl+V you will get the normal formatting since you are using the windows clipboard, but if you use the quick-paste menu, EVEN IF ITS THE FIRST ITEM, it would strip formatting.
Tom

dcwul62

  • Supporting Member
  • Joined in 2013
  • **
  • default avatar
  • Posts: 293
    • View Profile
    • Donate to Member
Matter is solved.

I was constantly trying to accomplish this in a wrong way....  ahum  :-[
(by selecting the text in CHS and then ctrl-c/ctrl-v)

whereas a number of other options were available.
Sorry to all for the confusion.

===============================================

Clipboard Help and Spell-Paste as non-formatted text-21082013 061817.png

================================================

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Removing text format when copying text from CHS into another application
« Reply #10 on: August 22, 2013, 11:07:34 AM »
Glad you got it working.

However, as Tomos points out, if CHS is ever crashing, then that's a bug in the program I'd like to fix -- so let me know if you've figured out a way to make the program crash!

dcwul62

  • Supporting Member
  • Joined in 2013
  • **
  • default avatar
  • Posts: 293
    • View Profile
    • Donate to Member
Re: Removing text format when copying text from CHS into another application
« Reply #11 on: August 22, 2013, 11:28:57 PM »
Hi Mouser, well, setting Hotkeys->Capture/View/Spell to CTRL-C and Past last clip as plaintext to CTRL-V, caused CHS to crash repeatedly. Tried it again...

Surely this is not the correct way, I have set them to "None" - no problems anymore.
=
SnagIt-23082013 062351.png
=

=
SnagIt-23082013 061646.png
=

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Removing text format when copying text from CHS into another application
« Reply #12 on: August 23, 2013, 12:53:41 AM »
Ha, you're right, those do make CHS crash!
Weird. I shall fix.