Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 04, 2016, 10:13:54 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Last post Author Topic: Screenshot Captor 3.28 aka 4.0RC Beta Test - Mar 17, 2013 - Feedback Wanted  (Read 54090 times)

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #25 on: February 23, 2013, 09:55:15 PM »
Latest update will let you save and restore settings files -- should make it a bit easier to switch between modes of operation.

TIP: Advanced users can manually edit saved settings files to have them only include a few options that they care about -- when you load those files any options not found in the file will be left alone.

cmpm

  • Charter Member
  • Joined in 2006
  • ***
  • default avatar
  • Posts: 2,025
    • View Profile
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #26 on: February 24, 2013, 03:59:01 AM »
Is the version number still 3.17.01?
That is what I'm getting from the first post.

xcopy

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 76
    • View Profile
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #27 on: February 24, 2013, 10:48:33 AM »
I configured the program to display the main window after doing a "grab selected region".

Most of the times the main window displays just the captured image (which is the expected result) but in certain cases an area is already selected. Seems to be that it happens when I select a region which is not in the center of the screen but nearer to the edges.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #28 on: February 24, 2013, 10:54:21 AM »
It should be trying to highlight the active window or window under the cursor.. does that make sense in terms of what it is selecting?

xcopy

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 76
    • View Profile
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #29 on: February 24, 2013, 11:35:17 AM »
No, the selection only seems to depend of the distance to the screen edges. I thought since it's the "area" mode screenshot captor shouldn't consider windows and the active window at all and just grab what's under the cursor?

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #30 on: February 24, 2013, 11:54:33 AM »
Ok this sounds like a bug i really need to fix.. i will look into it but please don't let me forget to fix it.


Quote
I thought since it's the "area" mode screenshot captor shouldn't consider windows and the active window at all and just grab what's under the cursor?

this has been changed so that SC will still try to do this -- but in your case it sounds like its not detecting a valid region.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #31 on: February 24, 2013, 01:08:40 PM »
Ok I think i see the problem you were experiencing; i've uploaded a new beta version (same url), can you give it a try and see if it's fixed?

xcopy

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 76
    • View Profile
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #32 on: February 24, 2013, 01:12:56 PM »
Thanks, partly fixed.
It doesn't happen anymore at the left, right and top edges but if you take the Win7 Taskbar into the screenshot there's still this selection.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #33 on: February 24, 2013, 01:38:53 PM »
Quote
but if you take the Win7 Taskbar into the screenshot there's still this selection.

but it's selecting the taskbar area right? in other words its highlighting the taskbar?

xcopy

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 76
    • View Profile
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #34 on: February 24, 2013, 03:34:49 PM »
No, not really. See here: http://screencast.com/t/7stVWgKIfZh

cmpm

  • Charter Member
  • Joined in 2006
  • ***
  • default avatar
  • Posts: 2,025
    • View Profile
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #35 on: February 24, 2013, 07:49:52 PM »
After saving the image with a caption,
and opening the screenshot in another viewer,
the text does not show in the caption.
The caption space shows but not the text.

The text and caption area both show in another viewer,
if I copy and 'paste as file' with c.gingerich's paste as file.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #36 on: February 24, 2013, 07:58:57 PM »
Quote
After saving the image with a caption,
and opening the screenshot in another viewer,
the text does not show in the caption.

It's really important to me if you can reproduce this problem and figure out the details of why its happening.

Now one important thing if you really have a file which shows the text in one viewer but not in another, then it may be that its a TRANSPARENT background and black text, so you cant see it in your viewer.

But I need to know if it's a real bug.

So.. if you can find such a file, please attach it to a post in a reply or email it to me (mouser@donationcoder.com) so i can examine.

cmpm

  • Charter Member
  • Joined in 2006
  • ***
  • default avatar
  • Posts: 2,025
    • View Profile
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #37 on: February 24, 2013, 08:07:07 PM »
ok i'll do it, hope it's me and not a bug though

cmpm

  • Charter Member
  • Joined in 2006
  • ***
  • default avatar
  • Posts: 2,025
    • View Profile
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #38 on: February 24, 2013, 08:22:57 PM »
here is the shots
neither text or caption area showed in Infranview
I just shot with grab selected region and added the caption. (part of my computer background)
I didn't change any transparency.

edit-I saved normally and with using quick save as new version too, same results
« Last Edit: February 24, 2013, 08:29:36 PM by cmpm »

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #39 on: February 24, 2013, 08:30:19 PM »
That's troubling :(

Can you reproduce the problem?

Did you happen to use the toolbar button to "launch image in graphic editor?"

cmpm

  • Charter Member
  • Joined in 2006
  • ***
  • default avatar
  • Posts: 2,025
    • View Profile
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #40 on: February 24, 2013, 08:31:49 PM »
no, I opened it via the windows explorer and SC's right left hand explorer

let me open it that way and see...

cmpm

  • Charter Member
  • Joined in 2006
  • ***
  • default avatar
  • Posts: 2,025
    • View Profile
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #41 on: February 24, 2013, 08:34:37 PM »
where is that command?

cmpm

  • Charter Member
  • Joined in 2006
  • ***
  • default avatar
  • Posts: 2,025
    • View Profile
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #42 on: February 24, 2013, 08:38:41 PM »
pfft-stupid me, found it, doh
same result in zoner my external editor

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #43 on: February 24, 2013, 08:44:15 PM »
can you re-create the problem again with new screenshots?

cmpm

  • Charter Member
  • Joined in 2006
  • ***
  • default avatar
  • Posts: 2,025
    • View Profile
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #44 on: February 24, 2013, 08:55:31 PM »
yes-there is a png object file that will not upload though-

cmpm

  • Charter Member
  • Joined in 2006
  • ***
  • default avatar
  • Posts: 2,025
    • View Profile
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #45 on: February 24, 2013, 08:58:08 PM »
the whole thing, caption and text will copy and paste into my word processor

cmpm

  • Charter Member
  • Joined in 2006
  • ***
  • default avatar
  • Posts: 2,025
    • View Profile
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #46 on: February 24, 2013, 09:01:40 PM »
ahh, ok-
under objects-
flatten all objects to background

That will make it viewable.

cmpm

  • Charter Member
  • Joined in 2006
  • ***
  • default avatar
  • Posts: 2,025
    • View Profile
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #47 on: February 24, 2013, 09:03:37 PM »
here-

cmpm

  • Charter Member
  • Joined in 2006
  • ***
  • default avatar
  • Posts: 2,025
    • View Profile
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #48 on: February 24, 2013, 09:05:38 PM »
and here-the actual file

cmpm

  • Charter Member
  • Joined in 2006
  • ***
  • default avatar
  • Posts: 2,025
    • View Profile
    • Donate to Member
Re: Screenshot Captor 3.17 Beta Test - Feb 23, 2013 - Feedback Wanted
« Reply #49 on: February 24, 2013, 09:07:14 PM »
flattening also removed the 'obects' file