Ah... I see someone is looking to start a war!
Pascal for this, camel for that, CAPS for another, and _these get underscores, while strThose get a pretty prefix, and so do btnThese.
Object.toString() or Object.ToString() or Object.tostring()?
I stick mostly to C#, Java, C and VB naming conventions. I like a bit of this and a bit of that. e.g. I like private field names with an _underscore and camel case:
I'm not fond of:
I like public properties in Pascal case:
I also like method names in Pascal case.
I like controls in Hungarian:
While this is short:
It's just easier to see/read when skimming. I'm not usually very fond of:
condition ? DoSomething() : DoNothing();
It has its uses, but often it's harder to read. Sometimes it is easier... depends... No right answers as far as I can see. Verbose and terse both serve a purpose.
I think following conventions is more important when you work in larger teams, and especially when other people, that you will never meet, end up using/modifying your code.
I do like lots of comments though.
Reading on variable types really is essential for a language though. Some languages do things that you would NEVER expect with some types, and as you're reading through, you end up going, "Ah... now I see what that didn't work..." They usually all make sense in their own contexts. Just different flavours. e.g. If you allocate memory for an integer but don't assign a value, what is the value? zero? null? Both are valid assumptions. Same for a string. Is it null or empty?