Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 04, 2016, 02:32:16 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Back to Firefox - sudden loud noise  (Read 2775 times)

MilesAhead

  • Supporting Member
  • Joined in 2009
  • **
  • Posts: 7,277
    • View Profile
    • Miles Ahead Software
    • Donate to Member
Back to Firefox - sudden loud noise
« on: November 06, 2012, 08:37:23 PM »
After doing Chromium for some time I'm back to Firefox/Waterfox as my primary browsers. Anyway, Chromium did have a built in multi-media blocker. Just disable all plugins.  I don't know what you guys are using, but Stop AutoPlay seems to work.

Just thought I'd post because when I first tried to get it on mozilla, it showed it as discontinued by author. But it's still available for download from Softpedia:

Stop AutoPlay Firefox Extension

You may want to try it before it's pulled down.

I've just started using it. One thing I noticed is download of audio files, like for radio shows that make podcast and mp3 of the show available, may be blocked also unless you add the site to the white list. (The links where you would normally "save link as" don't even show up if the files are blocked.)


eleman

  • Spam Killer
  • Supporting Member
  • Joined in 2009
  • **
  • default avatar
  • Posts: 393
    • View Profile
    • Donate to Member
Re: Back to Firefox - sudden loud noise
« Reply #1 on: November 06, 2012, 08:49:31 PM »

f0dder

  • Charter Honorary Member
  • Joined in 2005
  • ***
  • Posts: 9,029
  • [Well, THAT escalated quickly!]
    • View Profile
    • f0dder's place
    • Read more about this member.
    • Donate to Member
Re: Back to Firefox - sudden loud noise
« Reply #2 on: November 07, 2012, 07:51:39 AM »
Media autoplay is blocked here by a combination of NoScript, AdBlockPlys and not having the Flash plugin installed - when I need some flash stuff, it's not much bother firing up Chrome for that specific occasion :)
- carpe noctem

MilesAhead

  • Supporting Member
  • Joined in 2009
  • **
  • Posts: 7,277
    • View Profile
    • Miles Ahead Software
    • Donate to Member
Re: Back to Firefox - sudden loud noise
« Reply #3 on: November 07, 2012, 10:27:04 AM »
I use Selector



 to pass a page to a different browser when the current one doesn't have the facility. But in this case only Opera wanted to show the links on the site in question. I had to get rid of NoScript to see them in FF or install Opera just for that site. I don't like Opera enough to install just for that. If it already happens to be on, then fine. :)

Whoever is doing the page must have a lame scripting style. There were buttons to play Podcast crap but if you just wanted to download mp3 there were no links. I had to send the dude an email.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Back to Firefox - sudden loud noise
« Reply #4 on: November 07, 2012, 11:24:10 AM »
I use the more general NoScript, which disables all sorts of things from running until you manually enable them on a page.

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,137
  • Slartibartfarst
    • View Profile
    • Donate to Member
Re: Back to Firefox - sudden loud noise
« Reply #5 on: November 08, 2012, 12:34:13 AM »
Is this the same thing? In Firefox v14 there was a feature introduced for this:
  • In the about:config, there is a switch: plugins.click_to_play
  • If you set that to True, then you will get no more annoying Autoplay of any plugin.

I started to use it and it seems to have worked faultlessly - I'm up to Firefox v17 now.
There is a similar feature in Chrome, and I use that too.

I think this was the article I originally got the knowledge from:
(Copied below sans embedded hyperlinks/images.)
Quote
Firefox 14 to Get Flash Click-to-Play Feature
April 13th, 2012, 12:30 GMT · By Lucian Parfeni

Firefox is on its way to getting a click-to-play feature for plugins, Flash in particular. A similar option is available in Chrome, though it's not enabled by default. The click-to-play option is now available in the latest Firefox Nightly releases, but has to be enabled first.
As you can expect, it's still highly experimental. Google spent more than a year before making the option available to all users by default, but even so it's not enabled by default.
For good reason too, it's a feature best left to more advanced users since it can break sites in non-obvious ways.
The feature works in Firefox pretty much as you'd expect, plugins are not loaded until users click on the Flash element to run it.
"A couple days ago I landed an initial implementation of “click-to-play plugins” in desktop Firefox,"  Mozilla's Jared Wein wrote.
The feature is disabled even in the Nightly builds, you have to navigate to about:config and set "plugins.clik_to_play" to "true."
"When plugins.click_to_play is enabled, plugins will require an extra click to activate and start 'playing' content. This is an incremental step towards securing our users, reducing memory usage, and opening up the web," he explained.
The basic functionality is there and the developer is now working on making the feature run on a per-site basis, enabling users to allow plugins on some sites but on not others.
There's good reason to have plugins blocked by default. For one, if you don't need them, they won't use up memory doing nothing. That's not much of a concern on most desktops, but every bit helps.
Beyond that, blocking plugins removes a big cause of instability, Flash banner ads or heavy Flash sites won't run until you enable them. It also makes it harder to exploit vulnerabilities that creep up in plugins perhaps more so than in any other piece of software.
If all goes smooth, Firefox 14 should be sporting the feature, but even so it will be a while before it's something that most Firefox users will be able to enjoy.

MilesAhead

  • Supporting Member
  • Joined in 2009
  • **
  • Posts: 7,277
    • View Profile
    • Miles Ahead Software
    • Donate to Member
Re: Back to Firefox - sudden loud noise
« Reply #6 on: November 08, 2012, 09:50:12 AM »
I started to use it and it seems to have worked faultlessly - I'm up to Firefox v17 now.
There is a similar feature in Chrome, and I use that too.

Thanks. I've set it. Trying it out now. :)

Edit: It does block autoplay.  But it has the side-effect I don't get the mp3 download links. Stop AutoPlay allows me to see the links. I guess it's worth carrying one extra AddOn to avoid installing Opera just for that. :)

I use the Plugins Disabled in chromium too. That works on most sites but has the same mp3 link blocking side-effect. :(
« Last Edit: November 08, 2012, 09:55:54 AM by MilesAhead »

4wd

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 4,473
    • View Profile
    • Donate to Member
Re: Back to Firefox - sudden loud noise
« Reply #7 on: November 08, 2012, 05:39:25 PM »
For interests sake, in about:config there's also media.autoplay.enabled which acts on HTML5 content.

MilesAhead

  • Supporting Member
  • Joined in 2009
  • **
  • Posts: 7,277
    • View Profile
    • Miles Ahead Software
    • Donate to Member
Re: Back to Firefox - sudden loud noise
« Reply #8 on: November 08, 2012, 06:39:16 PM »
For interests sake, in about:config there's also media.autoplay.enabled which acts on HTML5 content.

Thank you. That seems to fix it up. :)

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,137
  • Slartibartfarst
    • View Profile
    • Donate to Member
Re: Back to Firefox - sudden loud noise
« Reply #9 on: November 09, 2012, 03:28:47 AM »
media.autoplay.enabled
That's interesting.
Mine was set to "True" - that's the default state.
That's why I couldn't understand @MilesAhead's earlier difficulty.

MilesAhead

  • Supporting Member
  • Joined in 2009
  • **
  • Posts: 7,277
    • View Profile
    • Miles Ahead Software
    • Donate to Member
Re: Back to Firefox - sudden loud noise
« Reply #10 on: November 09, 2012, 09:30:40 AM »
media.autoplay.enabled
That's interesting.
Mine was set to "True" - that's the default state.
That's why I couldn't understand @MilesAhead's earlier difficulty.

I set it to False. That stopped the autoplay while still allowing the mp3 links. Looks like I can dispense with Stop Autoplay. I'll just keep it backed up in case I find a need.  But so far I don't see one with these settings.

edit: Hmm, seems I need Stop Autoplay after all. With all the restarts every time you change something it's hard to tell what's what until you use the new settings for a bit.
« Last Edit: November 10, 2012, 11:45:32 AM by MilesAhead »