Welcome Guest.   Make a donation to an author on the site August 30, 2014, 05:20:10 AM  *

Please login or register.
Or did you miss your validation email?


Login with username and password (forgot your password?)
Why not become a lifetime supporting member of the site with a one-time donation of any amount? Your donation entitles you to a ton of additional benefits, including access to exclusive discounts and downloads, the ability to enter monthly free software drawings, and a single non-expiring license key for all of our programs.


You must sign up here before you can post and access some areas of the site. Registration is totally free and confidential.
 
Learn about the DonationCoder.com microdonation system (DonationCredits).
   
   Forum Home   Thread Marks Chat! Downloads Search Login Register  
Pages: [1]   Go Down
  Reply  |  New Topic  |  Print  
Author Topic: bug? LBC fails to set starting directory  (Read 1793 times)
dav4is
Participant
*
Posts: 6

View Profile Give some DonationCredits to this forum member
« on: July 16, 2012, 05:53:19 PM »

A shortcut placed on a LBC dock behaves differently from the same shortcut placed on my desktop.
The key is that LBC is not setting the "Starts in" properly, as coded in the link. In each case below the Starts in is coded: %USERPROFILE%\publishing\RW (as shown in the Properties of the lnk file). The shortcut invokes a Rexx script that executes the DIR command to show the starting directory.

Running the DIR command from outside LBC shows that the starting directory is properly set. Running from a LBC dock, the starting directory is set to C:\Program Files (x86)\LaunchBarCommander. This causes my application to fail.

Yes, I could change the script to set the directory, but I have hundreds of these, and I think LBC should do its job properly.

Using LBC 1.132.01
Windows 7, 64-bit


* Clipboard02.jpg (9.2 KB, 250x171 - viewed 89 times.)

* Clipboard03.jpg (38.86 KB, 640x300 - viewed 77 times.)

* Clipboard04.jpg (44.63 KB, 640x300 - viewed 84 times.)
« Last Edit: July 16, 2012, 05:58:22 PM by dav4is; Reason: forgot environment info » Logged
mouser
First Author
Administrator
*****
Posts: 33,286



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #1 on: July 16, 2012, 10:10:18 PM »

I'll check and fix; I want to release an LBC update this week so this is just one more thing to fix for it.  thumbs up
Logged
dav4is
Participant
*
Posts: 6

View Profile Give some DonationCredits to this forum member
« Reply #2 on: July 17, 2012, 05:11:27 AM »

I'll check and fix; I want to release an LBC update this week so this is just one more thing to fix for it.  thumbs up
Thmbsup
Logged
dav4is
Participant
*
Posts: 6

View Profile Give some DonationCredits to this forum member
« Reply #3 on: January 29, 2013, 07:47:02 AM »

THIS BUG STILL NOT FIXED IN v.133  Angry
Logged
Pages: [1]   Go Up
  Reply  |  New Topic  |  Print  
 
Jump to:  
   Forum Home   Thread Marks Chat! Downloads Search Login Register  

DonationCoder.com | About Us
DonationCoder.com Forum | Powered by SMF
[ Page time: 0.026s | Server load: 0.11 ]