Welcome Guest.   Make a donation to an author on the site April 23, 2014, 11:40:12 AM  *

Please login or register.
Or did you miss your validation email?


Login with username and password (forgot your password?)
Why not become a lifetime supporting member of the site with a one-time donation of any amount? Your donation entitles you to a ton of additional benefits, including access to exclusive discounts and downloads, the ability to enter monthly free software drawings, and a single non-expiring license key for all of our programs.


You must sign up here before you can post and access some areas of the site. Registration is totally free and confidential.
 
The N.A.N.Y. Challenge 2014! Download dozens of custom programs!
   
   Forum Home   Thread Marks Chat! Downloads Search Login Register  
Pages: [1]   Go Down
  Reply  |  New Topic  |  Print  
Author Topic: Alias group only showing a single match after dosearch added to definition  (Read 1194 times)
Paul Gardner
Participant
*
Posts: 8

View Profile Give some DonationCredits to this forum member
« on: May 09, 2012, 06:15:11 AM »

I have a alias group defined with just the trigger name, and a number of items in the results dialog box - everything else on the alias edit box is left blank.  Originally, it was simply a list of documents with associated ID numbers that I would use as a reminder of which document belonged to which ID.  Today, I added a "dosearch <directory> ID" string to each item in the results window, so each one looked like this:

Doc1 (4) | dosearch c:\temp 4
Doc2 (10) | dosearch c:\temp 10

As soon as I did this, the FARR search operated differently.  Before, if I typed "mod Doc" (mod being the trigger name), I would see Doc1 (4) and Doc (10) in the list of matches.  Now, all I see is Doc1 (4).  Doc2 (10) doesn't show up until I enter the 2, and then Doc1 is removed from the list and replaced by Doc2.

Is this by design?  Or do I need to set something else on the edit box to being back the earlier functionality.  dosearch works as it's supposed to, but the change in the search results is disconcerting.

Thanks!
Paul
Logged
Paul Gardner
Participant
*
Posts: 8

View Profile Give some DonationCredits to this forum member
« Reply #1 on: May 18, 2012, 07:14:27 AM »

Never mind me!  Wrong command; restartsearch is what I was after!  embarassed
Logged
mouser
First Author
Administrator
*****
Posts: 32,693



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #2 on: May 18, 2012, 09:18:54 AM »

Thanks for figuring it out on your own and sharing the solution -- makes me not feel as bad for missing the post originally.  I must admit that dosearch vs restartsearch is a confusing thing.
Logged
Pages: [1]   Go Up
  Reply  |  New Topic  |  Print  
 
Jump to:  
   Forum Home   Thread Marks Chat! Downloads Search Login Register  

DonationCoder.com | About Us
DonationCoder.com Forum | Powered by SMF
[ Page time: 0.057s | Server load: 0.14 ]