Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • July 26, 2016, 02:50:16 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Eggdrop tcl error [mcpshandlepubOK]  (Read 4110 times)

flikker

  • Participant
  • Joined in 2012
  • *
  • default avatar
  • Posts: 3
    • View Profile
    • Donate to Member
Eggdrop tcl error [mcpshandlepubOK]
« on: February 29, 2012, 02:28:43 AM »
Seems like not to much activity here, but trying anyway if anyone can please help:

I am trying to run a tvrage script made by GaveUp http://forum.egghelp...rder=asc&start=0
The script works great without Mircryption, but with Mircryption loaded I get the following error ONLY on the command "!showinfo" (all other commands work fine):

Tcl error [mcpshandlepubOK]: wrong # args: should be "::tvrage::showinfo displayLine nick uhost hand chan text"
I don't know tcl so hope someone can help me... If additional info is required let me know

Edit: Some more info:
.set errorInfo
[09:40:14] #mynick# set errorInfo
Currently: wrong # args: should be "::tvrage::showinfo displayLine nick uhost hand chan text"
Currently:     while executing
Currently: "::tvrage::showinfo mynick ~me@LinkNet-5881122160.evosurge.com mynick #mychan nikita             "
Currently:     ("eval" body line 1)
Currently:     invoked from within
Currently: "eval $callback [list $nick $uhost $hand $chan $remaindertext]"
Currently:     (procedure "stdrag_trybind" line 91)
Currently:     invoked from within
Currently: "stdrag_trybind $comtype $nick $uhost $hand $chan $text $table $flags $mask $hits $call             back"
Currently:     (procedure "stdrag_triggermcbinds" line 18)
Currently:     invoked from within
Currently: "stdrag_triggermcbinds $comtype $bindfilter $n $uh $h $c $t "
Currently:     (procedure "mcpsrunbinds" line 10)
Currently:     invoked from within
Currently: "mcpsrunbinds $comtype $n $uh $h $c $t "
Currently:     (procedure "mcpshandlecommand" line 72)
Currently:     invoked from within
Currently: "mcpshandlecommand "pub" $n $uh $h $c $t"
Currently:     (procedure "mcpshandlepubOK" line 6)
Currently:     invoked from within
Currently: "mcpshandlepubOK $_pub1 $_pub2 $_pub3 $_pub4 $_pub5"
« Last Edit: February 29, 2012, 02:43:23 AM by flikker »

Ath

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 2,732
    • View Profile
    • Donate to Member
Re: Eggdrop tcl error [mcpshandlepubOK]
« Reply #1 on: February 29, 2012, 03:13:41 AM »
With the risk of being totally wrong, but doesn't the message "wrong # args" suggest it needs 1 or more arguments passed?, so you'd type "!showinfo somenick" (without the quotes ofcourse)

flikker

  • Participant
  • Joined in 2012
  • *
  • default avatar
  • Posts: 3
    • View Profile
    • Donate to Member
Re: Eggdrop tcl error [mcpshandlepubOK]
« Reply #2 on: February 29, 2012, 03:38:53 AM »
With the risk of being totally wrong, but doesn't the message "wrong # args" suggest it needs 1 or more arguments passed?, so you'd type "!showinfo somenick" (without the quotes ofcourse)
The script is suppose to output info about tv show listed on tvrage. Typing "!showinfo nikita" in this case should output info about the tv show Nikita. It works fine without Mircryption, but with Mircryption loaded I get the above error.

Ath

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 2,732
    • View Profile
    • Donate to Member
Re: Eggdrop tcl error [mcpshandlepubOK]
« Reply #3 on: February 29, 2012, 04:04:31 AM »
Shouldn't this be better asked in the egghelp forum you referred to? I see you posted there yesterday, but ask no question(s) regarding this issue, and imho the knowledge should be there, or there's an error in the script...

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,072
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Donate to Member
Re: Eggdrop tcl error [mcpshandlepubOK]
« Reply #4 on: February 29, 2012, 05:22:24 AM »
well it is related to mircryption so this forum is appropriate BUT the the problem is we dont know much about eggdrop/tcl here and this looks like an eggdrop/tcl specific issue.

maybe you can drop by the #mircryption irc channel on efnet, there are a couple of good tcl/eggdrop people that *occasionally* hang out there.

flikker

  • Participant
  • Joined in 2012
  • *
  • default avatar
  • Posts: 3
    • View Profile
    • Donate to Member
Re: Eggdrop tcl error [mcpshandlepubOK]
« Reply #5 on: February 29, 2012, 06:15:23 AM »
Thanks for your replies.

I didn't post in the other forum at first because I testet the script without Mircryption and it worked fine. I have however posted there now, but nobody replied yet....
I will check out #mircryption on efnet, thanks for the tip. If i find a solution I will come back and post it for future reference.