Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 08, 2016, 08:02:24 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Citrix issue  (Read 3760 times)

Arthur Menu

  • Supporting Member
  • Joined in 2012
  • **
  • Posts: 18
    • View Profile
    • Donate to Member
Citrix issue
« on: January 31, 2012, 12:26:09 AM »
Hi Mouser,

Here is a problem with CHS. I connect to my work network from my home computer using Citrix. Once I have logged on to my work network, I can open a number of applications on the work servers such as Word or Acrobat Reader. If I am in Word, for example, and select some text and copy it with Control-C, I am able to paste it into an application on my home computer with Control-V. However, the copied text does not show up as a clip in CHS. All CHS shows in the text bos is "Citrix ICA Client)". It's strange to me that text that is clearly on the Windows 7 clipboard is not accessible in CHS. Can you comment on this?

Arthur

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,421
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Citrix issue
« Reply #1 on: January 31, 2012, 04:15:31 AM »
I'm really interested to hear the answer to this -- I know I have users of some of my other programs (Screenshot Captor) that use Citrix; but since i have no experience with Citrix myself, I don't know if there are special issues with the clipboard.  Perhaps its some setting in citrix management options..

Any other citrix users can shed some light on this?

kunkel321

  • Supporting Member
  • Joined in 2009
  • **
  • Posts: 464
    • View Profile
    • Donate to Member
Re: Citrix issue
« Reply #2 on: January 31, 2012, 09:54:50 AM »
This doesn't surprise me.  I don't currently have access to a Citrix environment, but have used them lots in the past.  They tend to act a lot like a sandbox, were they act like a normal Windows OS, but an app that is outside of Citrix, trying to look in, can only see "Citrix" and not what is inside of Citrix.  (That wasn't a very good explanation, but I'm not a programmer and the behavior is hard to describe.)

Anyhoo...  I wonder if CHS is trying to figure out what app, etc the clip is originating from, but it can only see "Citrix" and so it gets stuck when trying to display the clip.  (Even though it  is still able to understand the text content of the clipboard.)

I've found that sometimes launching things directly in Citrix helps.  (Depending on your permission levels you might not be able to do this).  I've successfully used a couple different portable applications (TranslatorBoomerang was one, I think), that function correctly when started from inside Citrix, but don't function correctly if started outside.   I'm not sure if this applies to an app as sophisticated as CHS though...

Stoic Joker

  • Honorary Member
  • Joined in 2008
  • **
  • Posts: 6,296
    • View Profile
    • www.StoicJoker.com
    • Donate to Member
Re: Citrix issue
« Reply #3 on: January 31, 2012, 11:34:16 AM »
I've only encountered Citrix a few times, but a bit of Googling turned up a Citrix utility here that might be of some use.

Arthur Menu

  • Supporting Member
  • Joined in 2012
  • **
  • Posts: 18
    • View Profile
    • Donate to Member
Re: Citrix issue
« Reply #4 on: January 31, 2012, 09:29:41 PM »
I looked at Citrix utility you mention but it seems to solve the problem of not being able to copy and paste text between apps opened in a Citrix session and apps opened in the home computer. I don't have that problem. I can copy and paste using CTRL-C and CTRL-V. The problem is that CHS does not see the text, so I can't use CHS to paste old clips from a Citrix session or use CHS to edit a clip copied from a Citrix session. I'm no programmer so I can't even begin to speculate on why this is.
-- Arthur

Stoic Joker

  • Honorary Member
  • Joined in 2008
  • **
  • Posts: 6,296
    • View Profile
    • www.StoicJoker.com
    • Donate to Member
Re: Citrix issue
« Reply #5 on: February 01, 2012, 06:57:52 AM »
The utility (best I could tell from a quick read) is for troubleshooting clipboard chaining issues. It appears from what you described above that Citrix isn't playing nice with CHS's attempts to be part of the CB chain (bogus output vs. no output). So... I figured it would be interesting to see what if any error/explanation it gave for feeding CHS ("Citrix ICA Client") a garbage string. Does it even see it as a valid part of the CB chain? Or is it ("intentionally") pragmatically ignoring it, because it's miffed about something?

Just a Thought :)