Welcome Guest.   Make a donation to an author on the site November 24, 2014, 07:51:57 AM  *

Please login or register.
Or did you miss your validation email?


Login with username and password (forgot your password?)
Why not become a lifetime supporting member of the site with a one-time donation of any amount? Your donation entitles you to a ton of additional benefits, including access to exclusive discounts and downloads, the ability to enter monthly free software drawings, and a single non-expiring license key for all of our programs.


You must sign up here before you can post and access some areas of the site. Registration is totally free and confidential.
 
Free DonationCoder.com Member Kit: Submit Request.
   
   Forum Home   Thread Marks Chat! Downloads Search Login Register  
Pages: [1] 2 Next   Go Down
  Reply  |  New Topic  |  Print  
Author Topic: Thanks, with questions...  (Read 14551 times)
kfitting
Charter Member
***
Posts: 574


View Profile Give some DonationCredits to this forum member
« on: March 19, 2005, 10:04:58 AM »

Great program!  Obviously well thought out and with some great features.  A few questions, however:

- When using the tray dll I press pause/break and the search window comes up but I have to either alt-tab or click on it before I am able to type.  Is this normal, or am I doing something stupid?

- At work I was noticing that FindRun has problems with opening multiple excel files.  I'm assuming this is because the new Excel window does not always take focus (hence FindRun just sits in the forground and must be closed manually

- On that note, is there a way to make FindRun close at the beginning of the launch process rather than once the target application becomes active?

- Is there an easy way to be able to change the columns for the detailed view?  (Just me being a picky idiot Wink  )

- Why does FindRun seem unable to open shortcuts and links correctly.  This I feel is just me being stupid because from the documentation it seems that opening these files is a feature.  Everytime I try to run a link or shortcut however, it FindRun closes and nothing happens.  It never ran the link. What am I doing wrong here?

I use WinXP SP2 at home and Win2000 Professional at work (dont know the service pack but I assume it's the latest).  Thanks for the program, even with the above quirks (on my machine at least!) it is still quite a useful little program.  Thanks again,

Kevin
Logged
nudone
Cody's Creator
Columnist
***
Posts: 4,116



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #1 on: March 19, 2005, 11:47:06 AM »

there's something definately not right - the functions you're having problems with work fine on my machine (as i'm sure they do on the majority of users). i've not got sp2 installed - can't see this being the problem though.

have you got other 'shortcut' or quick key programs running in the background - i've had conflicts with these sort of programs before - not with 'find and run robot' though.

i'm no expert on any of this but i'm sure mouser will be able to help much more than this.

just thought i would let you know that it's not operating correctly on your system. what you've described sounds like a right pain.
Logged
mouser
First Author
Administrator
*****
Posts: 33,692



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #2 on: March 19, 2005, 02:20:25 PM »

you definitely should not have to hit alt-tab to switch to it after it activates.  does this always happen? what application grabs focus from it?  or does the focus stay with the application you were using when you hit break.

maybe when you hit break you are in an app that is stealing back focus? does this behavior happen no matter what app you are using?
what os does it happen in?

find&run has had tons of testing on my single pc, but not much testing out in the real world, so there could be issues liek this that need addressing  - i will fix it, we just have to find a way for me to see the problems.

Quote
- On that note, is there a way to make FindRun close at the beginning of the launch process rather than once the target application becomes active?

yes this is what it should do - i will check the code to make sure i'm not doing something stupid.  but yes it should exit immediately after telling the file to open.

i'm not sure why its having trouble with shortcuts.. can you be a little more specific about what it does?
all of these problems are on a win2k machine?  if so i will try some extra tests on a win2k machine and see what i see, though really it shouldnt be any dif than winxp.

tell me what you would like wrt columns - there are various options in the config to change what is displayed, from just the file/shortcut name to a bunch of columns.  if you have some dif requests let me know.

i'm going to try to do some updates next week of my apps so its a good time for requests smiley
Logged
kfitting
Charter Member
***
Posts: 574


View Profile Give some DonationCredits to this forum member
« Reply #3 on: March 19, 2005, 03:16:48 PM »

Updates?  Updates are fun! 

Well, I rebooted (software, especially M$ products seem to like machines to reboot) and it cleared up the losing focus problem... for now!  I was wondering if, since the only "weird" thing I had done to break it was put my notebook to sleep, if this could have something to do with it.  Dont quite see why this would make a difference, but hey, who knows.  However, when it was a problem, the focus issue did not seem to matter which application I was in at the time. 

I have the excel weirdness on Win2K and WinXP.  The first file opens no problem but if the second excel file opens beneath the first one, FindRun just stays open and I have to Ctrl-Alt-Del to get it away.  FindRun also stays open if I launch an Excel file with macros in it because of the "Warning Software can contain virus'" dialog, after I enable the macros, and the file comes up, FindRun goes away.  That's why I was asking if it could minimize as soon as the file begins to open. 

Choosing columns... what I mean here is that you could right-click on the column headings and choose which columns you want to see.  For example, I dont really care to see the Score column but I like detailed view because it tells me if it's an exe, lnk, etc (due to the above mentioned problem with lnk and shortcuts).  Not a big deal and if it doesnt get implemented it wont be the end of the world, but it would be kind of nice.

As far as the whole lnk and shortcuts issue, there really is not a whole lot I can tell you.  They just dont open.  If I press a number that corresponds to a lnk file, FindRun goes away and nothing happens.  I tried looking at the lnk files themselves to see if they point to the wrong place but they dont.  This happens on my XP machine.  Havent tried at work... something to do Monday i guess. 

And, while I'm requesting away and making myself a pain, i was wondering if you could add hotkey functionality.  FindRun is great dont get me wrong, but there are times when pressing Win+C to bring up a program is simpler than hitting pause/break and typing a few characters.  I had been using ShellEnhancer for this functionality but it has so much other bloat to it that I'm looking for a way to get rid of it.  Find Run has 99.9% of everything I've been looking for except for hotkeys.  I had about 5 hotkeys set up to different programs that I used all the time.  FinRun is great because it allows access to all programs everywhere but for those that are used a lot it would be nice to bypass the main dialog.

But, as with all requests feel free to not do mine!!  Great program anyway!  Coding isnt easy so thanks for the work you've put into the program,

Kevin
« Last Edit: May 03, 2007, 04:10:12 PM by kfitting » Logged
mouser
First Author
Administrator
*****
Posts: 33,692



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #4 on: March 19, 2005, 03:33:29 PM »

the more feature requests the better - just to gather ideas.

letting user choose options might not be a bad idea - i have to re-examine the code again to see what's easiest; but if nothing else i can add the option for the display you want.

the whole original purpose of f&r was to launch shortcut (link) files smiley
thats the only way i use it, to launch shortcuts from start menu, so the fact that it doesnt work on your shortcuts at all is kind of distressing Wink

ill look more specifically at the shortcut launching code again next week and i will check both the behavior with regard to not closing immediately, and the beheavior wrt launching shortcuts, maybe ill find something for us to try out.  meanwhile let me know if you figure out any more clues.

i think adding hotkeys would be a reasonable thing to add, considering that f&r has to be sitting waiting for keypresses anyway - so it might as well be checking against some user defined hotkeys.  as usual though the trouble usually comes in making a nice user interface for the user to specify options, etc.  but i may give it a try since i think it would be a nice thing to add.

keep the suggestions coming!  its nice to hear other people's ideas for what areas deserve further work.
Logged
piedone
Participant
*
Posts: 9

View Profile Give some DonationCredits to this forum member
« Reply #5 on: March 20, 2005, 10:37:34 AM »

Hi. first of all, good idea and good program.
On the other hand, I also have problems with running shortcuts. They do not start, not matter what i do. If  i search for an *.exe file then it will start, otherwise no...
I have winxp pro sp2.
strange.

a quick suggestion:
- possibility to control the degrees of transparency of the form.

thanks.
Logged
mouser
First Author
Administrator
*****
Posts: 33,692



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #6 on: March 20, 2005, 10:42:43 AM »

someone had this exact problem with launching shortcuts - must be a bug in the program.
kinda embaressing since launching shortcuts is the main purpose of this program!

i just wonder why its working fine on some machines, and other seem to have it not work at all when launching shortcuts..

well i will try to solve this bug this week.

maybe if one or two of you who are suffering fromt his problem can check this section occasionally this week you can help me beta test it?

we'll get it solved this week for sure - any problem like this which is consistently occuring is easy to fix.

transparency.. hadnt thought of it but its not hard to add.
would you want it to always run at a given level of transparency, or change levels at certain times?

i'll try to add an option for it this week, for adjustable transparency.
Logged
piedone
Participant
*
Posts: 9

View Profile Give some DonationCredits to this forum member
« Reply #7 on: March 20, 2005, 10:53:38 AM »

thanks for the fast answer. I will be glad to test the beta version.
Logged
kfitting
Charter Member
***
Posts: 574


View Profile Give some DonationCredits to this forum member
« Reply #8 on: March 20, 2005, 12:51:12 PM »

I likewise wouldnt mind beta testing.  Seems like things are running too smoothly if there isnt a beta program running loose somewhere on my system!

Also, I noticed that the other user experiencing this problem is running XP SP2... is there something in this that gives probems?   I'll have to try at work on my Win2K machine to see if I can duplicate this problem. 

One more thing:  I notice that when I hit Pause/Break and the program comes up in detailed mode the column headings are not in sight, there is just a blank gray line.  Once I type the first character or interact with the program somehow, the columns heading come up.  This is not a usability issue since the program works fine, but just a consistency thing!

Thanks,

Kevin
Logged
kfitting
Charter Member
***
Posts: 574


View Profile Give some DonationCredits to this forum member
« Reply #9 on: March 22, 2005, 07:16:45 AM »

After testing with Win2K at work I've discovered that most of the problems I was having on XPSP2 are not a problem!  Links and shortcuts work fine, and excel files open ok.  I have still noticed the column headings problem I mentioned above and, while the excel files do open, FindRun does stay on top until after the file loads.  Neither of these are very big problems, just quirks.  Thanks, and have fun,

Kevin
Logged
mouser
First Author
Administrator
*****
Posts: 33,692



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #10 on: March 22, 2005, 07:19:22 AM »

i find that taking care of these lingering issues can sometimes be the most time consuming, but if you guys are willing to help me out by testing stuff, we'll get them all fixed and have the program performing perfectly as soon as possible.
Logged
mouser
First Author
Administrator
*****
Posts: 33,692



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #11 on: March 23, 2005, 09:04:28 PM »

Quote
I have the excel weirdness on Win2K and WinXP.  The first file opens no problem but if the second excel file opens beneath the first one, FindRun just stays open and I have to Ctrl-Alt-Del to get it away.


two questions:

can you get this to reliably happen, ie if i upload an attempted fix will we be able to test it and know whether i've fixed the problem or is this one of those mysterious bugs that only happens on rare occasions.  a reproducable bug is worth its weight in gold..

second question,
are you running it using the "slower but less memory/resources" mode to run the program? and if the bug is reproducable, can you see if the bug happens with both?
Logged
kfitting
Charter Member
***
Posts: 574


View Profile Give some DonationCredits to this forum member
« Reply #12 on: March 24, 2005, 06:13:18 AM »

The Excel weirdness seems to only happen with the less memory version of the program on Win2K. I tried running both and with the faster version it opened correclty.  With the slower version it hung while opening the second file.   It seems to be reproducible.  Won't promise it though!  Let me know if you have more questions.

Kevin
Logged
mouser
First Author
Administrator
*****
Posts: 33,692



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #13 on: March 24, 2005, 06:31:38 AM »

i'm uploading a new version to test;
when you get a chance could you let me know if the the launching problems persist in the dif modes;
i just tested it on my win2k vmware machine and it ran ok, so this is one of those things where your help is invaluable.

see future post for url

just exit the program if its currently running, and install this version over old version.

if you'd prefer i upload just the changed exe without installer i'd be happy to do that in the future.

i'm working my way through fix list.  so far things that i addressed:

  • fixed bug that could result in program trying to save changed options more than necesary
  • changed default launch history to 50 items
  • fixed (maybe) gray empty header on launch in details mode with no items
  • fixed bug causing flash of previous items when clear on restart is checked
  • double click now toggles view when using fast style launcher
  • fixed bug where on trigger you would see previous find list first before it resets
  • adding exclusion rules for apps now adds these rules to pattern match box not history box, and removes any existing entry from history launch.
  • some apparent "hanging" of the program was due to obscured windows, hopefully fixed now.
  • adding an exclusion now forces score to -9999 even if a prior rule exists
  • new window transparency control in options
  • by default moves recent docs and desktop links to top of search list and enabled by default.
  • pressing down arrow during search stops search and moves cursor into results view. 
  • fixed bug with scrollbars on long listviews.
  • slightly improved icon.
  • Cursor arrows in and out of search box works better now. 


Note to Upgraders:
i realized from discussions here that the "recent documents" and "desktop" and maybe even "favorites" directory entries in the search path tab should be enabled and moved to top.  they are that way by default with this new version, but if you're upgrading it won't modify your existing settings so i suggest you enable those and move them to top by default.
« Last Edit: March 24, 2005, 05:55:23 PM by mouser » Logged
nudone
Cody's Creator
Columnist
***
Posts: 4,116



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #14 on: March 24, 2005, 12:53:58 PM »

is this new version just a bug fix edition as you say mouser or does it feature any new features that were discussed earlier in this forum?
Logged
mouser
First Author
Administrator
*****
Posts: 33,692



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #15 on: March 24, 2005, 01:16:52 PM »

i thought it would probably be prudent to make this mainly a bug fix release given that a number of issues were discovered,
and then come back to adding more substantial feature once those are cleaned up.

i have some more small things i want to add, but
the next major thing i will add will be the option to grab the internal list that windows tracks of programs run and add an option to start with that in your start list and/or give score biases.

after that i will try to add some folder searching functionality.

please keep posting suggestings, they help me work out what direction to go in.

im primarily concerned with adress the issue of failing to launch shortcuts on some computers and the report of it handing in these cases.  once i get some idea that these issues are fixed i will make this release official and start working on a release with these new substantial features.
Logged
nudone
Cody's Creator
Columnist
***
Posts: 4,116



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #16 on: March 24, 2005, 01:28:24 PM »

 Thmbsup excellent. going to be a great update when it arrives.
Logged
kfitting
Charter Member
***
Posts: 574


View Profile Give some DonationCredits to this forum member
« Reply #17 on: March 24, 2005, 01:49:55 PM »

Just tested the new version on Win2K at work and still got the excel bug.  It appears to start another instance of FindRun.  Here is what happens:

- I start an excel file and everything goes great
- I start to launch the second file
- FindFun freezes and no excel window comes up
- I ctrl-alt-del and go to kill FindRun but find that it has two instances running
- I kill one of the instances, FindRun flashes to the foreground then goes away entirely (both instances)
- The second excel window comes up

The blank column headings bug seems to be fixed. (both versions)

I notice that when I hit Pause/Break and FindRUn comes up, hitting Pause/Break does not close the window.  Is this how it should be? (less memory version ONLY)

The up/down key presses move me side to side in the search text box not up/down the search returns. (both versions)

Sorry, this is not very detailed.  I only have a few minutes every now and then while I work to try this.  I'll try on WinXP tonight at home.  Also, I personally prefer just having the .exe to copy into the directory.  The Government is a little paranoid when it comes to installing things!  I've done it before but I try to limit it as much as possible.   Thanks,

Kevin
Logged
mouser
First Author
Administrator
*****
Posts: 33,692



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #18 on: March 24, 2005, 02:01:01 PM »

np, i will start uploading the exes alone.

at least i think i have a much better feel for the excel problem at this point, that it is all based on this ShellExecute thing, and the fact that the less memory version works as a pair of programs, a tiny helper and a main app, and that the second launch is confusing the helper to launch another app, which triggers a chain of bumbling after that.

i have to tell you guys, in case you don't already know, having beta testers willing to try out these unofficial releases is an indescribably helpful thing.

i'm going to try an alternative way to launch document files that doesnt require hanging around and waiting for the target app to launch.

side to side huh, lol, thats kinda strange.. if you try the down arrow while a search is ongoing, does it work then? if so then i know the problem.
Logged
kfitting
Charter Member
***
Posts: 574


View Profile Give some DonationCredits to this forum member
« Reply #19 on: March 24, 2005, 02:44:46 PM »

Nope, cant get the cursor keys to work while the search is ongoing either.

Kevin
Logged
mouser
First Author
Administrator
*****
Posts: 33,692



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #20 on: March 24, 2005, 03:44:25 PM »

hi kevin,

ok upped a new version:
http://www.donationcoder..../FindAndRunRobotSetup.exe

something really strange happens in excel - for some reason the system hotkey triggers twice in close succession which was wrecking havock.  a new check for this condition seems to solve the problem.  let me know your results.

i also implemented a special tiny helper utility which now assumes responsibility for launching documents, to avoid this problem where f&r was having wait for excel (or similar app) to fully load before being allowed to go away.

its so typical the MS programs are the worst behaved ones on their own operating system.. boggles the mind.

look forward to hearing your results and if the cursor issue is still present, which is quite strange to me.  but it could be a win2k issue like different keyboard controls.
« Last Edit: March 25, 2005, 01:38:52 PM by mouser » Logged
kfitting
Charter Member
***
Posts: 574


View Profile Give some DonationCredits to this forum member
« Reply #21 on: March 24, 2005, 04:27:59 PM »

Quick test with new version 1.05.05 at home on WinXP SP2. 

- lnk files still dont launch
- excel works fine!!!!!
- Column headings gray again on startup (Trigger version ONLY, XP vs Win2K??)
- Cursor keys work (XP vs Win2K issue??)
- FindRun now IMMEDIATELY exits no matter what file is launched... nice!
- Hitting pause/break opens AND closes window (XP vs Win2K?)

Those are the results of my 5 mins of testing.  Obviously, I cant try out this version on Win2K and I'm not sure if I will be able to try it out on 2K until Monday (Holiday weekend).  But, I should be able to test periodicaly throughout the weekend on XP.  Can you think of any system specs I could tell you that would make this easier to troubleshoot?  Let me know,

Kevin
Logged
mouser
First Author
Administrator
*****
Posts: 33,692



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #22 on: March 24, 2005, 04:39:58 PM »

anyone else with win2k can give a second opinion on some of these win2k issues?

the .lnk thing is the one i absolutely must fix immediately, its driving me crazy that this one main feature of the program is not working properly for you.

can you see if there are some .lnks that work and some that dont..

if we can find some that work and some that don't it could be the clue i need.

and if you go and find these .lnk yourself and double click them, do they launch ok?
Logged
kfitting
Charter Member
***
Posts: 574


View Profile Give some DonationCredits to this forum member
« Reply #23 on: March 24, 2005, 04:56:50 PM »

Regarding lnk files:

tried a bunch with both versions of FindRun... none worked.  Double clicked on them from within win Explorer and they opened right up.  Can you make a version of FindRun that will spit out a log file?  Thanks,

Kevin
Logged
mouser
First Author
Administrator
*****
Posts: 33,692



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #24 on: March 24, 2005, 05:57:02 PM »

yes, if this latest version doesnt fix it im going to make a version that produces log output to help us find the problem.

but try this first:

http://www.donationcoder..../Beta/FindAndRunRobot.zip
or
http://www.donationcoder..../FindAndRunRobotSetup.exe
« Last Edit: March 25, 2005, 01:39:16 PM by mouser » Logged
Pages: [1] 2 Next   Go Up
  Reply  |  New Topic  |  Print  
 
Jump to:  
   Forum Home   Thread Marks Chat! Downloads Search Login Register  

DonationCoder.com | About Us
DonationCoder.com Forum | Powered by SMF
[ Page time: 0.042s | Server load: 0.06 ]