Welcome Guest.   Make a donation to an author on the site August 29, 2014, 03:02:27 AM  *

Please login or register.
Or did you miss your validation email?


Login with username and password (forgot your password?)
Why not become a lifetime supporting member of the site with a one-time donation of any amount? Your donation entitles you to a ton of additional benefits, including access to exclusive discounts and downloads, the ability to enter monthly free software drawings, and a single non-expiring license key for all of our programs.


You must sign up here before you can post and access some areas of the site. Registration is totally free and confidential.
 
The N.A.N.Y. Challenge 2010! Download 24 custom programs!
   
   Forum Home   Thread Marks Chat! Downloads Search Login Register  
Pages: [1]   Go Down
  Reply  |  New Topic  |  Print  
Author Topic: Problem with 1.129.01 when launching rdp-Files  (Read 2218 times)
MichaelHerrmann
Supporting Member
**
Posts: 2


see users location on a map View Profile Give some DonationCredits to this forum member
« on: December 06, 2011, 01:39:38 AM »

Hi,
on my Windows XP Professional I use a Directory Folder in Launchbar Commander which points to a directory with .rdp-files (Remote Desktop Session files). Everytime I click on one of those files in launchbar commander I get an error which says (translated from german): "C:\_LocalCopy\Config\RemoteDesktop\Fook.rdp Wrong Parameter".



When I chose other links from folders parallel to the RemoteDesktop-folder which are of another file-type it works fine. Also I can open the rdp-files via explorer and they start normally.

What I tried so far without success:
- create a new link to the directory folder - same error
- directly link a .rdp-file as command - same error

This might be a bug in the new release, or I have to change some configuration - any hints / advice for me? Is there a way to see the commandline that LBC tries to execute when clicking on the link?
« Last Edit: December 07, 2011, 12:23:08 AM by MichaelHerrmann » Logged
mouser
First Author
Administrator
*****
Posts: 33,285



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #1 on: December 07, 2011, 06:53:02 AM »

Hey Michael,

Ok so LaunchBar Commander (and my other program FARR) use this external little helper tool to launch other files and shortcuts, because doing so can avoid some odd slowdowns that occur when launching files directly.  But there are actually a couple of ways to open documents -- and in fact a small bug fix that i haven't released yet, that could be the cause of this problem.  I've been working overtime to get a new program finished and released for the last couple of weeks so i'm a bit behind with LBC and FARR releases. If you can give me a few days I'll try to have a version out which will let us track down what's going on here.

One quick workaround that might work until i fix it is to make a .bat batch file that will open the rdp you care about.
Logged
MichaelHerrmann
Supporting Member
**
Posts: 2


see users location on a map View Profile Give some DonationCredits to this forum member
« Reply #2 on: December 07, 2011, 07:16:08 AM »

Hey Mouser,

thanks for your reply! Sadly I cannot tell you which the exact version was that I hat installed before (with which the starting of rdp-files worked), but it should have been a quite new version since I use DcUpdater once a month or so. I will try your workaround. Of course I can wait, and maybe we can find out what is going on then.

Regards,

Michael
Logged
r.orrison
Participant
*
Posts: 1


View Profile Give some DonationCredits to this forum member
« Reply #3 on: December 15, 2011, 04:33:14 AM »

Just checked in to report this issue, and found that it's already known.

I found a different workaround: I moved the RDP file elsewhere and put a shortcut to the RDP file where FARR could find it.
Logged
mouser
First Author
Administrator
*****
Posts: 33,285



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #4 on: December 15, 2011, 06:08:06 AM »

thanks for reporting r.orrison the workaround  thumbs up

I've actually been really late releasing an updated farr, because i've spent the last few weeks on a new app.. but i'll be releasing a farr update soon and hopefully it will fix this.
Logged
hornsts
Participant
*
Posts: 21


View Profile Give some DonationCredits to this forum member
« Reply #5 on: January 27, 2012, 11:32:12 AM »

I use LBC to start RDP-Sessions in the same way MichaelHerrmann does. So I have the problem too.
As I have a lot of RDP-Files, I wasn't very happy to create shortcuts to them. But as I missed it so much, I tried the suggested workaround with shortcuts. Sadly  without success. I received the same error message as before.
The creation of many batch files was not an option and I decided to find a different solution.
After some investigation I found out, that LBC's quickdoclauncher.exe tries to find the shell open command for RDP.File in the registry. But this isn't possible, because for RDP.Files the shell command "connect" is used instead.
After adding the shell command "Open", LBC was able to launch my RDP-Sessions again. Hooray!!  Thmbsup
In Win XP this can be achieved by using the file and folder options dialog. Simply create a new action "Open" by using the same entries as the default action "Connect".
In Win7, and I think in Vista too, this way can't be used any more. A big "thank you" to Redmond! 
The following way isn't very hard, but it changes the registry directly!!! Do this only, if you know what you are doing!!! Use it at your own risk!!!
I exported the corresponding registry entries under "HKEY_CLASSES_ROOT\RDP.File\shell\Connect" to a file, changed every "Connect" to "Open" in it and finally imported the file.
This is the content of the REG-File that I've used:
[copy or print]
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\RDP.File\shell\Open]
@="Open"
"MUIVerb"=hex(2):40,00,25,00,73,00,79,00,73,00,74,00,65,00,6d,00,72,00,6f,00,\
  6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,\
  00,6d,00,73,00,74,00,73,00,63,00,2e,00,65,00,78,00,65,00,2c,00,2d,00,34,00,\
  30,00,30,00,32,00,00,00

[HKEY_CLASSES_ROOT\RDP.File\shell\Open\command]
@="mstsc.exe \"%1\""
Logged
mouser
First Author
Administrator
*****
Posts: 33,285



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #6 on: February 03, 2012, 03:51:56 PM »

Nice investigation and solution!  thumbs up

Could it also be solved by right-clicking on an rdp file in widows explorer and saying "open with -> (always) ->" and the mstsc.exe?
Logged
hornsts
Participant
*
Posts: 21


View Profile Give some DonationCredits to this forum member
« Reply #7 on: February 07, 2012, 07:12:48 AM »

This would have been a nice and easy fix. But at least in Win7 it doesn't seem to work this way.
I assume, that RDP-connections as a part of the OS are somehow preconfigured with the default action "connect" on opening RDP-files. So "open with.." is always interpreted as "connect" and no shell command "open" will be created in the registry. But without this LBC's quickdoclauncher.exe isn't able to "launch" RDP-Files.
Anyway I'm not sure, if changing the OS default action from "connect" to (always) "open" (with...) would be a good solution.  undecided
Logged
Pages: [1]   Go Up
  Reply  |  New Topic  |  Print  
 
Jump to:  
   Forum Home   Thread Marks Chat! Downloads Search Login Register  

DonationCoder.com | About Us
DonationCoder.com Forum | Powered by SMF
[ Page time: 0.031s | Server load: 0.11 ]