Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 10, 2016, 06:27:58 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Hanging behavior -- FARR Problem?  (Read 4091 times)

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,143
  • Slartibartfarst
    • View Profile
    • Donate to Member
Hanging behavior -- FARR Problem?
« on: November 12, 2011, 12:31:59 AM »
Possible FARR problem?
I thought I should note that FARR has been occasionally hanging on my laptop, with no error messages.
When it does this, it leaves a sort of ghostly oblong button at about 1pm on the screen near the top of the Desktop image. The button seems to push through faintly (is on top?) of all opened window layers.

I just kill the process and restart it when that happens.

One associated symptom is that some of my newly-started proggies don't start up and seem to be delayed in a queue whilst FARR s hanging like this. Killing the FARR process sometimes seems to unblock the queue and the queued processes then belatedly run.
« Last Edit: November 12, 2011, 10:10:27 PM by mouser »

anandcoral

  • Honorary Member
  • Joined in 2009
  • **
  • Posts: 410
    • View Profile
    • App, to help you : Overlap Wallpaper, Park Cursor Aside, Stick A Note, Merge CSV and Text and many more.
    • Donate to Member
Re: Hanging behavior -- FARR Problem?
« Reply #1 on: November 12, 2011, 01:20:42 AM »
@IainB, it looks like there are many folders/files in "Search Folder" Options of FARR. So it is taking long time to load the relevant ones from these.

Try reducing the folders/files or add 'file extension' like 'exe' only to read from the folder. This may reduce the FARR load time and leave others for the queue. I once had similar problem and doing the above helped it.

Regards,

Anand



IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,143
  • Slartibartfarst
    • View Profile
    • Donate to Member
Re: Hanging behavior -- FARR Problem?
« Reply #2 on: November 12, 2011, 03:13:41 AM »
@anandcoral: Thanks for the suggestion, but I don't see how that can be it because FARR hangs whilst it is idle -  doing nothing - i.e., not searching.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,435
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Hanging behavior -- FARR Problem?
« Reply #3 on: November 12, 2011, 07:39:59 AM »
I'm going to split this issue off into its own thread, Iain.

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,143
  • Slartibartfarst
    • View Profile
    • Donate to Member
Re: Hanging behavior -- FARR Problem?
« Reply #4 on: November 12, 2011, 08:48:44 PM »
@mouser: Thanks.
Do bear in mind that I'm not certain that it is necessarily a FARR-related issue anyway. It may be that something else I have configured in my system is knocking FARR out.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,435
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Hanging behavior -- FARR Problem?
« Reply #5 on: November 12, 2011, 10:11:09 PM »
One thing i'd like you to try is to go to the General options tab.  If you have it set to "stay in memory longer", try setting that to "Average memory use" and see if that helps.

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,143
  • Slartibartfarst
    • View Profile
    • Donate to Member
Re: Hanging behavior -- FARR Problem?
« Reply #6 on: November 13, 2011, 03:16:49 AM »
I have done that - changed the setting. Then I exited FARR and restarted it for good measure. Will report back if/when this odd hanging recurs.
« Last Edit: November 13, 2011, 05:13:35 AM by IainB »

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,143
  • Slartibartfarst
    • View Profile
    • Donate to Member
Re: Hanging behavior -- FARR Problem?
« Reply #7 on: November 18, 2011, 08:51:44 PM »
OK. FARR hung last night on me and again today.
Same symptoms as already described.
Kill the process and restart is an effective workaround.

Here is a screen clip of the ghostly button poking through, taken today (2011-11-19, 13:05hrs):
19_408x161_BF165C2C.png

I had just used FARR:
Pressed Pause (hotkey to open FARR).
Select button for Services.msc
May have left FARR in an "open" window state.
Did something in Services.
Noticed some time later (maybe about 10+mins) that FARR was not responding to Pause key.
Took the screen clip at 2011-11-19, 13:05hrs.
Brought up WTM , killed the FARR process and started it normally via its QuickLaunch icon.

Sorry I can't add more of use.
Still unsure whether this is a FARR problem or whether FARR's hanging is symptomatic of some other causal problem.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,435
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Hanging behavior -- FARR Problem?
« Reply #8 on: November 18, 2011, 08:57:46 PM »
Can you post a screenshot of the "Launching Files" tab in your FARR options.

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,143
  • Slartibartfarst
    • View Profile
    • Donate to Member
Re: Hanging behavior -- FARR Problem?
« Reply #9 on: November 19, 2011, 03:18:27 AM »
Here it is:
19_729x531_FFCD543F.png

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,143
  • Slartibartfarst
    • View Profile
    • Donate to Member
Re: Hanging behavior -- FARR Problem?
« Reply #10 on: December 06, 2011, 03:13:03 AM »
Another of these strange "hangs" again today with the same "ghost" button symptom.
I had not been using FARR that much.
The last thing I had done in FARR before the hang  was to launch some proggies, then exited the FARR display.
Same workaround used.
There was some general system instability though (e.g., PAUSE hotkey for FARR did not work, CHS misbehaving) so I rebooted the laptop.
All came back up OK.

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,143
  • Slartibartfarst
    • View Profile
    • Donate to Member
Re: Hanging behavior -- FARR Problem?
« Reply #11 on: December 19, 2011, 04:12:36 AM »
Just reporting another couple of these odd FARR hangs - one about a week ago, and one yesterday.
Same symptoms. Same workaround. Except the OS (well, Windows Explorer) seemed unstable yesterday, even after I had restarted WE.
So I rebooted and the problem went away.

I don't see why this would necessarily be a FARR-caused problem. On the other hand, I don't see what could be causing it either. There's no apparent pattern that I can see, and I cannot deliberately make the problem repeat.

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,143
  • Slartibartfarst
    • View Profile
    • Donate to Member
Re: Hanging behavior -- FARR Problem?
« Reply #12 on: February 12, 2012, 04:04:40 AM »
Just reporting another couple of these odd FARR hangs...
As at 2012-02-12 2300hrs, I have had no further evidence of these FARR hangs since making the above post.
There have been a lot of system changes made to my laptop's configuration in the meantime.
Looks like the causal problem has "gone away" and may have been nothing to do with FARR anyway.