ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE.

Main Area and Open Discussion > General Software Discussion

Taking ownership of files ... confused, irritated & discombobulated

<< < (3/5) > >>

I assume you are booting from some other drive than the one with the problem. Potentially, it could be the part of the disk where the permissions for those folders are stored that is defective. On the other hand it could be something else like a defective cable too.

If it is an actual harddisk failure, you could try your luck with GetDataBack. The free download will allow you to check if you can read the files with it before you buy.

There are a number of such applications, the reason I suggest this one is that it has saved me in the past.

Oh, no, I should have been more clear.

These are both external drives, USB connections.  Both Fantom Green Drives, a 1 TB (the recipient) and a 2 TB (the recalcitrant donor) :D.

I'll take a look at GetDataBack ... might be worth having for other occasions, as well  :up:. 

[Bleary-eyed, staggers off to bed <yawn />.]

Stoic Joker:
One of the more interesting gotchas that tends to manifest at times like this is name length. If you have long folder names that accumulate into a really long path name, the copy/move operation will trip over it with a (rather erroneous) permissions error (e.g. The Whole (mess) really is the sum of its (name length) parts).

The work around is to try moving part of the subdirectory tree (out of the uber path) to the root of the same drive, which actually only updates the file pointers, so the files can then be accessed. Either that or try renaming the folders to shorten up the overall path name.

I've frequently tried moving the hole tree to see what/where it was failing, and then just renamed that target to "stitch" things back together. If the user had a really complicated (convoluted) file system. But if it's dying out of the gate - safe bet - the probled lies at the (assumed alphabetical) top of the folder structure. For this you can either try moving random folders one at a time, or sort the explorer folder view by something else and see if it'll get started (from that "angle") then.

[Still bleary-eyed <Yawn />, but semi-awake again <yawn />.]

Yeah, that path too long beastie has bitten me more than once  :o.  However, that particular nasty comes not into play in this instance, at least not by visible character count  :D.  I've seen reference recently to software - SourceForge, I thimk - that addresses that issue, examines source(s) and target(s) for just that issue.  TLPD maybe?  Or am I extrapolating that from TL;DR?  Memory fails.

Hm-m-m ... cannot access the files even to play w/VLC, but hadn't considered changing sort order ... don't think it'll do anything beneficial, but any straw ...

Nope, still get, "You require permission ..." for anything in the _vid directory  :(.  And still get, "This is no longer located ...," for the _win directory  :mad:.  Still cannot tell if this is a true Win permissions problem, or a problem with the drive, although I suspect the latter.  Guess I'm gonna hafta try GetDataBack or one of its kin  :-\.

To rescue data on HDD with bad sector, the best tool to use is Norton Ghost. In your case I think you can get back almost all of your data, but you will need a pair of 1TB HDD. With the right setting, Ghost the whole HDD (the one with bad sectors) to a 1TB HDD then restore it to another 1TB HDD. That is it.

I have witness a 2 days non-stop backup of a bad sector HDD (its condition is much worse than yours) by Norton Ghost, the result is a full reclaim of all data... it is simply that powerful.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version