Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 07, 2016, 06:29:47 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Need Help Understanding CHS Behavior  (Read 1500 times)

deepskytraveler

  • Member
  • Joined in 2011
  • **
  • Posts: 23
    • View Profile
    • Donate to Member
Need Help Understanding CHS Behavior
« on: October 04, 2011, 02:55:41 PM »
I recently stumbled on CHS while searching for a method to log a date/time stamp for clipboard captures. CHS seems to be ideal for my needs however in testing it I'm experiencing behavior that I don't understand. Being a CHS newbie I'm guessing it is either a key principle I don't understand or some setting that needs adjusted.

I'm using a purchased program called MegaStar. The program presents a graphical display that is a star map. When you left click on an object a window pops up containing data about that object. With the data window in focus when you right click you get a context menu that includes an task to copy-to-clipboard which captures the object data in the window to the clipboard. Note that you are not able to select the text in this window and copy it with a control-c. The program intercepts a control-c and to capture a printable version of the graphic window.

With that background here is the behavior I'm experiencing consistently with CHS and its default settings. CHS seems to log only the odd number captures (that is selecting the menu option on the object data box to copy to clipboard). So the first, third, fifth copies are logged, but not the second and fourth. I thought it coulb be a timing issue but the behavior is the same whether the subsequent copy-to-clipboard is seconds after the previous one or minutes.

Hopefully I've explained the problem well enough so that someone will be able to provide some suggestions. I recall there being one or more timing settings for CHS but I'm not entirely clear on their purpose. BTW, I've tried this on both XP SP2 and Win7 Ultimate with the same results.

Mark

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,408
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Need Help Understanding CHS Behavior
« Reply #1 on: October 04, 2011, 03:07:49 PM »
I'm having a little bit of trouble following what exactly is happening.

Are you saying that you are copying images to the clipboard, and CHS is ignoring every other image copies to the clipboard, even though all images are being copied to the clipboard by the other program?  Or are you saying CHS is grabbing something, but not the right image?

Sounds like a fairly simple bug to track down if i can get my head around what's going on..

Can you try a test? Between triggers of the image copy that you are interested in, if you select some text in another program and ctrl+C to copy it to clipboard, does CHS then get every image?

And can you verify in another image program that even though CHS is ignoring every other capture -- that your megastar program is actually copying every image to the clipboard?

deepskytraveler

  • Member
  • Joined in 2011
  • **
  • Posts: 23
    • View Profile
    • Donate to Member
Re: Need Help Understanding CHS Behavior
« Reply #2 on: October 04, 2011, 04:19:53 PM »
And can you verify in another image program that even though CHS is ignoring every other capture -- that your megastar program is actually copying every image to the clipboard?

Went through the test cases you suggested. Problem solved - kinda. It isn't with CHS.  :)  I went through a sequence of "copy-to-clipboard" menu tasks in MegaStar without CHS loaded. After each copy I pasted the clipboard contents into a Word document. Guess what? The clipboard is consistently empty on the odd number captures. Mostly likely a MegaStar bug. Thanks for your suggestions which helped me isolate the source of the problem.

Mark

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,408
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Need Help Understanding CHS Behavior
« Reply #3 on: October 04, 2011, 04:22:49 PM »
 :up: