Welcome Guest.   Make a donation to an author on the site July 28, 2014, 03:19:33 AM  *

Please login or register.
Or did you miss your validation email?


Login with username and password (forgot your password?)
Why not become a lifetime supporting member of the site with a one-time donation of any amount? Your donation entitles you to a ton of additional benefits, including access to exclusive discounts and downloads, the ability to enter monthly free software drawings, and a single non-expiring license key for all of our programs.


You must sign up here before you can post and access some areas of the site. Registration is totally free and confidential.
 
The N.A.N.Y. Challenge 2010! Download 24 custom programs!
   
   Forum Home   Thread Marks Chat! Downloads Search Login Register  
Pages: [1]   Go Down
  Reply  |  New Topic  |  Print  
Author Topic: Bug? Arrow Endpoint Text very slow  (Read 4373 times)
johnfdeluca
Charter Member
***
Posts: 81


View Profile Give some DonationCredits to this forum member
« on: August 19, 2011, 09:22:42 AM »

Let me start by saying that I love this tool....it's wy I joined Donation Coder several years ago and I use SC just about every day.  I am expereincing a new issue that I hadn't seen before and a search on this forum reveals no hits.  I often use the arrow tool to point someting out in a screenshot and when I start typing endpoint text, it is very slow to 'paint' the text into the screenshot.....taking several seconds per character.  Any ideas?

Windows XP SP3
Screenshot Captor v2.95.02 by DonationCoder

My workaround is to type the text in another app, then copy/paste into the endpoint text field in SC.
Logged
mouser
First Author
Administrator
*****
Posts: 33,183



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #1 on: August 19, 2011, 09:57:18 AM »

i've noticed this once before too..
it may have to do with antialiasing kicking in with screenshot magnification not at 100%.

can you check this option and see if it helps:


oh and also (more importantly):
Logged
johnfdeluca
Charter Member
***
Posts: 81


View Profile Give some DonationCredits to this forum member
« Reply #2 on: August 19, 2011, 10:36:18 AM »

I checked both options and they are the same as your screenshots but it is still very slow.  I should clarify that it's not just slow to paint....but also slow to even show the typed characters in the endpoint text entry field in the options.  If you can think of anything else that might address this, let me know....I've uninstalled and reinstalled SC to see if that did the trick and it did not.
Logged
mouser
First Author
Administrator
*****
Posts: 33,183



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #3 on: August 19, 2011, 11:05:19 AM »

does it happen on every screenshot when you try to add an arrow, or only one?
does it happen even if magnification is at 100%?
if you drag the arrow around is that super slow also?
« Last Edit: August 19, 2011, 11:10:26 AM by mouser » Logged
johnfdeluca
Charter Member
***
Posts: 81


View Profile Give some DonationCredits to this forum member
« Reply #4 on: August 19, 2011, 11:09:34 AM »

Every screenshot at all mag levels, including 100%.
Logged
mouser
First Author
Administrator
*****
Posts: 33,183



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #5 on: August 19, 2011, 11:14:52 AM »

very odd.. it definitely shouldn't be so slow, so it's a bug somewhere.. but where.

i still suspect the antialiasing routines.  can you tell if antialiasing is disabled when you are typing text? the way to check is to compare the look when you are typing text for the arrow against what the screenshot looks like after you disable object editing mode (by clicking the button with the O and arrow).
Logged
johnfdeluca
Charter Member
***
Posts: 81


View Profile Give some DonationCredits to this forum member
« Reply #6 on: August 19, 2011, 11:36:19 AM »

The text doesn't appear to undergo any difference visually wile typing vs. clicking o+arrow.

Attacments of objects and ini.

* Screenshot - 8_19_2011 , 11_31_47 AM.zip (103.19 KB - downloaded 56 times.)
* ScreenshotCaptorTools.zip (3.68 KB - downloaded 58 times.)
Logged
mouser
First Author
Administrator
*****
Posts: 33,183



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #7 on: August 19, 2011, 11:42:09 AM »

ok first result is -- with my screenshto captor settings and your screenshot+object i can edit that arrow text very rapidly.

so..  now to figure out what is it about your settings or setup that makes it slow..

i will try your screenshot captor ini file now..

even with your screenshotcaptor.ini file the text edits very quickly.

i'm going to email you my current screenshotcaptor.exe file just so we can make sure there isnt something up with that.
Logged
Deozaan
Charter Member
***
Posts: 6,258



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #8 on: August 21, 2011, 10:19:47 PM »

I just want to chime in and say that I've experienced this as well. But that was on my old slow computer so I thought it was a symptom of my PC being really bad.

I just got SC reinstalled on this new PC and haven't used the arrow text yet so I'm not sure if it will happen to me again.
Logged

lanux128
Global Moderator
*****
Posts: 6,087



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #9 on: August 22, 2011, 01:27:27 AM »

i used to have this problem but mouser fixed it through one of the updates, can't remember which one. i suggest deleting/renaming the ini file and make sure to have the latest version. also the number of images in the screenshot folder might have an impact, though i'm not sure.
Logged

mouser
First Author
Administrator
*****
Posts: 33,183



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #10 on: August 25, 2011, 09:39:56 AM »

John,

I just managed to reproduce this.  It's definitely a bug, and it's definitely related to SC trying to anti-alias the text while you are editing it -- even when you tell it not to.  Seems that for some random reason sometimes high-quality anti-aliasing is being enabled during editing.

Working on a fix now.
Logged
johnfdeluca
Charter Member
***
Posts: 81


View Profile Give some DonationCredits to this forum member
« Reply #11 on: August 25, 2011, 10:21:48 AM »

Awesome....glad you were able to replicate the issue.  Looking forward to a fix!
Logged
mouser
First Author
Administrator
*****
Posts: 33,183



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #12 on: August 26, 2011, 02:01:32 AM »

Can you try this version:
http://www.donationcoder....ScreenshotCaptorSetup.exe

Hopefully it will not only fix the slowdown bug but also speed up editing of the text from what it was before and improve the look of anti-aliased text (especially in memo boxes) when you use the default settings to anti-alias when not editing.

Let me know!
Logged
johnfdeluca
Charter Member
***
Posts: 81


View Profile Give some DonationCredits to this forum member
« Reply #13 on: August 26, 2011, 07:55:01 AM »

Much faster with endpoint text tho still a minor lag for me (checked my settings to ensure they were right based on your previous feedback).  Vast improvement though, thanks!
Logged
mouser
First Author
Administrator
*****
Posts: 33,183



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #14 on: August 28, 2011, 04:34:50 AM »

I see something else that could still be slowing it down.. Ill upload another beta soon.
Logged
mouser
First Author
Administrator
*****
Posts: 33,183



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #15 on: August 28, 2011, 04:52:07 AM »

Can you try the new beta (same url: http://www.donationcoder....ScreenshotCaptorSetup.exe) and tell me if this performs a little better with regard to arrow text editing speed.

Note: this version also changes the connection points for labeled arrows, as well as memo box transparency method.
Logged
mouser
First Author
Administrator
*****
Posts: 33,183



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #16 on: August 30, 2011, 06:12:42 AM »

Well.. how's the new version?
Logged
mouser
First Author
Administrator
*****
Posts: 33,183



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #17 on: September 02, 2011, 03:53:17 PM »

tap.. tap... is this thing on?
Logged
johnfdeluca
Charter Member
***
Posts: 81


View Profile Give some DonationCredits to this forum member
« Reply #18 on: September 06, 2011, 09:22:05 AM »

Sorry.....I was on vacation.  Will download, test and provide feedback once I get a few free mins.
Logged
johnfdeluca
Charter Member
***
Posts: 81


View Profile Give some DonationCredits to this forum member
« Reply #19 on: September 06, 2011, 10:53:42 AM »

Just tried it (new version above) and it is very slow again.....like really slow.  Checked options and they are set properly per your previous suggested values.
Logged
mouser
First Author
Administrator
*****
Posts: 33,183



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #20 on: September 06, 2011, 11:00:27 AM »

crap  Angry thumb down

I just don't understand it Sad

Is there any way you could make a screencast showing you selecting an image with arrow text, then editing the arrow text and showing the slowness?

The main thing i really need to see is if the font is trying to anti-alias while you are typing.

I may have to upload a test version too that can output some debug information for me to check on.

I just wish i understood what was going on.

Anyone else experiencing slow arrow text editing with the new beta version?
« Last Edit: September 06, 2011, 11:04:29 AM by mouser » Logged
mouser
First Author
Administrator
*****
Posts: 33,183



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #21 on: September 06, 2011, 11:06:10 AM »

And maybe attach again an image which exhibits the slow editing behavior with the new version?
Perhaps i can replicate it again..
Logged
mouser
First Author
Administrator
*****
Posts: 33,183



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #22 on: September 06, 2011, 11:07:31 AM »

Does it help if on the Drawing Object Options tab you select "Anti-alias Object Display: Never" ?
Logged
mouser
First Author
Administrator
*****
Posts: 33,183



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #23 on: September 07, 2011, 12:02:43 PM »

Question -- do you have the shadow checkbox checked? if you uncheck it (on all arrows on the screenshot) does it solve the problem?
Logged
mouser
First Author
Administrator
*****
Posts: 33,183



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #24 on: September 07, 2011, 07:51:05 PM »

I just encountered the slow arrow text just now, randomly, right after making v2.99 live and after a week of trying everything i could to trigger it.
So clearly the bug is still lurking about -- and i'm back on the hunt for it.


Note that it's definitely (my occurrences of it at least) a very random thing -- going in and out of object mode or doing various things makes the problem completely go away).
« Last Edit: September 07, 2011, 08:34:34 PM by mouser » Logged
Pages: [1]   Go Up
  Reply  |  New Topic  |  Print  
 
Jump to:  
   Forum Home   Thread Marks Chat! Downloads Search Login Register  

DonationCoder.com | About Us
DonationCoder.com Forum | Powered by SMF
[ Page time: 0.063s | Server load: 0.21 ]