Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 08, 2016, 02:15:58 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: %MYRECENTDOCS% not working?  (Read 2576 times)

AStroP

  • Participant
  • Joined in 2005
  • *
  • default avatar
  • Posts: 10
    • View Profile
    • Donate to Member
%MYRECENTDOCS% not working?
« on: August 09, 2011, 08:01:23 PM »
Here on my PC (Win7Pro 32Bit, FARR 2.99.02) the virtual folder/variable replacement %MYRECENTDOCS% in "Options > Lists > Search Folders" doesn't seem to work. When I specify the absolute path C:\Users\<MyUsername>\AppData\Roaming\Microsoft\Windows\Recent everything works ok. Does anybody have the same problem?

Eóin

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 1,401
    • View Profile
    • Donate to Member
Re: %MYRECENTDOCS% not working?
« Reply #1 on: August 09, 2011, 10:56:46 PM »
Well you can check and change the various Environment Variables (that's what those %whatever% are) through "Control Panel" > "System" > "Advanced System Setting" > "Environment Variables". With that you can see what it's currently set to and change it accordingly.

To make the job easier I'd recommend Rapid Environment Editor. Personally I use it whenever I need to mess those variables.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,416
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: %MYRECENTDOCS% not working?
« Reply #2 on: August 09, 2011, 11:10:57 PM »
You are right, the code to use it was missing from FARR; i've fixed it in my version, it will be in the next update.  Thanks for the report.

AStroP

  • Participant
  • Joined in 2005
  • *
  • default avatar
  • Posts: 10
    • View Profile
    • Donate to Member
Re: %MYRECENTDOCS% not working?
« Reply #3 on: August 10, 2011, 12:00:53 AM »
[...] Thanks for the report.

It's just the other way round - I have to thank you!  :)

Eóin

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 1,401
    • View Profile
    • Donate to Member
Re: %MYRECENTDOCS% not working?
« Reply #4 on: August 10, 2011, 07:23:53 AM »
Oops, my bad, didn't realise this was a FARR specific question :-[

phitsc

  • Honorary Member
  • Joined in 2008
  • **
  • Posts: 1,187
    • View Profile
    • Donate to Member
Re: %MYRECENTDOCS% not working?
« Reply #5 on: August 10, 2011, 09:59:04 AM »
Well you can check and change the various Environment Variables (that's what those %whatever% are) through "Control Panel" > "System" > "Advanced System Setting" > "Environment Variables". With that you can see what it's currently set to and change it accordingly.

To make the job easier I'd recommend Rapid Environment Editor. Personally I use it whenever I need to mess those variables.

Seems like a useful tool to have. Thanks for mentioning it :)

AStroP

  • Participant
  • Joined in 2005
  • *
  • default avatar
  • Posts: 10
    • View Profile
    • Donate to Member
Re: %MYRECENTDOCS% not working?
« Reply #6 on: October 03, 2011, 09:09:55 PM »
You are right, the code to use it was missing from FARR; i've fixed it in my version, it will be in the next update.  Thanks for the report.

Many thanks for the fix!  :Thmbsup: