Welcome Guest.   Make a donation to an author on the site September 02, 2014, 11:50:04 PM  *

Please login or register.
Or did you miss your validation email?


Login with username and password (forgot your password?)
Why not become a lifetime supporting member of the site with a one-time donation of any amount? Your donation entitles you to a ton of additional benefits, including access to exclusive discounts and downloads, the ability to enter monthly free software drawings, and a single non-expiring license key for all of our programs.


You must sign up here before you can post and access some areas of the site. Registration is totally free and confidential.
 
The N.A.N.Y. Challenge 2013! Download dozens of custom programs!
   
   Forum Home   Thread Marks Chat! Downloads Search Login Register  
Pages: [1]   Go Down
  Reply  |  New Topic  |  Print  
Author Topic: MS Word Spell Checker - Selective Failure  (Read 3217 times)
Stoic Joker
Honorary Member
**
Posts: 5,218



View Profile WWW Give some DonationCredits to this forum member
« on: May 24, 2011, 02:27:31 PM »

Okay, so a client sends me a Word document (.docx) that has some spelling errors in it that Spell Check isn't finding. The errors are reasonably obvious and don't result in the creation of another different/shorter word. They are indeed, wrong. But completely undetected.

To eliminate anything application instance or document related I copied just the one word to a new Word document...And Spell Check ignored that one too. Here's a screen-shot to save time and typing:


Pressing F7 (force full check) still misses the same bad word. Ignore word X only lasts - or is only supposed to last - until the line it's on changes...But that is not the case here. So I added a bit more garbage text to better dramatize the issue:


...So, does anybody have any idea how the hell that happened?
Logged
tranglos
Supporting Member
**
Posts: 1,079



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #1 on: May 24, 2011, 02:33:13 PM »

Is the language set correctly for the text? Have you tried Ctrl+A then set language (on the Review tab)?
Logged

Stoic Joker
Honorary Member
**
Posts: 5,218



View Profile WWW Give some DonationCredits to this forum member
« Reply #2 on: May 24, 2011, 02:49:36 PM »

Is the language set correctly for the text? Have you tried Ctrl+A then set language (on the Review tab)?

Yes, language is correct for the document. I also tried resetting it just to be sure. It had no effect.

The word in question, hurricane, is the main topic of the 20 page document...And is therefore used repeatedly. If I go up or down one paragraph from this block of text, spell check will again recognize the missspelling (much like the screen shot). But on this one line it just don't matter what you put in there ... Spell Check completely ignores it.
Logged
Ath
Supporting Member
**
Posts: 2,202



see users location on a map View Profile WWW Give some DonationCredits to this forum member
« Reply #3 on: May 24, 2011, 03:09:43 PM »

Where did you copy it from? Another Word document, or plain text?

Could you reset the attributes to the default (select + Ctrl-Space) that usually works if I have issues like these, or paste it as plain text (using Notepad++ as an intermediate, but there are several tools discussed here, that I don't want to install on my work-PC, that can do that for you).
Logged

mwb1100
Supporting Member
**
Posts: 1,298


View Profile Give some DonationCredits to this forum member
« Reply #4 on: May 24, 2011, 03:55:38 PM »

The language (which is where spell checking can be disabled) for the the paragraph can also be specified in a style - I'm not sure if setting the language for the whole document will override a setting that's in a style applied to a paragraph or selection.  So check the style applied to the paragraph/selection of text as well.


Edit: I just checked - setting the language (and clearing the "do not spell check box") when the whole document is selected will override the style.  So my suggestion provides no value over tranglos'.


« Last Edit: May 24, 2011, 04:04:33 PM by mwb1100 » Logged
Stoic Joker
Honorary Member
**
Posts: 5,218



View Profile WWW Give some DonationCredits to this forum member
« Reply #5 on: May 24, 2011, 04:00:20 PM »

Where did you copy it from? Another Word document, or plain text?

Yes, it's from another Word document that was originally exibiting to odd behavior.

Could you reset the attributes to the default (select + Ctrl-Space) that usually works if I have issues like these, or paste it as plain text (using Notepad++ as an intermediate, but there are several tools discussed here, that I don't want to install on my work-PC, that can do that for you).

There's a lot of work in this perticular 20 page document, so stripping the formatting was the option the client was trying to avoid.

I'll have to play with and remember that hot key...Sounds interesting.
Logged
Stoic Joker
Honorary Member
**
Posts: 5,218



View Profile WWW Give some DonationCredits to this forum member
« Reply #6 on: May 24, 2011, 04:04:08 PM »

Is the language set correctly for the text? Have you tried Ctrl+A then set language (on the Review tab)?

Yes, language is correct for the document. I also tried resetting it just to be sure. It had no effect.

Correction, It didn't have any effect, until I did it a 2nd time. So either it needed to be pounded into the documents little head... *Shrug* ...Or I did it wrong the first time (not sure).

But it is at this point resolved. Thank you.
Logged
Stoic Joker
Honorary Member
**
Posts: 5,218



View Profile WWW Give some DonationCredits to this forum member
« Reply #7 on: May 24, 2011, 04:08:47 PM »

I'm not sure if setting the language for the whole document will override a setting that's in a style applied to a paragraph or selection.

When I tried it again (with Office 2007) at the clients location it worked fine the first time. I've got Office 2010 at the office but may have missed something the first time (Not sure). But yes the Ctrl + A (whole document at once) language correction does (or rather did) work.
Logged
fenixproductions
Honorary Member
**
Posts: 1,169



see users location on a map View Profile WWW Give some DonationCredits to this forum member
« Reply #8 on: May 24, 2011, 04:33:44 PM »

@Stoic Joker
I had similar issue at work and setting whole document language was not always working.
Solution: Review -> Set Language -> Detect language automatically -> OFF

BTW If you encounter similar issues with PowerPoint you will need special macro to fix it.
Logged

Надо было учиться, а не камни в школу бросать...
--
When I am bored I write for displaynone smiley
--
f0dder is my personal hero smiley
Stoic Joker
Honorary Member
**
Posts: 5,218



View Profile WWW Give some DonationCredits to this forum member
« Reply #9 on: May 24, 2011, 05:03:31 PM »

Solution: Review -> Set Language -> Detect language automatically -> OFF

Hm... Ya know, I do recall doing that now that you mention it. Not sure if I did it the first time, but I do recall doing it the 2nd time. So I believe you're correct in that allowing Word to guess the language is bad.
Logged
eleman
Supporting Member
**
Posts: 268

see users location on a map View Profile Give some DonationCredits to this forum member
« Reply #10 on: May 25, 2011, 03:13:50 AM »

You may also have inadvertently added the word Hurricne to the dictionary. Check your custom.dic (tools, options, spelling & grammar, custom dictionaries, modify).
Logged
Pages: [1]   Go Up
  Reply  |  New Topic  |  Print  
 
Jump to:  
   Forum Home   Thread Marks Chat! Downloads Search Login Register  

DonationCoder.com | About Us
DonationCoder.com Forum | Powered by SMF
[ Page time: 0.033s | Server load: 0.11 ]